LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-12-2004, 02:32 PM   #1
tomfilip
LQ Newbie
 
Registered: Sep 2004
Posts: 1

Rep: Reputation: 0
Question dell inspiron 8600 keyboard problem


hi,

im kind of new to linux, but i have a dell inspiron 8600 laptop with gentoo on it. the problem is special keys like apostrophes, quotes, tildas, etc. - they dont work whenever i am in X (in the console it works just fine). i have to hit the apostrophe key twice to get something resembling an apostrophe (but say in NetBeans, it displays some completely b/s character). after a while it gets annoying, and i have no clue where to fix this. does anyone have any ideas?

btw. heres a chunk of my XFree86 file:



Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "USB Mouse" "CorePointer"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

id really appreciate any help. thanks in advance,

tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard problem om DELL Inspiron 8600 guckusko Linux - Laptop and Netbook 0 10-06-2005 12:41 PM
Nvidia problem with Suse 9.2 on Dell Inspiron 8600 laptop c_anindya Suse/Novell 3 01-08-2005 07:55 PM
Nvidia problem with Suse 9.2 on Dell Inspiron 8600 laptop c_anindya Linux - General 0 01-04-2005 07:06 AM
Nvidia problem with Suse 9.2 on Dell Inspiron 8600 laptop c_anindya Linux - Laptop and Netbook 1 01-04-2005 04:43 AM
External Display Problem on Dell Inspiron 8600 w/ nVidia card and Redhat 9 jeetasher Linux - Laptop and Netbook 0 07-16-2004 01:14 PM


All times are GMT -5. The time now is 09:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration