LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 11-16-2012, 10:21 AM   #1
Enkhbayar
LQ Newbie
 
Registered: Dec 2010
Posts: 7

Rep: Reputation: 0
debian 6.0.6 screen mess on laptop with eDP display


I installed Ubuntu 11 on dell e6410 laptop and almost all worked just fine,
also successfully installed Debian(with GUI wizard, debian-6.0.6-amd64-DVD-1.iso), but can't get the screen work properly.

after grub information show correctly, the Linux bootstrap begins to mess up.

I connected a second monitor, logged in and got xrandr command result.
xrandr result under Debian
Code:
Screen 0: minimum 320 x 200, current 2464 x 900, maximum 8192 x 8192
DP-1 connected 1440x900+1024+0 (normal left inverted right x axis y axis) 303mm x 189mm
   1440x900       40.0* 
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 312mm x 234mm
   1024x768       85.0*+   75.1     70.1     60.0  
   1280x1024      60.0  
   1152x864       75.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     66.7     60.0  
   720x400        70.1  
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
ubuntu 11.04's result is
Code:
Screen 0: minimum 320 x 200, current 2464 x 900, maximum 8192 x 8192
eDP-1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 189mm
   1440x900       60.0*+   40.0  
   1152x864       60.0  
   1024x768       59.9  
   800x600        59.9  
VGA-1 connected 1024x768+1440+0 (normal left inverted right x axis y axis) 312mm x 234mm
   1024x768       85.0*+   75.1     70.1     60.0  
   1280x1024      60.0  
   1152x864       75.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     66.7     60.0  
   720x400        70.1  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
I've tried many resolution and many refresh rate, and with gtf and cvt timing with "xrandr" command on the laptop display all don't work under Debian.

Debian thinks the display is on DP port, but Ubuntu recognizes it as eDP(embedded DP according to Wikipedia), and listed some of the screen's compatible resolutions. it seems this caused the problem.

so how to fix such situation? export some settings from Ubuntu to Debian? or install some driver like windows? I'm new to Linux, thanks in advance.
 
Old 11-17-2012, 11:35 PM   #2
Enkhbayar
LQ Newbie
 
Registered: Dec 2010
Posts: 7

Original Poster
Rep: Reputation: 0
after this i've also tried using nVidia's binary driver, which in text mode on half way of installation encountered some error, said that not sure about the compiler version(cc) and i aborted, I don't know what those are.

and then i run the binary with argument --uninstall, the wizard tell me no driver was installed. but afer reboot, the display showed picture in very basic performance on laptop screen(1024 768, with all 2D window sluggish).

i guess this is caused by nvidia's driver changed the settings to the debian's default "nouveau" driver not in use, so some very basic driver is on.
I then removed the nouveau driver , and reinstalled, assume this should get back the nouveau and the snowy messy picture on laptop display. but this still didn't work, still in the basic graphic.
by the way, "dpkg-reconfigure xserver-xorg" or "dpkg-reconfigure xserver-xorg-video-nouveau" never worked, always back to command prompt with nothing instantly.

after all this done, the xrandr --prop, or xrandr never recognizes my laptop screen correctly again, even 1440x900 is not listed, and no screen EDID is listed.
the second monitor on VGA port didn't even listed under xrandr.


this version of Debian i installed is "stable" version. some said this is for servers, with older programs and less drivers.
"testing" versions are suitable for desktop users with newer features. am I on wrong way? I'm now downloading the "testing" version.
the debian on my laptop not only display issue, there are also sound problem, wifi problem by now.
 
Old 11-18-2012, 05:49 AM   #3
Enkhbayar
LQ Newbie
 
Registered: Dec 2010
Posts: 7

Original Poster
Rep: Reputation: 0
I installed Debian's testing version.
dual screen, sound, wired network worked, but WiFi.

the testing version's kernel is 3.2, and the stable version I previously installed is 2.6.3XX kernel.
the testing version include gnome 3 DE, which I don't like much, more desktop effects, less usability.
problems I encountered:
  1. mouse stops about every 10 second, like ubuntu 11, 12.
  2. there are no system -> preferences -> appearance, in which i can adjust dpi, and font rendering details, the default font rendering in the gnome 3's are likely rendering MS like clearlook style. I prefer heavier font.
  3. the Gnome-pannel in gnome2 is configurable, such as right click and add/remove items, and adjust size, put vertically on left or right side of the she screen, but in gnome3 the gnome-pannel have no such useful functionalities.
  4. I prefer gnome 2 + clearlook, it's clean and elegant. gnome 3's android like black stripe on top, and black popup messages, and some fancy transparent things are somehow annoying to me.

now i'm wondering how do i remove the gnome3 (I successfully removed it on a test machine), and install gnome 2.
 
Old 11-18-2012, 06:01 AM   #4
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
You dont just install the nVidia drivers, it reuqires some stuffing around. Try fllowing the debian guide on how to install nVidia drivers-

http://wiki.debian.org/NvidiaGraphicsDrivers

You wont get gnome 2.X running with debian 7 ('wheezy', currently frozen). You xcan try the modded/forked version of gnome 3, cinnamon-

http://en.wikipedia.org/wiki/Cinnamo...r_interface%29
http://cinnamon.linuxmint.com/

AFAIK there is no native debian installer for wheezy/cinnamon. I could be wrong on that, I dont follow cinnamon at all.

Or MATE, a gnome 2.X fork-

http://en.wikipedia.org/wiki/MATE_%2...environment%29
http://mate-desktop.org/

I'd try Xfce before either of them.
 
Old 11-18-2012, 06:35 PM   #5
Enkhbayar
LQ Newbie
 
Registered: Dec 2010
Posts: 7

Original Poster
Rep: Reputation: 0
thank you. I have just known that debian have squeeze wheezy and unstable, and there's such big compability issues.

I've tried mate-desktop, which is look like gnome2, but sometimes not as seamless as original gnome2.
what all the DE is about? AFAIK many linux programs are cross platform, so GNOME 2 is not even cross version? is the differences between squeeze and wheezy is about only kernel,..

btw, my last known hardware problem is WI-FI(intel AGN 6250). it asks for firmware from me, but ubuntu 11,12 didn't.
any suggestion on how to get it work?
 
Old 11-19-2012, 01:45 AM   #6
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally Posted by Enkhbayar View Post
AFAIK many linux programs are cross platform, so GNOME 2 is not even cross version? is the differences between squeeze and wheezy is about only kernel,..
Theres if far more differecnes than just the kernel.

The gnome foundation dropped gnome 2.X. All distros are slowly getting rid of gnome 2.X, and replacing it with gnome 3 or other DEs.

That is why there is MATE and cinnamon, theya re both efforts to keep the gnome 2.X look.

Quote:
Originally Posted by Enkhbayar View Post
btw, my last known hardware problem is WI-FI(intel AGN 6250). it asks for firmware from me, but ubuntu 11,12 didn't.
any suggestion on how to get it work?
http://wiki.debian.org/iwlwifi
 
Old 11-19-2012, 04:02 AM   #7
descendant_command
Member
 
Registered: Mar 2012
Posts: 796

Rep: Reputation: 180Reputation: 180
Quote:
Originally Posted by cascade9 View Post
You dont just install the nVidia drivers, it reuqires some stuffing around. Try fllowing the debian guide on how to install nVidia drivers-

http://wiki.debian.org/NvidiaGraphicsDrivers
No shagging about with DKMS method and it also updates the module with each future kernel change.
Quote:

I'd try Xfce before either of them.
+1
 
Old 11-19-2012, 11:10 PM   #8
Enkhbayar
LQ Newbie
 
Registered: Dec 2010
Posts: 7

Original Poster
Rep: Reputation: 0
yeah,
i've installed xfce by following debian's instructions. this DE is really clean and beautiful. and pannels are more easier to customize, even have vertical layout options. I almost use vertical arrangement of icons in everywhere as long as it is possible, like vertical taskbar in win7, vertical toolbar in libreoffice, vertical pane's in linux DE. because the screen is becoming shorter and shorter now days.

it's xfce 4.8 come with the debian, look like this
http://www.xfce.org/about/tour48

but i really prefer xfce 4.6 style, the most obvious window style difference is right up corner buttons. the 4.6's buttons are bigger, combined with the edge, easier to click.
http://www.xfce.org/about/tour46

in the "Appearance" dialog(application menu - settings - appearance ), style tab, there is a option of xfce-4.6 but it doesn't change window control buttons, but just change window title color.

there are too many themes on xfce-look.org, its hard to find xfce 4.6's stock theme since i don't know it's name.
any suggestions are appreciated.

Last edited by Enkhbayar; 11-19-2012 at 11:25 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my laptop mess up everytime i lock the screen? joeyrf Linux - Laptop and Netbook 4 04-01-2010 09:52 PM
hp compaq presario v3412tu no display on laptop screen, just external display y33_4nn Linux - Laptop and Netbook 2 02-08-2010 11:33 PM
X display won't fill screen - old laptop zekthedeadcow Slackware 7 09-27-2005 03:41 PM
Display Screen Error on Laptop Bootup cheetahman Suse/Novell 2 05-09-2005 02:10 PM
Sony Laptop Screen / Display Settings ebmaster Fedora 11 07-02-2004 10:44 PM


All times are GMT -5. The time now is 06:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration