LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 07-03-2007, 01:23 AM   #1
H-Radical
LQ Newbie
 
Registered: Dec 2006
Location: among the rich and powerful
Distribution: Ubuntu Edgy Eft
Posts: 17

Rep: Reputation: 0
Dead Screen on nVidia GeForce4 420 Go with Ubuntu Feisty Fawn


Hi all,

Just recently I upgraded from Ubuntu edgy to feisty. On edgy I had used http://doc.gwos.org/index.php/Latest...OBLEMS_SECTION to get my nVidia card working. The feisty installation kept my xorg.conf file, but now the screen goes completely dead (ie the monitor is off) when I load feisty. I tried the updated version of the same guide for feisty but it hasn't changed with regard to my hardware. I know from the log files that there's something wrong with the edid commands in the xorg.conf file, but I don't know how it should be fixed. I'm running feisty on a Sony Vaio pcg-grt100 laptop with nVidia GeForce4 420 Go. I can get the screen working with the nv drivers, but the quality is extremely low. I would appreciate any help on getting the nvidia driver working.

Thanks
 
Old 07-03-2007, 08:21 AM   #2
emi_ramo
Member
 
Registered: Apr 2007
Location: Barcelona, Spain
Distribution: Debian, KUbuntu
Posts: 213

Rep: Reputation: 36
If you upgraded the kernel, it's possible that you need to re-compile (or re-instal) the nvidia driver with nvidia-* utilities.

An advice: it's good to post your logs and/or config files when you post a question...
 
Old 07-03-2007, 03:01 PM   #3
H-Radical
LQ Newbie
 
Registered: Dec 2006
Location: among the rich and powerful
Distribution: Ubuntu Edgy Eft
Posts: 17

Original Poster
Rep: Reputation: 0
I don't know what you mean about updating nvidia-* utilities. The only one I ever used was nvidia-xconfig and I don't know what else there is. However, while I was trying to get the screen working, I went through the whole guide (posted above). I think I upgraded nvidia-glx in the process because after went through the whole thing, the error message was different. Now, the X server just crashes and gives me the following error messages instead of loading with a blank screen:
/var/log/Xorg.0.log (only the part with the errors):
Code:
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly. 
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
/var/log/gdm/:0.log :
Code:
X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: Linux Ubuntu
Current Operating System: Linux my-laptop 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686
Build Date: 04 April 2007
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul  3 11:43:04 2007
(==) Using config file: "/etc/X11/xorg.conf"
Error: API mismatch: the NVIDIA kernel module has the version 1.0-7184, but
this X module has the version 1.0-9631.  Please make sure that the kernel
module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly. 
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Notice the difference the kernel module versions. That is why I think I upgraded something. Should I now try to upgrade the nvidia driver itself?
P.S. Sorry that I didn't post the log files before. I was trying to see if I could get it the give me the original error messages.

Last edited by H-Radical; 07-03-2007 at 03:07 PM.
 
Old 07-04-2007, 06:13 AM   #4
emi_ramo
Member
 
Registered: Apr 2007
Location: Barcelona, Spain
Distribution: Debian, KUbuntu
Posts: 213

Rep: Reputation: 36
nvidia-installer

Hi again,
there is an utility to autoconfigure (download, compile and install) the NVIDIA driver. It's called nvidia-installer. Try with this. If you don't have this program, download it from repositories (if possible) or from nvidia webpage (it's easy to find out the download page).
 
Old 07-05-2007, 02:29 PM   #5
H-Radical
LQ Newbie
 
Registered: Dec 2006
Location: among the rich and powerful
Distribution: Ubuntu Edgy Eft
Posts: 17

Original Poster
Rep: Reputation: 0
well, I have it so close to working. With this xorg.conf, I get three flashes of the NVIDIA logo and then a crash. I know there's something I have to do with the edids. In edgy, the line Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes" was crucial to getting the card working... now, for some reason, the NoEdidDFPMaxSizeCheck is not recognized so its not working... I don't know why its not recognized or what to replace it with... Any help with that?

xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Apr 16 20:37:13 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "dbe"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 51.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
	Identifier     "NVIDIA Corporation NV17 [GeForce4 420 Go]"
    Driver         "nvidia"
	Option		   "ConnectedMonitor" "DFP"
	Option		   "AddARGBVisuals" "TRUE"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV17 [GeForce4 420 Go]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option         "ExactModeTimingsDVI" "TRUE"
    Option		   "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes"
    Option         "XAANoOffscreenPixmaps"
#    Option	   "AddARGBGLXVisuals" "TRUE"
    SubSection     "Display"
        Depth       1
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1024x768"
    EndSubSection
	SubSection     "Display"
        Depth       16
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1024x768"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
 
Old 07-05-2007, 02:48 PM   #6
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Have you updated your driver to be consistent, as was suggested to you in an earlier post?

What does your Xorg.0.log file say about your most recent problem?
 
Old 07-05-2007, 05:14 PM   #7
H-Radical
LQ Newbie
 
Registered: Dec 2006
Location: among the rich and powerful
Distribution: Ubuntu Edgy Eft
Posts: 17

Original Poster
Rep: Reputation: 0
Well, yes; I don't get the API mismatch error anymore. In my efforts to fix that problem, I ran Envy, which removed everything and did a fresh install. After that, there was still an API mismatch error, but I fixed that by running a driver installer from NVIDIA (1.0-9639). Then I added the line: ' Option "ConnectedMonitor" "DFP" ' (I got the idea of using this line from someone who had posted similar problems with a different card on ubuntu forums). Now I get three flashes of the NVIDIA logo before X crashes. Here's the Xorg.0.log (I'm posting only the section that changed)
Code:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "ExactModeTimingsDVI" "TRUE"
(**) NVIDIA(0): Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes"
(**) NVIDIA(0): Enabling RENDER acceleration
(WW) NVIDIA(0): Unrecognized ModeValidation token "NoEdidDFPMaxSizeCheck";
(WW) NVIDIA(0):     ignoring.
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(II) NVIDIA(0): NVIDIA GPU GeForce4 420 Go at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 32768 kBytes
(--) NVIDIA(0): VideoBIOS: 04.17.20.22.03
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 420 Go at PCI:1:0:0:
(--) NVIDIA(0):     Nvidia Default Flat Panel (DFP-0)
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 224.0 MHz maximum pixel
(--) NVIDIA(0):     clock
(--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Mode Validation Overrides for Nvidia Default Flat Panel
(II) NVIDIA(0):     (DFP-0):
(II) NVIDIA(0):     NoVesaModes
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (81, 81); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
Notice the parts in bold! The mode validation overrides were crucial to get the nvidia drivers working in edgy, but now one of them isn't recognized. Also, before I added the Connected monitors line, the DPI was set to (75,75) and there was a lot of reference in this part of the log file about CRT-0 (my card has an external output but nothing's ever connected to it).
 
Old 01-03-2008, 11:20 AM   #8
xzased
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Rep: Reputation: 0
Hi. Did you ever found the fix for his? Im having the exact same problem with my GeForce 420 Go driver, works with the nv but when I switch to nvidia the screen goes kaput.
 
Old 01-03-2008, 02:21 PM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
There is a fix for this. I have the same laptop (PCG-GRT100) with the same card (GeForce4 420 Go), and here's how it works. It did the same thing for me at first, but after messing around with it a lot I figured it out. Here's my entire 'xorg.conf':

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep  5 19:30:08 PDT 2007

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
    FontPath        "/usr/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/Speedo/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/lib/X11/fonts/TTF/"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us(dvorak)"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Nvidia Default Flat Panel"
    HorizSync       29.0 - 65.0
    VertRefresh     0.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce4 420 Go"
    Option         "nologo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Potentially important parts highlighted in red

Basically, the problem is that this card has two outputs, one to the laptop screen and one to analog CRT (the port on the back of the laptop for external monitor output). I think nvidia made a mistake in their newer drivers and the CRT interface is active even tho there is no input. To fix it I ran 'nvidia-settings' and disabled CRT-0 interface. Then I saved the resulting 'xorg.conf', which you can see above.

Last edited by H_TeXMeX_H; 01-03-2008 at 02:27 PM.
 
Old 01-08-2008, 01:23 PM   #10
xzased
LQ Newbie
 
Registered: Jan 2008
Posts: 20

Rep: Reputation: 0
Thanks for your post TexMex man. I managed to go halfway now. I ended up with the same xorg file doing all the steps you mentioned, but my resolution is set to 800x600. I cant change it for some reason...
 
Old 01-10-2008, 03:32 PM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, I let nvidia auto-select the resolution, you may want to choose it instead. You can do it through 'nvidia-settings' or:

Code:
    Option         "metamodes" "DFP: 1024x768 +0+0"
if you wanted '1024x768' which replaced 'nvidia-auto-select'.
 
Old 11-17-2008, 09:55 PM   #12
jppranker
LQ Newbie
 
Registered: May 2008
Posts: 2

Rep: Reputation: 0
Thanks H_TeXMeX_H this really go me out of the ditch with Dl3.3. I made a post at the dream linux forums quoting this help thread.
 
Old 11-18-2008, 08:28 AM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Glad to help. This is actually an odd case that took me a while to figure out.
 
  


Reply

Tags
feisty fawn, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3D desktops with nVidia GeForce4 420 Go H-Radical Linux - Desktop 10 06-30-2007 11:14 PM
LXer: Install Beryl with latest nvidia drivers in Ubuntu Feisty Fawn LXer Syndicated Linux News 0 04-25-2007 05:46 PM
NVIDIA GeForce4 MX 420 TwinVeiw Problems standard.killer Linux - Hardware 2 10-11-2005 09:26 AM
About NVIDIA GeForce4 420 Go installing on TOSHIBA 6100 laptop AnthraxCN Linux - Laptop and Netbook 1 05-16-2004 08:42 AM
I have problem in X screen. My NVIDIA GeForce4 MX 420 AGP is not working. kai_rana Linux - Hardware 2 09-02-2003 01:56 AM


All times are GMT -5. The time now is 11:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration