LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-03-2008, 05:56 PM   #1
SuperK
LQ Newbie
 
Registered: May 2006
Posts: 25

Rep: Reputation: 15
Cursor disappearing after suspend and wifi question


Hey all,

I have searched and searched for an answer here, Google and at the PCLOS forums. I desperately do not want to have to use XP on this laptop but the cursor issue at least is a deal breaker for me. Here the deal:

Installed PCLOS on a Dell Latitude 100L, all seemed to work well, including suspend for the first day or two, then for no apparent reason I can see when it would wake after suspend I would have no cursor. If I moved it on the touch pad or with my wireless mouse things on the screen would react as if it was there, just no pointer to be seen. I have read things that point to this being a common issue but darned if I can find any posted solutions to it. That's the deal breaker.

Now for what is probably operator error:

I bought a Dynex wireless G notebook card from Best Buy as I had read several reviews online of people saying how well it worked with Linux and how surprised they were by that. I have never configured a wireless card in Linux (or really Windows for that matter as this is my first ever laptop) So I am fairly sure this is the easier of the two to fix, I just dn't see what I have done wrong.

Like I said, I really don't wnat to have to put windows on it if I can avoid it. I have been using PCLOS on my primary PC for months now and Ubuntu for several years before that. Everything else works great with PCLOS on the laptop, it's just what's not working is a real show stopper.

If anyone can help, please do, I will be very, very grateful indeed. I have posted this at the PCLOS forums but after two days lot's of looks but no response except a bump by me.

Please, save me from having to use Windows!!!

Thanks to all in advance.

Last edited by SuperK; 03-03-2008 at 05:58 PM.
 
Old 03-03-2008, 06:47 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,617
Blog Entries: 3

Rep: Reputation: 219Reputation: 219Reputation: 219
did you set your bios to none plug n play or none windows or none os what ever you bios say when your not using windows. make sure your grub or lilo pass the command acpi=on as far as your curor in bios you have two setting one or both. yeap you can run the on board cursor or the plug ps2 or usb . set it to what ever one you want good luck .
 
Old 03-04-2008, 01:03 PM   #3
SuperK
LQ Newbie
 
Registered: May 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Wasn't entirely clear on everything you suggested but did try what I was familiar with. Unfortunately the problem remains.

Thanks for post however, I appreciate any attempts to help for sure.

Cheers
 
Old 03-04-2008, 02:36 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Not sure what's up with the cursor problem, but to figure out the wireless driver, you need to know the chipset that card uses. Try running lspci and see if the card is listed. If not, it might be time to hit google and see if that info is out there.
 
Old 03-04-2008, 08:23 PM   #5
SuperK
LQ Newbie
 
Registered: May 2006
Posts: 25

Original Poster
Rep: Reputation: 15
here's the output:

Broadcom Corporation BCM4318 (AirForce One 54g) 802.11g wireless LAN controller (rev 02)
 
Old 03-05-2008, 12:56 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
OK, the 4318 presents a little bit of a problem. It supposedly has native linux drivers (bcm43xx on kernels earlier than 2.6.24 and b43 on 2.6.24 and later) however, it doesn't work very well with those. The alternative is ndiswrapper, which allows Windows drivers to function in Linux. To be honest, for this chipset, ndiswrapper is probably the way to go. However, make sure you don't have a 2.6.24 or later kernel as 2.6.24 broke ndiswrapper. Supposedly there is a patch out, but I haven't messed with it yet so I can't comment on how good it is. If you go the ndiswrapper route, be sure to blacklist the native linux driver (bcm43xx or b43) as having both ndiswrapper and a linux driver loaded at the same time will cause trouble. Be sure to visit the ndiswrapper wiki site as they have a lot of excellent installation instructions.
 
Old 03-05-2008, 05:36 PM   #7
SuperK
LQ Newbie
 
Registered: May 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
OK, the 4318 presents a little bit of a problem. It supposedly has native linux drivers (bcm43xx on kernels earlier than 2.6.24 and b43 on 2.6.24 and later) however, it doesn't work very well with those. The alternative is ndiswrapper, which allows Windows drivers to function in Linux. To be honest, for this chipset, ndiswrapper is probably the way to go. However, make sure you don't have a 2.6.24 or later kernel as 2.6.24 broke ndiswrapper. Supposedly there is a patch out, but I haven't messed with it yet so I can't comment on how good it is. If you go the ndiswrapper route, be sure to blacklist the native linux driver (bcm43xx or b43) as having both ndiswrapper and a linux driver loaded at the same time will cause trouble. Be sure to visit the ndiswrapper wiki site as they have a lot of excellent installation instructions.
Thanks. If you might be able to recommend a card that is a bit easier to get working in PCLOS, I have no problem taking this one back and buying one a little more linux friendly at all, even if it's a bit more money. If I can get this issue as well as the no cursor after suspend issue sorted I will be golden. Like I said I really DO NOT want to install XP but those two issue are deal breakers when it come to a laptop I will be doing work on. I will also hate not having Bluefish to use either- that will be a true tragedy!

Thanks for the taking the time to help so far.
 
Old 03-05-2008, 05:58 PM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
If you might be able to recommend a card that is a bit easier to get working in PCLOS
Linux is a bit different in that you have to pay attention to the chipset rather than the card brand. Intel actively supports Linux driver development as does Atheros, so cards with either of those chipsets would be a good choice. But to be honest, ndiswrapper isn't hard to get going (at least not any harder than Intel or Atheros), it is just the victim of a temporary spat with the kernel development team. You'll have to do a little console work, but ndiswrapper is really pretty easy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi card LED comes on after suspend/resume but not at boot? hollywoodb Linux - Hardware 3 04-18-2007 01:10 PM
mandriva 2007: suspend, resume, wifi won't work thevanillaspy Mandriva 1 01-23-2007 06:05 AM
disappearing mouse cursor HugoTG Linux - Hardware 2 03-06-2006 09:07 AM
wifi doesnt get up after suspend jimqode Linux - Wireless Networking 0 04-03-2005 03:00 PM
Console Cursor Disappearing JFoster Linux - General 0 02-26-2004 04:13 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration