LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 01-11-2005, 08:40 AM   #1
sonis
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Rep: Reputation: 0
cpu freq. scaling problem


my laptop is IBM R40 pentium-M 1.3Ghz and suse 9.2 pro installed. today i found in info ceter that my cpu is working in a freq. of 598 Mhz. what happened?any one know how this problem can be fixed?
 
Old 01-12-2005, 01:00 PM   #2
BrianNJ
Member
 
Registered: Jul 2003
Distribution: Gentoo 2004.0
Posts: 157

Rep: Reputation: 30
sounds like speed step. it's a feature in mobile processors that keeps the cpu underclocked when the system is idle or not under a small load.
 
Old 01-13-2005, 06:09 PM   #3
db391
Member
 
Registered: Jun 2004
Location: Britain
Distribution: Slackware
Posts: 186

Rep: Reputation: 31
To make the processor run at full speed (and waste the battery ) then you will need to use the klaptop applet in the panel, and change CPU throttling to 00% slowdown.
This is what works on my Thinkpad T22
 
Old 01-13-2005, 06:30 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
* Proccessor Throttling
Check an see what the following says:
cat /proc/acpi/processor/CPU0/throttling
cat /proc/acpi/processor/CPU0/info

This commands changes speed step cpu setting. 0 is top speed.
echo -n 5 > /proc/acpi/processor/CPU0/throttling

Brian1
" Google the Linux way @ http://www.google.com/linux "
 
Old 04-25-2005, 08:24 AM   #5
octinum
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 35

Rep: Reputation: 15
That is exactly what I am trying to do now!
I am running an HP-Compaq nx9005 (Mobile Athlon 2400+), I had been using powersaved but a few days ago I decided to reinstall Slack. A few problems with that:

1) Powersave doesn't compile. It gives an error related to some cpufreq-thing, although I have everything needed in the kernel..
2) acpid doesn't start. It says:
Code:
acpid: can't open /proc/acpi/event: Device or resource busy
3) Anyways, I am planning to use KLaptop. It shows available speed levels (there are six), but won't let me change. The notebook is always running at 1800 MHz when I don't need that power.

Opening a new topic seemed unnecessary.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU heat monitoring and freq. control Yonatanph Programming 1 04-12-2005 05:19 PM
how to control cpu freq ruh31 Debian 6 02-14-2005 10:58 AM
cpu freq. scaling problem sonis Suse/Novell 3 01-12-2005 06:04 PM
Enabling power save/power management/cpu freq scaling features for a Debian system zero79 Debian 0 12-19-2004 02:17 PM
Lower CPU freq Adony Linux - Hardware 2 10-01-2004 10:23 AM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration