LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   cpu freq. scaling problem (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/cpu-freq-scaling-problem-276487/)

sonis 01-11-2005 07:40 AM

cpu freq. scaling problem
 
my laptop is IBM R40 pentium-M 1.3Ghz and suse 9.2 pro installed. today i found in info ceter that my cpu is working in a freq. of 598 Mhz. what happened?any one know how this problem can be fixed?

BrianNJ 01-12-2005 12:00 PM

sounds like speed step. it's a feature in mobile processors that keeps the cpu underclocked when the system is idle or not under a small load.

db391 01-13-2005 05:09 PM

To make the processor run at full speed (and waste the battery ;)) then you will need to use the klaptop applet in the panel, and change CPU throttling to 00% slowdown.
This is what works on my Thinkpad T22

Brian1 01-13-2005 05:30 PM

* Proccessor Throttling
Check an see what the following says:
cat /proc/acpi/processor/CPU0/throttling
cat /proc/acpi/processor/CPU0/info

This commands changes speed step cpu setting. 0 is top speed.
echo -n 5 > /proc/acpi/processor/CPU0/throttling

Brian1
" Google the Linux way @ http://www.google.com/linux "

octinum 04-25-2005 07:24 AM

That is exactly what I am trying to do now! :)
I am running an HP-Compaq nx9005 (Mobile Athlon 2400+), I had been using powersaved but a few days ago I decided to reinstall Slack. A few problems with that:

1) Powersave doesn't compile. It gives an error related to some cpufreq-thing, although I have everything needed in the kernel..
2) acpid doesn't start. It says:
Code:

acpid: can't open /proc/acpi/event: Device or resource busy
3) Anyways, I am planning to use KLaptop. It shows available speed levels (there are six), but won't let me change. The notebook is always running at 1800 MHz when I don't need that power.

Opening a new topic seemed unnecessary.


All times are GMT -5. The time now is 02:15 PM.