LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 02-08-2005, 02:52 PM   #1
nickleus
Member
 
Registered: Nov 2004
Location: Noreg
Distribution: ubuntu
Posts: 107

Rep: Reputation: 15
Configuring X on my dell inspiron 510m


i've got mandrake 10.1 with a 2.6.10 kernel.

when i log in and run
$ kde

X (xorg) starts up but the picture is all messed up. when i switch to another console:
ctrl+alt+f2
and then back again to X:
ctrl+alt+f7
everything is fine.

when i check tty1 (ctrl+alt+f1) i see the following error messages:
ksplash: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
SetClientVersion: 0 8

---------------------

why won't it just start up and work fine the first time? why do i have to switch to another tty and then back again to tty7 for it to work?
 
Old 02-09-2005, 09:39 AM   #2
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
I get this error message whenever I run any KDE application (I only see it when I call it from the console). Nothing doesn't work, it's just... there. My applications work, just this stuff fills up my console whenever I call such an app from it.

Code:
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kdecore (KIconLoader): WARNING: Icon directory /home/alex/.kde/share/icons/nuvola/ group  not valid.
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
kded: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
kded: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
kdecore (KIconLoader): WARNING: Icon directory /home/alex/.kde/share/icons/nuvola/ group  not valid.
kdecore (KIconLoader): WARNING: Icon directory /home/alex/.kde/share/icons/nuvola/ group  not valid.

Have you tried using the command "startx" instead of "kde"?
 
Old 02-09-2005, 09:45 AM   #3
nickleus
Member
 
Registered: Nov 2004
Location: Noreg
Distribution: ubuntu
Posts: 107

Original Poster
Rep: Reputation: 15
when i run "startx" it starts up gnome. how do i configure it so that "startx" starts kde instead?

but the real question is why the heck does it work fine after i go to another tty (tty6, for example) and then back again to the X tty (tty7)?

the exact same thing happens when i run startx too with gnome, so its not a kde or gnome issue, it must be Xorg.

Last edited by nickleus; 02-09-2005 at 09:46 AM.
 
Old 02-09-2005, 11:34 AM   #4
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
could you please post the contents of this file? ~/.xinitrc
 
Old 02-09-2005, 05:58 PM   #5
nickleus
Member
 
Registered: Nov 2004
Location: Noreg
Distribution: ubuntu
Posts: 107

Original Poster
Rep: Reputation: 15
all i can find is /etc/X11/xinit/xinitrc
============================

if [ "`whoami`" != root ]; then
xsetroot -solid "#21449C"
fi

exec /etc/X11/Xsession $*
=============================

oh yeah, and i normally log in as root.
 
Old 02-10-2005, 01:15 AM   #6
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
Then create an .xinitrc file and add one line to it, telling X to load KDE, as follows:

Code:
$ echo "exec startkde" > ~/.xinitrc
startx should (hopefully) load KDE when called.

And if I may add.. don't ever login as root into a graphical desktop environment, because it allows for mistakes to occur without anyway of recovering them. You should create a user account, and use it as your main account. You should only need root to do maintenance, checkups, or edit system-wide files, and the like - NOT as your default account. It is considered bad practice and leaves your computer vulnerable to attacks, as any program that is run by root is given root permissions which allows it to run other processes with the same access rights.

Last edited by student04; 02-10-2005 at 01:16 AM.
 
Old 02-10-2005, 05:02 AM   #7
nickleus
Member
 
Registered: Nov 2004
Location: Noreg
Distribution: ubuntu
Posts: 107

Original Poster
Rep: Reputation: 15
thanks for the tips but my main questions still is unanswered. why do things work fine after i switch to another terminal (tty6, for example) and then back to the X terminal (tty7)? why won't it work fine from the start?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dell inspiron 510m vs fc3 yenonn Linux - Laptop and Netbook 1 05-16-2005 02:09 AM
Dell Inspiron 510m + external flat panel monitor nickhug2000 Linux - Laptop and Netbook 1 04-05-2005 12:56 PM
need wireless internet help mandrake 10 dell inspiron 510m intel wireless 2100 3A nickleus Mandriva 3 11-09-2004 10:52 PM
Linux on Dell Inspiron 510M does not install... kalle123 Linux - Laptop and Netbook 1 09-02-2004 01:54 PM
Dell inspiron 510m, i855GME, 1400x1050 resolution ? Ben2210 Linux - Laptop and Netbook 7 07-29-2004 07:11 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration