LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 02-13-2010, 07:16 AM   #1
AkylaQD
LQ Newbie
 
Registered: Feb 2010
Posts: 6

Rep: Reputation: 0
Configuring WFI in Slackware 13 on Lenovo IdeaPad S10-2


I have a problem configuring WiFi in Linux on Lenovo IdeaPad S10-2.
It doesn't connetct. In Ubuntu 9.10 WiFi worked fine. Please help, and sorry for my bad english=)




Netbook Lenovo S10-2

WiFi Adapter: Intel WiMAX / WiFi Link 5150

iwconfig output :

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abgn Mode: Managed Access Point: Not-Associated
Tx-Power = 15 dBm
Retry long limit: 7 RTS thr: off Fragment thr: off
Encryption key: off
Power Management: off

sit0 no wireless extensions.

wmx0 no wireless extensions.

lspci output:

02:00.0 Network controller: Intel Corporation WiMAX / WiFi Link 5050 Series

dmesg | grep firmware output:

[ 5.821117] i2400m_usb 1-6:1.0: firmware: requesting i2400m-fw-usb-1.4.sbcf
[ 8.099046] i2400m_usb 1-6:1.0: firmware interface version 9.2.0
[ 220.163240] iwlagn 0000:02:00.0: firmware: requesting iwlwifi-5150-2.ucode
[ 220.259419] iwlagn 0000:02:00.0: loaded firmware version 8.24.2.2

Last edited by AkylaQD; 02-13-2010 at 01:58 PM.
 
Old 02-13-2010, 07:41 AM   #2
slackwaredanny
Member
 
Registered: Feb 2010
Location: Sweden
Distribution: Slackware
Posts: 88
Blog Entries: 3

Rep: Reputation: 20
Quote:
Originally Posted by AkylaQD View Post
I have a problem configuring WiFi in Linux on Lenovo IdeaPad S10-2.
It doesn't connetct. In Ubuntu 9.10 WiFi worked fine. Please help, and sorry for my bad english=)




Netbook Lenovo S10-2

WiFi Adapter: Intel WiMAX / WiFi Link 5150

iwconfig output :

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abgn Mode: Managed Access Point: Not-Associated
Tx-Power = 15 dBm
Retry long limit: 7 RTS thr: off Fragment thr: off
Encryption key: off
Power Management: off

sit0 no wireless extensions.

wmx0 no wireless extensions.

lspci output:

02:00.0 Network controller: Intel Corporation WiMAX / WiFi Link 5050 Series


look for a slackbuild if you need a driver,but looks like wlan0 is your wifi.
run netconfig
slack local.domain loopback works for me.
ifconfig wlan0 up
start wpa_gui
start wicd (its on the dvd in extra if you dont have it)
refresh wicd if you get any network connect to it.
scan wpa_gui as wicd tries to connect now you should be able to double click on the network you want and enter your info and connect in wpa_gui.
hope u get ur wifi going!
and look in slackware section on this forum for more tips....
 
Old 02-13-2010, 08:11 AM   #3
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 141Reputation: 141
Does slackware come with the required firmware?

What is the output of
Code:
dmesg | grep firmware
http://intellinuxwireless.org/?n=Downloads
 
Old 02-13-2010, 01:12 PM   #4
AkylaQD
LQ Newbie
 
Registered: Feb 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by reed9 View Post
Does slackware come with the required firmware?

What is the output of
Code:
dmesg | grep firmware
http://intellinuxwireless.org/?n=Downloads
dmesg | grep firmware output:

[ 5.821117] i2400m_usb 1-6:1.0: firmware: requesting i2400m-fw-usb-1.4.sbcf
[ 8.099046] i2400m_usb 1-6:1.0: firmware interface version 9.2.0
[ 220.163240] iwlagn 0000:02:00.0: firmware: requesting iwlwifi-5150-2.ucode
[ 220.259419] iwlagn 0000:02:00.0: loaded firmware version 8.24.2.2
 
Old 02-15-2010, 09:30 AM   #5
slackwaredanny
Member
 
Registered: Feb 2010
Location: Sweden
Distribution: Slackware
Posts: 88
Blog Entries: 3

Rep: Reputation: 20
did you work it out and what kernel do you have if not.
 
Old 02-17-2010, 05:45 AM   #6
AkylaQD
LQ Newbie
 
Registered: Feb 2010
Posts: 6

Original Poster
Rep: Reputation: 0
thanks all, I install wicd and WiFi works correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lenovo s10 WiFi in Puppy 4.31 TheHimself Puppy 8 01-11-2010 06:35 AM
LXer: Lenovo S10 Netbook: Fabulous Hardware, Yuck Software LXer Syndicated Linux News 0 03-10-2009 08:40 PM
Cable and Fedora 10 on Lenovo S10 internet trouble connection yukapuka Linux - Laptop and Netbook 1 02-14-2009 07:37 PM
Linux on Lenovo IdeaPad U110 echasketch123 Linux - Laptop and Netbook 1 09-19-2008 09:25 AM
Lenovo IdeaPad Y510 mrzack General 3 03-21-2008 08:32 AM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration