LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 02-04-2006, 08:01 PM   #1
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Rep: Reputation: 15
Compaq v5005us, want to turn off touchpad


I know it's not fashionable, but is there a way to turn off the #$!@#$!@#$ touchpad. it is very sensitive, and i don't have the fingers of a pianist, so all i have to do is lightly brush the touchpad, and either garbage gets pasted into whatever i'm doing, or i get sent to a random window. very aggravating.

btw, otherwise this is a sweet laptop! (broadcom wlan works if you follow the directions, still need to install ati driver, but I'll get to that this weekend...)

thanks in advance!
 
Old 02-05-2006, 03:05 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
You can usually turn off the "tap to click" feature if you have a Synaptic touchpad - this is the problematic behavior you're reporting. In /etc/X11/xorg.conf:

Code:
Section "InputDevice"
    Identifier     "Synaptics"
    Driver         "synaptics"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "auto-dev"
    Option         "Emulate3Buttons" "no"
    Option         "ShmConfig" "on"
    Option         "MaxTapTime" "0"
    Option         "TapButton1" "0"
    Option         "TapButton2" "0"
    Option         "TapButton3" "0"
        #Option "HorizScrollDelta" "0"
EndSection
 
Old 02-05-2006, 09:34 PM   #3
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Original Poster
Rep: Reputation: 15
Yahoo! Works great. I can play a drum solo on the damn touchpad now without farking up my code!

Homework will now be easier.

while (1) printf("Thank you!\n");
 
Old 02-07-2006, 01:14 AM   #4
trainee
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 142

Rep: Reputation: 16
Sorry but I am lost here. What is "tap to click"?
 
Old 02-07-2006, 07:54 AM   #5
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
trainee: Touchpads have hardware buttons that perform as mouse buttons. However, they also have a software function that simulates these buttons. By briefly touching (tapping) the touchpad, mouse button 1-3 can be simulated.

This sounds good in theory, but when the palm of your hand brushes against the touchpad as you are typing, you can get strange and unexpected behavior. This thread discusses how to disable that behavior for Synaptics touchpads (a popular laptop model).
 
Old 02-07-2006, 11:16 AM   #6
trainee
Member
 
Registered: Dec 2004
Distribution: Slackware
Posts: 142

Rep: Reputation: 16
Thanks. It works.
 
Old 02-09-2006, 05:37 PM   #7
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Original Poster
Rep: Reputation: 15
OK, it worked mostly..

I put in the config changes in the Synaptics section of xorg.conf, and most of the really big problems stopped (it had been randomly pasting text almost everytime I was typing. Since I work with mostly konsole screens, (about 50% of the time) with the rest being graphic, that was the main problem.

However, it still gives me grief by running the mouse around the screen, and I don't think the touch to click is completely off. Much less sensitive, but not off.

There seems to be no way to turn off the touchpad in the bios (my preferred solution), where is the place in the system start up that will alllow me to turn the #$@%$!@$% thing off completely.

( i also notice error messages popping up about the mouse when i am switched over to a text screen. i forget exactly what they are, but they are the kind of message that farks up the whole screen, CTRL-L is now my friend.)

These are the messages:

Feb 5 11:30:15 localhost kernel: psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
Feb 5 11:30:15 localhost kernel: psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
Feb 5 11:30:15 localhost last message repeated 3 times
Feb 5 11:30:15 localhost kernel: psmouse.c: TouchPad at isa0060/serio4/input0 - driver resynched.
Feb 5 11:30:47 localhost kernel: psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
Feb 5 11:30:47 localhost kernel: psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 4
Feb 5 11:30:47 localhost kernel: psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
Feb 5 11:30:47 localhost kernel: psmouse.c: TouchPad at isa0060/serio4/input0 - driver resynched.

so what I want to know is how i can turn off isa0060/serio4/input0, and will this mess up the usb mouse?

thanks in advance!
 
Old 02-10-2006, 08:14 AM   #8
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Original Poster
Rep: Reputation: 15
OK, in another forum (I should have looked farther!) eliot678 posted more info about the synaptics touchpad. Apparently, not only is there a 'tap to click' but ther is also a 'touch somewhere on the edge and have the mouse click, just because we're jerks' option. the config that turns that stuff off is:
Identifier "TouchPad"
Driver "synaptics"
Option "Protocol" "auto-dev"
Option "Device" "/dev/mouse"
Option "LeftRightScrolling" "off"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"#Allows use of synclient
Option "RTCornerButton" "0" #Turns off right top corner button
Option "RBCornerButton" "0" #Turns off right bottom corner button
EndSection
the RTCornerButton and RBCornerButton are the ones that deal with those 'edge' clicks.

thanks to all who helped, especially eliott678 and macemoneta!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptics touchpad on Compaq laptop sydonn Linux - Hardware 5 12-19-2005 12:56 AM
Subtle synaptics touchpad problem on Compaq R4000 bear.remien Linux - Laptop and Netbook 0 11-30-2005 03:45 PM
Compaq doesn't turn off after shutdown jhwhite Linux - Laptop and Netbook 17 11-03-2005 09:26 PM
alps touchpad on compaq r3000 w/ knoppix drum2jc Linux - Laptop and Netbook 1 08-17-2004 01:22 AM
How do I turn the TouchPad back on? KitKat Linux - Laptop and Netbook 2 02-11-2004 12:31 AM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration