LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-03-2007, 12:53 PM   #1
maxcell
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Rep: Reputation: 0
Compaq Presario 2100


I installed Fedora 6 on my compaq presario 2100 AMD xp 2800+. But I notice it gets a litter hotter than it did in XP.. Is that normal?

Are there drivers for the touchpad? My touchpad seems to be out of whack.. It'll try scrolling at random places, and do funny things sometimes..
 
Old 03-03-2007, 01:18 PM   #2
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
I had FC4,FC5,and FC6 running on that laptop. I did not notice the laptop running hotter. Possibly it is running hotter because there is no cpu scaling. I would check your log for acpi or powernow to verify there are no errors there. However with FC6 I recall this worked out of the box.

I never had to putz with the touchpad driver. However I configured it to my likings. In your /etc/X11/xorg.conf add the option
Code:
Option      "SHMConfig" "1"
in the InputDevice section for the synaptics touchpad. Then restart X.

Then 'yum install ksynaptics' or gsynaptics (k for kde version, g for gnome)
and you should have a gui for playing with the settings of the touchpad.

Last edited by accessrichard; 03-03-2007 at 01:20 PM.
 
Old 03-03-2007, 01:22 PM   #3
cpd05
Member
 
Registered: Jan 2006
Distribution: Debian
Posts: 90

Rep: Reputation: 15
Hey,

Is the cpu fan coming on at all? If it isn't you need to make sure that the acpi daemon is installed, have a search on yum for 'acpid' and 'acpi' install it if it isn't already installed.

You also need to set up your kernel to scale the cpu frequency, this is what really keeps the cpu cool. Enter:

lsmod

In a terminal and look for the a module called powernow-k7 or powernow-k8 if one is listed you should be able to change the way the kernel scales the cpu frequency. Look in:

/sys/devices/system/cpu/cpu0/cpufreq/

There should be a load of info in there, post back if there is.

Hope that makes sense

Chris.
 
Old 03-04-2007, 02:03 AM   #4
maxcell
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks guys!
Okay I have some relies for the sulutions I tried that you guys provided me.. I have 3 different ssectins of replies/questions. Ill divide them so it'll make it easier to follow...

--------------Touchpad pointer device-----------
I added that option line ("SHMConfig" "1") for the input device... What does that change? what else did you customize? One wierd thing that happens is alot when im browing the web, and I'll move my pointer (mouse) using the touchpad up very fast towards the top menu and it'll go back to the previous page, or a few pages back.. or sometimes it goes somewhere... What could be causing this?

---------CPU - Laptop being too hot.. ---------------
My CPU fan does come on... but it still seems to me that windows XP didn't heat my laptop as much...
I checked the "/sys/devices/system/cpu/cpu0" directory and I didn't have a "cpufreq" directory there...

I also didn't see the module called powernow-k7 or powernow-k8 when typing "lsmod" in the terminal..

Anyway I can install or enable that?


-------------- Video Card drivers?------------------
Another question.. I dont think my video card is installed properly, I believe i have a Radeon IGP 320M. I found some forum with people that said they got 3d acceleration installed and working, however I'm still a newbie and cant follow what they discussed...
anything I should change in my xorg config file?

This is my xorg config file:
Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
	Option      "SHMConfig" "1"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Thanks guys! I really appreciate your help!
 
Old 03-04-2007, 11:09 AM   #5
cpd05
Member
 
Registered: Jan 2006
Distribution: Debian
Posts: 90

Rep: Reputation: 15
To install the cpufreq module try, as root:

modprobe powernow-k7

If it loads then look again in the /sys directory for the cpufreq stuff, there should be some files in there that refer to the scaling governor, the governor defines how linux will scale the cpu its by default the performance governor. This means the cpu will go at full speed all the time which makes things hot, if in the file called something like "available scaling governors" ondemand is listed you should be able to as root do:

cpufreq-set -g ondemand

if ondemand isn't listed in the above file, as root try:

modprobe cpufreq-ondemand

If that loads without any problems retry the cpufreq-set command again. Then look back in the /sys directory cpufreq stuff for the current frequency or set up an applet on your desktop to tell you the current cpu frequency. On gnome its just right-click->add to panel->cpufreq-applet.

Chris.
 
Old 03-04-2007, 03:57 PM   #6
accessrichard
Member
 
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
For the Touchpad adding that option to Xorg allows you to configure the settings of the touchpad using ksynaptics. Ksynaptics is a kde frontend for the command synclient. If you type synclient -l in a terminal you will see your touchpad settings, you can set these manually using the command line tool synclient or as an alternative you can use the gui ksynaptics.

For the graphics card, you are currently using the open source driver. If you dont mind using the closed source driver, check out the fedorafaq.org and you will have instructions on using the ati proprietary drivers.
 
Old 03-05-2007, 02:10 AM   #7
maxcell
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by cpd05
To install the cpufreq module try, as root:

modprobe powernow-k7

If it loads then look again in the /sys directory for the cpufreq stuff, there should be some files in there that refer to the scaling governor, the governor defines how linux will scale the cpu its by default the performance governor. This means the cpu will go at full speed all the time which makes things hot, if in the file called something like "available scaling governors" ondemand is listed you should be able to as root do:

cpufreq-set -g ondemand

if ondemand isn't listed in the above file, as root try:

modprobe cpufreq-ondemand

If that loads without any problems retry the cpufreq-set command again. Then look back in the /sys directory cpufreq stuff for the current frequency or set up an applet on your desktop to tell you the current cpu frequency. On gnome its just right-click->add to panel->cpufreq-applet.

Chris.
Seems like it cant find it:
Code:
[root@localhost ~]# modprobe powernow-k7
FATAL: Module powernow_k7 not found.
also tried that for K6
Code:
[root@localhost ~]# modprobe powernow-k6
FATAL: Error inserting powernow_k6 (/lib/modules/2.6.19-1.2911.fc6/kernel/arch/i                              386/kernel/cpu/cpufreq/powernow-k6.ko): No such device
?

Thanks Chris!
 
Old 03-05-2007, 09:00 AM   #8
cpd05
Member
 
Registered: Jan 2006
Distribution: Debian
Posts: 90

Rep: Reputation: 15
Yes, it does seem like the powernow modules haven't been compiled. It may be that fedora call the modules something different you should have a look at the man page for the cpufreq command. It will probably give you some pointers to the other relevant man pages.

If thats a no go your'll have to recompile a kernel to include the cpu frequency scaling modules, its a really simple process once you've done it a few times.
Just download the source for your current kernel or a different one if you like from yum or kernel.org.

Once you have the a copy of kernel source code, put it in the /usr/src directory, then copy across your current kernels config file from the /boot directory. Put the config in the kernel source directory as the .config, you can then execute make menuconfig and the current kernels configuration will be used as a starting point.

This how-to explains pretty well the next steps of the process:
http://www.digitalhermit.com/linux/K...ild-HOWTO.html

Theres plenty of others around as well though. The cpu scaling options are located in:
Power Management options->CPU Freq Scaling

Take out all the scaling driver modules except the AMD althon/duron Powernow one. Include as modules all the governor modules and set the default governor to userspace. Don't take out the ACPI P-states module.

If once you've got the kernel up and running the powernow and ondemand modules aren't being loaded as default you should add them to the /etc/modules file - that file may be call something else on fedora check out the man pages for modules and modprobe they'll probably tell you the correct file.

Hope that helps

Chris.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compaq made a presario 2100 with mandrake 9.1 donavan01 Linux - Laptop and Netbook 0 07-20-2004 02:29 PM
Compaq Presario 2100 Wireless problem LordGrahf Linux - Laptop and Netbook 3 05-06-2004 01:43 AM
1real problem with Compaq Presario 2100 _RA_ Linux - Laptop and Netbook 2 02-17-2004 09:24 PM
MDK 9.2 on Compaq presario 2100 kyoshiro Linux - Laptop and Netbook 11 12-18-2003 03:04 AM
best distro for Compaq Presario 2100 l337f00l Linux - Laptop and Netbook 8 11-05-2003 05:43 AM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration