LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Clevo P151EM Optimus - Can't lower screen resolution, defaults to 1920x1080 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/clevo-p151em-optimus-cant-lower-screen-resolution-defaults-to-1920x1080-4175417716/)

stason 07-20-2012 12:43 AM

Clevo P151EM Optimus - Can't lower screen resolution, defaults to 1920x1080
 
Hello everyone! I am new to these forums, but am relatively familiar with Linux and have just purchased a laptop which is giving me a hard time - I can not lower the screen resolution.

Laptop is Clevo P151EM (with Optimus):
Code:

- CPU i7-3610QM x64
- 8GB of DDR3-1600
- Integrated Intel HD Graphics 4000
- Dedicated nVidia GTX 670M (1.5GB DDR5)
- Backtrack 5 RC2 x64 KDE installed on separate partition

Just because it's an Optimus-enabled laptop and there is no option in BIOS for choosing between video-cards am not trying to make nVidia card work. I have tried everything possible for the past week to no go, so I am sticking with integrated Intel HD for the time being.

My current install is fresh with no nVidia drivers installed.

As soon as I enter GUI after the install, my screen resolution is 1920x1080 and I cannot change it through System Settings:
- "Size" only has "Disabled" and "1920x1080" (selected) as options;
- "Refresh" only has "Auto"(selected) and "0.0 Hz";
- "Orientation" only has "No Rotation"

I really hate this FULL HD, as I can barely see anything on the screen, I would like to get 1600x900 at most (supported by laptop, have it in Windows 7 on another partition).

I've re-installed 3 times, and that's what I did during the last and most-successful re-installation:
REBOOT AFTER INSTALL
Code:

modprobe -r nouveau (blacklisted it as well);
Code:

apt-get update
Code:

apt-get upgrade
in /etc/default/grub I have changed:
Code:

GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
to:
Code:

GRUB_CMDLINE_LINUX_DEFAULT="text i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1 pcie_aspm=force"
Code:

update-grub
reboot
log-in as root and:
Code:

modprobe i915 modeset=1
This results in screen turning black and blinking blue every second. If I blindly type "startx", screen starts rapidly blinking RGB with nothing visible as well. Had to hard reboot because CTRL+ALT+F1 resulted in black screen.
boot into GUI and:
Code:

add-apt-repository ppa:xorg-edgers/ppa
apt-get update

Then manually updated from KPackageKit and reboot.

At this point, nothing has changed, still 1920x1080 and no possible way of applying another resolution.

I then proceeded with modifying xorg.conf located in /usr/share/xresprobe/xorg.conf (no /etc/X11/xorg,conf existed because no nVidia drivers were installed and "X -configure" command was not yet executed).
Modified it as so (added "ModeLine" to "Monitor" section, added "Modes" lines to every "Display" subsection):
Code:

# bare-bones XFree86 config to start the server in probe-only mode
Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
        RgbPath        "/etc/X11/rgb.txt"
EndSection
Section "ServerFlags"
        Option "AllowMouseOpenFail"
EndSection
Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "extmod"
        Load    "freetype"
        Load    "int10"
        Load    "record"
        Load    "vbe"
EndSection
Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"    "us"
EndSection
Section "InputDevice"
        Identifier      "Generic Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
EndSection
Section "Device"
        Identifier      "Generic Device"
        Driver          "vesa"
EndSection
Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        ModeLine        "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
        #this modeline was taken from result of running: cvt 1600 900
EndSection
Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Device"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth          1
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          4
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          8
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          15
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          16
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          24
                Modes          "1600x900"
        EndSubSection
        SubSection "Display"
                Depth          32
                Modes          "1600x900"
        EndSection
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice    "Generic Keyboard"
        InputDevice    "Generic Mouse"
EndSection

Still 1920x1080.
So I have created /etc/X11/xorg.conf by executing "X -configure", removed nVidia lines from there - starting X with it resulted in 1024x768 resolution. I then copied by modified /usr/share/xresprobe/xorg.conf to /etc/X11/xorg.conf, this as well resulted in my resolution to default to 1024x768 again, so i removed that file.

Can any of you guys help me to proceed in the right direction? I simply dont know what else to try.

Code:

xrandr --newmode "1600x900"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
Gives me:
Code:

xrandr: Failed to get size of gamma for output default
if run again:
Code:

xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19

Code:

xrandr --addmode default 1600x900
Gives me:
Code:

xrandr: Failed to get size of gamma for output default
Code:

xrandr --output default --mode 1600x900
Gives me:
Code:

xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed

glxgears run at 5500-6000 frames in 5 secods.
There is no graphic lag unless I turn effects on, then it starts to lag a little when moving windows around.

lspci | grep VGA
Code:

00:02.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 1213 (rev a1)

In my /var/log/Xorg.0.log (some lines skipped)
Code:

[    36.194] (II) VESA(0): VESA BIOS detected
[    36.194] (II) VESA(0): VESA VBE Version 3.0
[    36.194] (II) VESA(0): VESA VBE Total Mem: 65472 kB
[    36.194] (II) VESA(0): VESA VBE OEM: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
[    36.194] (II) VESA(0): VESA VBE OEM Software Rev: 1.0
[    36.194] (II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
[    36.194] (II) VESA(0): VESA VBE OEM Product: Intel(R) Sandybridge/Ivybridge Graphics Controller
[    36.194] (II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
[    36.198] (II) VESA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
...
...
...
[    36.211] (II) VESA(0): h_active: 1920  h_sync: 1980  h_sync_end 2028 h_blank_end 2050 h_border: 0
[    36.211] (II) VESA(0): v_active: 1080  v_sync: 1090  v_sync_end 1100 v_blanking: 1130 v_border: 0
...
...
...
[    36.211] (II) VESA(0): Printing DDC gathered Modelines:
[    36.211] (II) VESA(0): Modeline "1920x1080"x0.0  139.00  1920 1980 2028 2050  1080 1090 1100 1130 -hsync -vsync (67.8 kHz)
...
...
...
[    36.221] (II) VESA(0): Not using built-in mode "1280x1024" (no mode of this name)
[    36.221] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
[    36.221] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
[    36.221] (II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
[    36.221] (--) VESA(0): Virtual size is 1920x1080 (pitch 1920)
[    36.221] (**) VESA(0): *Built-in mode "1920x1080"
...
...
...
[    36.246] (II) VESA(0): Setting up VESA Mode 0x17F (1920x1080)

Anyone? :)

thorkelljarl 07-20-2012 12:15 PM

No Optimus...

You're trying to get one of the two graphics chips configured, but the fact that they function coupled to each other seems to get in the way.

Wouldn't it be easier to try to use Optimus under Bumblebee rather than trying to get the hardware to do something it isn't willing to do?

stason 07-20-2012 05:30 PM

Thank you for your reply.

I have tried Bumblebee and it does not work for GTX670M - https://github.com/Bumblebee-Project...bee/issues/187 (known issue, apparently), so I did a fresh re-install.

I am sure there is a way of forcing a lower resolution on integrated Intel card, I just don't know where to look for it, but I'm sure it should be in one of the config files somewhere.

Any more clues guys?


All times are GMT -5. The time now is 01:26 PM.