LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 08-12-2004, 09:35 PM   #1
caovankhanhvn
LQ Newbie
 
Registered: Mar 2004
Posts: 27

Rep: Reputation: 15
Can not turn off power with Slackware 10


My laptop does not turnoff power when I type in the console :


Quote:
poweroff

Althought I had done a the think like those :
In /ect/lilo.conf , I add :

Quote:
append="hdd=ide-scsi apm=power-off"
In /etc/rc.d/rc.modules , I change :
Quote:
#/sbin/modprobe ide-scsi
to
/sbin/modprobe ide-scsi
How should I do ? ?
 
Old 08-13-2004, 01:09 AM   #2
lethargo
LQ Newbie
 
Registered: Aug 2003
Location: St. Paul, Minnesota, US
Distribution: Slackware 10
Posts: 27

Rep: Reputation: 15
Could the laptop want ACPI power control?

Could the laptop be wanting ACPI for power control instead of APM? I installed Slackware on my desktop, chosing the bare.i kernel, and Slackware wouldn't power the machine down. The next time I installed Slackware (I play around a lot), I chose the bareacpi.i kernel with ACPI support. Then Slackware could power down my desktop.

I don't know much about power management, so I may be way off base; it's just a thought. Do you remember what kernel you picked when you installed Slackware? The same one the installer used? One you picked from the list of kernels on the CD (like bare.i, bareacpi.i, etc.)?
 
Old 08-13-2004, 02:18 AM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
You don't need either of the changes you made.

In /etc/rc.d/rc.modules, find this section (it's near the top):

Code:
#### APM support ###
# APM is a BIOS specification for saving power using several different
# techniques. This is mostly useful for battery powered laptops.
#/sbin/modprobe apm
Uncomment that modprobe line "/sbin/modprobe apm", and your machine will power off.
 
Old 08-13-2004, 03:54 AM   #4
caovankhanhvn
LQ Newbie
 
Registered: Mar 2004
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Uncomment that modprobe line "/sbin/modprobe apm", and your machine will power off.
Nothing happened .

Anything in lilo.conf ? ? ?
 
Old 08-13-2004, 04:00 AM   #5
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
It isn't going to take effect until the next time you restart your machine.
 
Old 08-13-2004, 04:30 PM   #6
SBing
Member
 
Registered: Mar 2004
Posts: 519

Rep: Reputation: 35
Just to add support to this option, this is what I did a couple of days ago and it worked for me :)

# modprobe apm
# shutdown -h now

As opposed to hanging with "Power Off" it actually shutdown. Uncommenting the line in modules.conf will avoid having to modprobe for apm manually.
 
Old 08-13-2004, 08:49 PM   #7
caovankhanhvn
LQ Newbie
 
Registered: Mar 2004
Posts: 27

Original Poster
Rep: Reputation: 15
Dear SBing :

Quote:
root@SlackOnLaptop:~# modprobe apm
/lib/modules/2.4.26/kernel/arch/i386/kernel/apm.o.gz: init_module: No such device
/lib/modules/2.4.26/kernel/arch/i386/kernel/apm.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.26/kernel/arch/i386/kernel/apm.o.gz: insmod /lib/modules/2.4.26/kernel/arch/i386/kernel/apm.o.gz failed
/lib/modules/2.4.26/kernel/arch/i386/kernel/apm.o.gz: insmod apm failed
root@SlackOnLaptop:~#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Wont turn off automatically marigb Linux - Hardware 5 11-16-2005 09:08 PM
Turn off Power save mode killersheep Debian 2 07-12-2005 05:34 PM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 04:22 PM
Mandrake 9.2 does not turn off power at shutdown dancro Mandriva 12 03-19-2004 07:41 AM
Turn on power through network? trees Linux - Networking 6 01-21-2004 02:25 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration