LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-29-2003, 12:26 PM   #1
jzero
LQ Newbie
 
Registered: Sep 2003
Distribution: Redhat 9
Posts: 3

Rep: Reputation: 0
Exclamation Can't get dvd/cdrom drive mounted on toshiba laptop


hey all,

been working w/ this for a few days now and just can't get the cd/dvd rom drive mounted. specs below:

Toshiba Satellite 5205-s505
Redhat 9
Kernel version 2.4.19

when I try to mount the device via:
mount /mnt/cdrom/
or
mount -t iso9660 /dev/cdrom /mnt/cdrom
i get the error
mount: /dev/cdrom is not a valid block device

the cdrom drive appears to be at /dev/hdb with a symbolic link from /dev/cdrom. fstab has an entry for /dev/cdrom. I've tried recompiling the kernel with IDE/ATAPI CDROM support built in and as a module, also tried compiling with SCSI CDROM support as well, both built in and as a module to no avail.
Anyone else having this problem, or am I doing something wrong?

Thanks for your help in advance!
j0


Last edited by jzero; 09-29-2003 at 02:17 PM.
 
Old 09-29-2003, 02:27 PM   #2
frankieboy
LQ Newbie
 
Registered: Aug 2003
Location: Germany/Hessen/Kassel
Distribution: RedHat 9.0A
Posts: 11

Rep: Reputation: 0
How about kernel-parameters

If you're using LILO you should add
append hdc=ide-scsi

With GRUB set
hdc=ide-scsi
directly behind the kernel-call.

Pls give feedback, if this hint helps you

Best regards

Frank
 
Old 09-29-2003, 02:34 PM   #3
jzero
LQ Newbie
 
Registered: Sep 2003
Distribution: Redhat 9
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Frank,

Thanks for responding so quickly

Here's what's in my grub.conf right now, not exactly sure what the insmod is for, got it from a document on getting linux working on this model:

kernel /k2419 ro root=/dev/hda2 insmod hdb=ide-scsi vga=0x31b idebus=66

Thanks again!
j0
 
Old 09-29-2003, 03:40 PM   #4
frankieboy
LQ Newbie
 
Registered: Aug 2003
Location: Germany/Hessen/Kassel
Distribution: RedHat 9.0A
Posts: 11

Rep: Reputation: 0
Hello j0,

pls type lsmod and look for these entries:

sr_mod 18136 0 (autoclean)
ide-scsi 12208 0
scsi_mod 107544 3 [sg sr_mod ide-scsi]
ide-cd 35712 0
cdrom 33728 0 [sr_mod ide-cd]

Then check if /dev/cdrom is a link to /dev/scd0

RU
Frank
 
Old 09-29-2003, 04:11 PM   #5
jzero
LQ Newbie
 
Registered: Sep 2003
Distribution: Redhat 9
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Frank,

Here's the what lsmod spits out:

Module Size Used by Tainted: PF
nvidia 1676448 10 (autoclean)
vmnet 23496 6
vmmon 27828 0 (unused)
keybdev 2944 0 (unused)
mousedev 5492 1
hid 22148 0 (unused)
input 5728 0 [keybdev mousedev hid]

no entry for anything scsi as far as I can tell.
It looks like /dev/cdrom is a link to /dev/hdb but it doesn't look like anything's pointing to /dev/scd0

Thanks again!
j0
 
Old 09-29-2003, 08:41 PM   #6
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
just went through this with my dad after we enabled scsi emulation. my guess coincides with yours in that /dev/cdrom isn't a valid block device any longer because it points to hdX (usually hdb or hdc). basically check your /dev folder and look for any cdrom links (cdrom, cdrom1, cdrom2, etc...). look at their properties and see where they point to. to test out open up your shell terminal and instead of using /dev/cdrom try using /dev/scd0 or /dev/scd1. if you get an error message about bad fs or no medium found, then you're half way there to figuring out the scsi mapping. if your drive used to be hdb, my guess is that the device block you want would be /dev/scd0. i'm also guessing, from what i experienced, that kudzu automatically created more /dev/cdromX links in /dev. all you have to do is delete /dev/cdrom and rename the right /dev/cdromX to /dev/cdrom.

Last edited by megaspaz; 09-29-2003 at 08:44 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
partitioning a mounted drive or from a boot DVD bnj Linux - Newbie 5 05-20-2005 06:01 AM
replaced cdrom with dvd/cdrw on my laptop blacksunshine Linux - Hardware 3 06-06-2004 01:23 AM
getting my dvd player to work on toshiba laptop harrycrumb11 Linux - Laptop and Netbook 11 09-26-2003 01:36 AM
CDROM drive can not be mounted fedel Programming 2 08-12-2002 09:50 AM
Installing RH 7.2 on Toshiba laptop w/pcmcia cdrom bigslim Linux - Hardware 2 03-31-2002 10:54 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration