LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 03-30-2011, 10:52 PM   #1
algorhythm
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Rep: Reputation: 0
Can't Disable Touchpad Tap-to-Click (Sony Vaio S) (openSUSE 11.4)


I have a brand new Sony Vaio S with a big sensitive touchpad that is making it very difficult to type more than a couple lines without accidentally clicking something. I've been scouring the internet for a way to turn off touchpad tap=click this evening and have decided I need to post this here. Some things I've learned already:

First of all, I have installed synaptic (which did not come pre-installed with openSUSE 11.4 interestingly). When I try to run it (or when I click "TouchPad" in Control Center I get the following classic error:

GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics

Regarding "/etc/X11/xorg.conf": this file does not exist in openSUSE 11.4. Instead there is "xorg.conf.install" and a directory called "xorg.conf.d" There is a file "50-synaptics.conf" in the directory. Adding:

Option "SHMConfig" "true"

here does not allow me to run synaptics. Being unable to run synaptics, I looked for other ways. A lot of people simply changed their "/etc/X11/xorg.conf" (which again does not exist) to include

Option "MaxTapTime" "0"

I've tried adding this to "/etc/X11/xorg.conf.install" and to "/etc/X11/xorg.conf.d/50-synaptic.conf" to no avail. Which leads to this forum post and me being out of ideas.

Thanks in advance.
 
Old 03-30-2011, 11:03 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
Look for the options "TapButton1", "TapButton2" and "TapButton3" in the 50-synaptics.conf-file and change the values to "0". Then reboot. This should disable the tapping.
 
Old 03-30-2011, 11:09 PM   #3
algorhythm
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
Look for the options "TapButton1", "TapButton2" and "TapButton3" in the 50-synaptics.conf-file and change the values to "0". Then reboot. This should disable the tapping.
Those options weren't there in "50-synaptic.conf" I added them though. It didn't work.
 
Old 03-31-2011, 08:32 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097Reputation: 4097
For reference, I show you my 50-synaptics.conf:
Code:
Section "InputClass"
	Identifier "touchpad"
	Driver "synaptics"
	MatchDevicePath "/dev/input/event*"
	MatchIsTouchpad "on"
	Option "TapButton1" "1"
	Option "TapButton2" "0"
	Option "TapButton3" "0"
	Option	"VertEdgeScroll"	"1"
EndSection
Keep in mind that I have tapping enabled ("TapButton1" "1").
 
Old 03-31-2011, 02:04 PM   #5
algorhythm
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Here's mine, which does not turn off touchpad clicking:
Code:
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event"
	Option  "SHMConfig" "1"
        Option	"HorizScrollDelta"	"0"
	Option  "TapButton1" "0"
	Option  "TapButton2" "0"
	Option  "TapButton3" "0"
EndSection
I've also tried reinstalling gsynaptics (which seems to be ignoring this file).

Also of note, I still can't run the synaptics gui (by clicking Touchpad in Control Center). The error is:

Quote:
Originally Posted by GSynaptics Error
GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics
As you can see I've tried to set that above. I've tried "true", and "1". My guess is that this is the wrong place. But GSynaptics is asking for the change in xorg.conf, which again, is a file that doesn't exist. I could try to put "SHMConfig" "true" in xorg.conf.install, but I have no idea what section it would go in.
 
Old 03-31-2011, 08:15 PM   #6
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 726

Rep: Reputation: 114Reputation: 114
Just go to Personal Settings (Configure Desktop), Hardware, Input Devices. If it's seen as a touchpad and the drivers are properly loaded, there will be a touchpad section with a tapping tab. You can simply disable tapping there.
 
Old 04-01-2011, 02:55 PM   #7
algorhythm
LQ Newbie
 
Registered: Mar 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Timothy Miller View Post
Just go to Personal Settings (Configure Desktop), Hardware, Input Devices. If it's seen as a touchpad and the drivers are properly loaded, there will be a touchpad section with a tapping tab. You can simply disable tapping there.
This thread is discussing that the touchpad tab is not present in the Control Center -> Mouse window. Something is wrong with the the driver and/or gsynaptics.
 
Old 04-02-2011, 09:23 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I have a Sony VPCF11 laptop. I know it's a different model from yours, but maybe it has the same touchpad hardware.

I had major troubles with the touchpad, and wanted to disable tap-to-click.

You should see the thread here for more information, and suggestions for getting it working, or disabling it completely (which is what I did in the end).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable "tap to click" on touchpad jsteel Linux - General 3 03-13-2011 02:01 PM
Disable touchpad "tap-to-click" Dankles Ubuntu 20 03-28-2009 12:17 AM
laptop touchpad - how to disable 'tap to click'?? Adrian Baker Linux - Laptop and Netbook 2 01-17-2006 06:15 PM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 09:57 PM
Make touchpad tap register as click drigz Linux - Software 8 10-15-2004 01:22 PM


All times are GMT -5. The time now is 08:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration