LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 06-06-2004, 09:01 PM   #1
Travis S
LQ Newbie
 
Registered: Jan 2004
Location: Kansas City, Missouri
Distribution: Fedora Core 1
Posts: 25

Rep: Reputation: 15
Broadcom built-in wireless


Howdy all,

Welp, I got back home with a new laptop at 3 PM, it's not 9 PM and while I have Linux successfully installed on it, I can not use it's built in wireless card.

I have gone through the whole config process as outlined by the HCL and a few alternates here in the forums. This is where I stand with it:

ndiswrapper -l displays:
Quote:
Installed ndis drivers:
bcmwl5 present
iwconfig displays:
Quote:
wlan0 IEEE 802.11g ESSID:"" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate=54Mb/s Tx-Power:16 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
And my /etc/network-scripts/ifcfg-wlan0 has:
Quote:
# Acer Wireless
DEVICE=wlan0
BOOTPROTO=dhcp
TYPE=Wireless
MODE=Managed
ESSID=domain51
GATEWAY=
CHANNEL=11
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
HWADDR=
IPV6INIT=no
ONBOOT=no
USERCTL=no
PEERDNS=yes
RATE=Auto
I have tried setting that up myself with a bare minimum, and with the redhat config utility which adds all of the blank pieces in.

I'm really at a loss. From everything I've read, once ndiswrapper shows "present" it looks like you're home free. I've been "home free" for the last 2 hours now... And I still have to plug this machine into the router in order for it to work. Any ideas would be greatly appreciated.

Thanks!
 
Old 06-06-2004, 11:01 PM   #2
Ohnodoctor
LQ Newbie
 
Registered: Feb 2004
Distribution: Slack Gentoo
Posts: 5

Rep: Reputation: 0
Did you set up your routing tables?
Try:

Code:
#route
If that displays only a loopback device then you need to add your gateway. I believe it's:

Code:
route add default gw 192.168.0.1
Change '192.168.0.1' to the ip of your router. Then, you might need an IP address if the redhat utility doesn't do this for you.

Code:
dhcpcd wlan0
I believe this should work, if not then try switching the last two steps around.
 
Old 06-06-2004, 11:23 PM   #3
Travis S
LQ Newbie
 
Registered: Jan 2004
Location: Kansas City, Missouri
Distribution: Fedora Core 1
Posts: 25

Original Poster
Rep: Reputation: 15
Hadn't run "route" at all. Hadn't seen it anywhere else as something that was needed. Here's what I got when I ran it:
Code:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
169.254.0.0     *               255.255.0.0     U     0      0        0 lo
127.0.0.0       *               255.0.0.0       U     0      0        0 lo

# route add default gw 192.168.2.1
SIOCADDRT: Network is unreachable

# ping 192.168.2.1
connect: Network is unreachable
Of course, when I plug in my network cable and ifup eth0, my route output changes to more what I would expect it to be:
Code:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         192.168.2.1     0.0.0.0         UG    0      0        0 eth0
Any ideas? I just realized I didn't post what I was getting when I attempt to run ifup wlan0, so here it is:
Code:
# ifup wlan0

Determining IP information for wlan0... failed; no link present.  Check cable?
Obviously, that error message doesn't help too much. I'm at a loss, and would appreciate anybody elses thoughts...
 
Old 06-06-2004, 11:46 PM   #4
esears
Member
 
Registered: Mar 2004
Location: Iraq, Baghdad
Posts: 32

Rep: Reputation: 15
wlan0 IEEE 802.11g ESSID:"" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462GHz Access Point: FF:FF:FF:FF:FF:FF


Notice the part where it says ESSID"". This indicates that your card isn't affiliating with your AP point. Try the following command:

iwconfig wlan0 essid "ANY"

That will affialite it with any access point in area. Most homes only have one point so it's not neccasary to indicate just the right name. However depending on your situation you can replace it with the right ESSID that your AP is broadcasting off.
 
Old 06-07-2004, 07:31 AM   #5
Travis S
LQ Newbie
 
Registered: Jan 2004
Location: Kansas City, Missouri
Distribution: Fedora Core 1
Posts: 25

Original Poster
Rep: Reputation: 15
Sorry I didn't mention that, but I guessed that not being able to find the AP was the problem. I just don't know how to get it to find the AP.

I'm taking my laptop to work with me today and going to try a few buddies' cards. Right now it's getting to the point that it's not worth spending any more time, unless someone just sees something I've overlooked.
 
Old 06-07-2004, 07:54 AM   #6
pevelius
Member
 
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Debian, Familiar, OS X
Posts: 145

Rep: Reputation: 15
# iwconfig wlan0 channel 6 <---Your AP Channel Number here
(edited, i made syntax error in my post. look next post for details)

this should help you see your AP.

be sure to use 8k kernel stacks if you have 2.6.x kernel (it seems redhat has defaulted to 4k at least with core 2 and ndiswrapper doesnt work then).

-peve

Last edited by pevelius; 06-08-2004 at 07:21 AM.
 
Old 06-07-2004, 09:17 AM   #7
Travis S
LQ Newbie
 
Registered: Jan 2004
Location: Kansas City, Missouri
Distribution: Fedora Core 1
Posts: 25

Original Poster
Rep: Reputation: 15
Code:
#iwconfig wlan0 channel=6
Error : unrecognised wireles request "channel=6"
From everything else I've seen, I thought it was "channel 6" with no equal sign...?

I ran it without the equal sign and didn't receive any errors, however my iwconfig looks the same.

I'm running the default kernel with Fedora Core 2. I don't even have the 8k stack option. I'm downloading 2.6.6 right now and will be compiling it as soon as I get it transferred over. Hopefully, that's my problem.
 
Old 06-07-2004, 01:45 PM   #8
Travis S
LQ Newbie
 
Registered: Jan 2004
Location: Kansas City, Missouri
Distribution: Fedora Core 1
Posts: 25

Original Poster
Rep: Reputation: 15
Ok... The kernel (at least buy itself) is not the problem. I just compiled 2.6.6 with 8k Stacks, reinstalled ndiswrapper using "make install", and I still get the same timeout.

Any thoughts?
 
Old 06-07-2004, 05:15 PM   #9
pevelius
Member
 
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Debian, Familiar, OS X
Posts: 145

Rep: Reputation: 15
sorry about the = my bad. im a total noob. but ive done this once with my broadcomm, so:

still, are you sure you have the right frequency (channel)?

try

# iwlist wlan0 scan

(hope i got it right this time )

does it list any ap:s?
are they on the same channel as your card?

-peve

Last edited by pevelius; 06-07-2004 at 05:16 PM.
 
Old 06-08-2004, 07:53 AM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Have a read through this how-to and see if it helps. It is setting up a different card, but most of the basics are the same..
 
Old 09-10-2004, 08:08 PM   #11
Clark Bent
Member
 
Registered: Jul 2004
Distribution: Debian, FreeBSD, Slamd64
Posts: 201

Rep: Reputation: 30
Quote:
Originally posted by esears
wlan0 IEEE 802.11g ESSID:"" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462GHz Access Point: FF:FF:FF:FF:FF:FF


Notice the part where it says ESSID"". This indicates that your card isn't affiliating with your AP point. Try the following command:

iwconfig wlan0 essid "ANY"

That will affialite it with any access point in area. Most homes only have one point so it's not neccasary to indicate just the right name. However depending on your situation you can replace it with the right ESSID that your AP is broadcasting off.
THANKS Esears! I couldn't get mine to work. Had the EXACT problem...changed it to essid any and wham! She's up! Yahooo! Man that was painful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Wireless (BCM4306) Wireless problems: modprobe ndiswrapper freezes HP Laptop shthap3ns Linux - Hardware 11 02-11-2007 12:53 PM
gateway 200arc laptop FC3, broadcom bcmwl5 built-in wireless card problem razcal Linux - Wireless Networking 6 03-12-2005 07:33 PM
wireless problems; Broadcom 802.11G Mini PCI Wireless with redhat WS surfbass Linux - Laptop and Netbook 1 12-17-2004 12:48 PM
Broadcom 802.11g built in wireless klfreese Linux - Hardware 6 07-01-2004 12:30 AM
Broadcom built-in wireless card Travis S Linux - Wireless Networking 0 06-07-2004 03:42 PM


All times are GMT -5. The time now is 12:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration