LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Broadcom 4318 Chipset issue with-in UE 2.8 (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/broadcom-4318-chipset-issue-with-in-ue-2-8-a-851815/)

ichase 12-22-2010 09:26 AM

Broadcom 4318 Chipset issue with-in UE 2.8
 
I know there has been a million and one posts about the broadcom issue and I can assure you, I believe I have read about 80% of them. I was really hoping to find the solution with out having to submit yet another post on this subject. :banghead:

Here is what I have as far as hardware goes:
Compaq Presario V2000
- PROCESSOR: Intel Pentium M 710 -- 1.4 GHz
- RAM 2 GB
- HD 80 GIG
- Duel booting XP Pro with Ultimate Edition 2.8(I understand this is built from Ubuntu 10.10...Correct me if I am wrong)(wireless works fine in XP)
- lspci -vnn | grep 14e4 yeilds the following:
Code:

03:00.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
I have followed to the tee this guidance:https://help.ubuntu.com/community/Wi...er/bcm43xx#b43
I tried the installing b43 drivers with internet (using ethernet)
I tried installing off the DVD using the no internet option
I even tried installing the STA drivers even though I know the 4318 chipset is not mentioned as a supported chipset. (I read where someone had luck with this)

All of these were loaded/extracted with no errors via terminal following the guidance to the letter.

Now here is a problem I have not read that anyone else has run into. (maybe I just missed it)
When I go: System > Administration > Additional Drivers the only additional driver that shows up is "Software Modem"

I can't for the life of me figure out why the b43 and STA drivers are not showing up to activate. :confused:I can install drivers all day long, if I can't activate them, it really does become a moot point.

Thank you in advance for all of you that take the time to respond.:hattip:

I wish you all the happiest of holidays and a great 2011!!!!:)

All the best,

Ian

aus9 12-23-2010 02:13 AM

hi

I am aware there are issues because some have different versions

this newish distro claims better support for Broadcom..

check out the manual and info page if you like

http://www.remastersys.com/forums/index.php?topic=976.0

http://www.bandshed.net/pdf/AV4Manual.pdf

good luck as I do not have br

ichase 12-23-2010 09:24 AM

I wanted to post that the problem is pretty much resolved. I had DL the firmware and did everything else that was required, but I had not "Loaded" the modules. Once I typed
Code:

sudo modprobe b43
My wireless instantly came up. I had previously gone into Network tools and set the ESSID and the password but that did not work. I saved it so once the module was loaded, it automatically connected to my network with the ESSID and Password I had previously set up. It even prompted me to load the proprietary b43 driver that was not showing before in my System > Administrator > Additional Hardware. Not to mention, my signal strength runs anywhere between 75% to 90% MUCH faster than I am getting on my XP partition on the same Lappy.

Now the only issue I am having is, when I re-boot, I have to re-load the modules manually sudo modprobe b43. I need to see if there is a way to write a script that will run this command upon boot. Maybe adding it to my /etc/modules folder

So once you have followed the directions on setting up the B43 firmware, make sure you Load the modules. :)

Also, thank you aus9 for replying to my post and providing additional guidance. I hope you and yours have a wonderful holiday and a great 2011.

All the best,

Ian

ichase 12-23-2010 10:11 AM

Actually did some research. If you happen to be having the same issue with the module not loading, go to /etc/modules edit by adding b43 at the bottom.
Such as:
Code:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
b43

All the best,

Ian

aus9 12-23-2010 04:13 PM

glad you solved it without my assistance

when you get a chance, can you mark your post as solved so others searching the forums can see what to do pls

happy surfing.


PS this link seems to explain what driver you need (for those researching)
http://linuxwireless.org/en/users/Drivers/b43

ichase 12-29-2010 07:14 AM

Quote:

Originally Posted by aus9 (Post 4201525)
glad you solved it without my assistance

when you get a chance, can you mark your post as solved so others searching the forums can see what to do pls

happy surfing.


PS this link seems to explain what driver you need (for those researching)
http://linuxwireless.org/en/users/Drivers/b43

I appologize aus9, I actually did not know how to do that. I looked into it a few days ago. I have sense figured it out and the post should now reflect as solved. :)
Thank you for taking the time to provide additional guidance. I hope you have a wonderful 2011.

All the best,

Ian


All times are GMT -5. The time now is 07:00 PM.