LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 09-18-2013, 04:49 PM   #1
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Rep: Reputation: Disabled
Booting hangs at 'Enabling /etc/fstab'...


Hi,

I'm running CentOS 6.4 64 bits on my laptop and since this morning i cannot boot normally again, system hangs at 'Enabling /etc/fstab [OK];

The last thing i did yesterday evening was to power it down brutally because gnome's shutdown gui would hang. I'm not sure it's because of that though.

I have tried single user mode, rescue mode, tried things like mkswap -c and it won't go, meaning it's probably not a swap problem here. Also i have fsck'ed / and /home, no bad sectors there.

This is the laptop i bought for both work and home and i'm lost right now, please help me boot again normally.

Thank you.

Last edited by Vareg; 09-18-2013 at 04:51 PM.
 
Old 09-18-2013, 05:17 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,479

Rep: Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803
Quote:
'Enabling /etc/fstab [OK];
well things are mounting

use the install dvd in rescue mode and after you type in "chroot /mnt/sysimage"
read the log
for booting " /var/log/boot.log "
and find out what the error is
"nano should be installed by default
Code:
cd /var/log
ls
----- then from that list the log file ------
nano boot.log
 
Old 09-19-2013, 01:28 AM   #3
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
well things are mounting

use the install dvd in rescue mode and after you type in "chroot /mnt/sysimage"
read the log
for booting " /var/log/boot.log "
and find out what the error is
"nano should be installed by default
Code:
cd /var/log
ls
----- then from that list the log file ------
nano boot.log
Hi,

Well, there are both nano and vim, but /var/log/boot.log doesn't tell me more than what the failing bootstrap tells me... It's just displays the same usual welcome to CentOS ... up to Enabling /etc/fstab swaps: [OK]

Anything else i should try while rescue cd is on and sysimage mounted?
 
Old 09-19-2013, 02:50 AM   #4
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,467
Blog Entries: 11

Rep: Reputation: 184Reputation: 184
Take a look at /etc/fstab. See if its fromat in a sane way.
To test further action would be to create a chroot enviroment with your orginial partition then run mount -a -f -v to see if everything is good. For this do something like this

mount all your system partitions to /mnt
Code:
mount -t proc chproc /mnt/proc
mount -t sysfs chsys /mnt/sys
mount -t devtmpfs chdev /mnt/dev
mount -t devpts cdpts /mnt/dev/pts
chroot /mnt
mount -a -f -v # to check fstab
the line with -t devtmpfs might not work but you can also rebind the actual dev with
Code:
mount -B /dev /mnt/dev
You could also check the output of dmesg.
 
Old 09-19-2013, 03:16 AM   #5
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
Hi, i have looked at /etc/fstab many times yesterday and everything seemed normal there, although i admit i never paid attention to it before this nightmare started, didn't have too..

I will add the line
Code:
mount -a -f -v # to check fstab
to fstab but should i do that in single user mod or in rescue mode?

Although i am very concerned that since it's started i've had to power off the laptop brutally dozens of times because i get an error while trying to reboot from single user mode. Besides, SELinux is doing a disk labeling check every time i reboot from rescue mode. All in all i am very concerned with all those harsh moves, if i can call it that way. I don't know what i am doing to my hardware(which is brand new) because of all this.
 
Old 09-19-2013, 03:45 AM   #6
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
To test further action would be to create a chroot enviroment with your orginial partition ....

Wait, isn't it what the rescue mode does? mounting the system on /mnt/sysimage and accessing it via chroot?
 
Old 09-19-2013, 03:58 AM   #7
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
also, when you say creating a chroot environment, does it mean i have to replace everything in fstab by what you gave me?
 
Old 09-19-2013, 04:43 AM   #8
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
anyway, i've noticed something: if i append single 3 to the kernel parameter line at boot, instead of just single, i don't get a prompt, and it just hangs at Enabling /etc/fstab...
the only i can get a prompt is if i have 'rghb quiet single' as parameters, and i get the prompt right after Enabling /etc/fstab...
 
Old 09-19-2013, 04:46 AM   #9
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
now as to dmesg, should i grep for anything in particular? coz the output is like a kilometer long actually and looking at the last lines i can't tell there's anything wrong...
 
Old 09-19-2013, 05:34 AM   #10
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
You can enter into single user mode and try to boot the server using fastboot, it will skip the filesystem check and check whether you could boot without any issue .(skipping fsk it was recommended it was used for toubleshoot purpose )



Set Linux kernel option by editing grub.conf / menu.lst

Open grub.conf or menu.lst (usually located in /boot),
# vi /boot/grub.conf
Find kernel line and put fastboot at the end of the kernel line. In the end it should look as follow:
kernel /vmlinuz-2.6.18-92.1.22.el5 ro root=LABEL=/ console=tty0 console=ttyS1,19200n8 fastboot

Last edited by arun5002; 09-19-2013 at 05:36 AM.
 
Old 09-19-2013, 05:46 AM   #11
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by arun5002 View Post
You can enter into single user mode and try to boot the server using fastboot, it will skip the filesystem check and check whether you could boot without any issue .(skipping fsk it was recommended it was used for toubleshoot purpose )



Set Linux kernel option by editing grub.conf / menu.lst

Open grub.conf or menu.lst (usually located in /boot),
# vi /boot/grub.conf
Find kernel line and put fastboot at the end of the kernel line. In the end it should look as follow:
kernel /vmlinuz-2.6.18-92.1.22.el5 ro root=LABEL=/ console=tty0 console=ttyS1,19200n8 fastboot
Hi, i wasn't able to locate grub.conf as in boot there's only /grub and /efi and in /grub there's no grub.conf.
However, i've added fastboot to my kernel parameter line was booting and although the bootstrat output comes shorter than before, it still hangs on Enabling /etc/..... Could that be some sort of indication already?
 
Old 09-19-2013, 05:53 AM   #12
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
maybe this will help:
in /var/log/dmesg

the two last lines are:
Quote:
Adding 5586936k swap on /dev/mapper/vg_236-lv_swap. Priority:-1 extents:1 across 5586936k
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts
 
Old 09-19-2013, 07:50 AM   #13
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,467
Blog Entries: 11

Rep: Reputation: 184Reputation: 184
Quote:
Originally Posted by Vareg View Post
I will add the line
Code:
mount -a -f -v # to check fstab
to fstab but should i do that in single user mod or in rescue mode?
This are lines to be run from command line and not added to your fstab.

chroot stands for change root and in somekind of way is what rescue modes do but not to the full attend. The process would be to mount your normal filesystem somewhere inside the rescue mode filesystem. I just took /mnt for this as this is normaly the way to go. As it seems the rescue system already does this to some kind of degree.
Lets clear things up even more.

1.) Boot into rescue mode
2.) Start a shell
3.) run mount to see what filesystems are mounted already.

Okay now we have to see if anything of your normal filesystem is mounted. And if is you have to be sure that really every part of it is mounted. Depends on how you partitioned your disk. Check the output of mount if it contains something like sda which should be your first harddisk.

For the next step you have to make sure that you have mounted you normal filesystem completly to /mnt.
We now are going to include some other needed pseudo filesystems.
Code:
mount -t proc chproc /mnt/proc
mount -t sysfs chsys /mnt/sys
mount -t devtmpfs chdev /mnt/dev
mount -t devpts cdpts /mnt/dev/pts
See my first post here for possible errors.
We now have your normal system mounted and ready to be run as though you have booted from it. Next step is to change into this so only this part is seen for all programs and the kernel. We need to change root

Code:
chroot /mnt /bin/bash
We now are inside your normal system and see if the fstab is all good.

Code:
mount -a -v -f
This makes sure that fstab is correct.

What you definetly should be on the lookout inside your fstab are filesystem that are remote. Like nfs.

For the dmesg output you might need to wade through all of it. Or see what is the output off:
Code:
dmesg | grep -i error
dmesg | grep -i firmware
dmesg | grep -i failure
While the rescue mode is up. Try to get the original fstab of your system and put it here.
 
Old 09-19-2013, 08:17 AM   #14
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks Zhjim for the detailed steps, however, having booted in rescue mode with the install dvd, started a shell, ran mount | grep sda, i found sda1 and sda2, passed that, everything seemed mounted normally, but... then i tried mount -t proc chproc /mnt/proc and got mount point /mnt/does not exist. I tried chroot /mnt/sysimage and tried again but same. I must be missing something here.
But can you please tell me if there's a way to avoid having SELinux relabeling my disk upon reboot?
 
Old 09-19-2013, 08:29 AM   #15
Vareg
LQ Newbie
 
Registered: Aug 2013
Distribution: Centos 6.4 x86_64
Posts: 14

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by zhjim View Post
Code:
dmesg | grep -i error
dmesg | grep -i firmware
dmesg | grep -i failure
actually, onlydmesg | grep -i firmware returns something which is(typing all by hand):
Code:
[Firmware Info]:CPU: Re-enabling disable Topology Extensions Support
[Firmware Info]:CPU: Re-enabling disable Topology Extensions Support
platform radeon_cp.0: firmware: requesting radeon/ARUBA_pfp.bin
platform radeon_cp.0: firmware: requesting radeon/ARUBA_me.bin
platform radeon_cp.0: firmware: requesting radeon/ARUBA_rlc.bin
platform radeon_cp.0: firmware: requesting radeon/TURKS_pfp.bin
platform radeon_cp.0: firmware: requesting radeon/TURKS_me.bin
platform radeon_cp.0: firmware: requesting radeon/BTC_rlc.bin
platform radeon_cp.0: firmware: requesting radeon/TURKS_mc.bin
r8169 0000:05:00.0: firmware: requesting rtl_nic/rt18105e-1.fw
Can the problem be with my radeon HD x7000s series? Hoping not...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power failure - boot hangs (after enabling /etc/fstab swap [OK]) workaholicbe Linux - Software 5 01-17-2013 11:31 AM
Enabling local filesystem quotas [ok] ...HANGS (PC HANGS) RHEL 5 please help maxy Red Hat 2 05-09-2011 06:46 AM
Enabling /etc/fstab swaps adarshmca Linux - Newbie 2 01-04-2011 12:20 AM
System hangs on "Enabling /etc/fstab swaps :" rajb366a Linux - Hardware 2 01-05-2009 07:25 PM
Sony Vaio PCG-NVR23 Booting FC2, hangs after "Enabling Swap Space" mgargiullo Fedora 1 09-08-2004 10:47 AM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration