LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-20-2009, 11:06 AM   #1
pruesdn
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
Boot hangs for several minutes?


I've had quite the journey with my EeePC 701. I started learning about Linux with the prepackaged Xandros, then quickly ran out of customizability in tweaking it. I switched for a time to Ubuntu-eee (now Easy-Peasy), but my performance suffered too much for my liking. So I found Eeebuntu base and thought I'd found what I'd been looking for. But the boot time really left a lot to be desired: I've heard it's generally about a minute, but mine takes almost 5. I really started digging into this recently and discovered that one particular part of my boot process hangs for several minutes:

input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9

waits for a few minutes, then returns:

[Fail]

My apologies for being more or less a newbie to the Linux scene, but what's going on here and what do I do about it?
 
Old 03-20-2009, 11:21 AM   #2
manwithaplan
Member
 
Registered: Nov 2008
Location: ~/
Distribution: Arch || Sidux
Posts: 393

Rep: Reputation: 45
I would try editing your xorg.conf file. I think maybe xorg-server's auto detect is taking unusually long.

Try adding these lines at the beginning of your /etc/X11/xorg.conf


Code:
Section "ServerFlags"
Option "AutoAddDevices" "off"
EndSection
See if this helps, I still think its your xorg.conf file...

Also you can go to
Quote:
System > Preferences > Sessions
and uncheck all that isnt needed, like login sounds, visual assistance, tracker, beagle anything that takes resources to start. You can always add delays to these startups if needed with a
Code:
-sleep (x)
command
 
Old 03-20-2009, 12:52 PM   #3
pruesdn
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Adding that section to my xorg.conf does seem to make the boot process run a bit faster, but it didn't have any effect whatsoever at the ~2 minute stall after the line printed above; after the stall, it just prints [Fail] and moves on with the boot.

It did, however, seem to disable the easy-vertical-scroll feature on my touchpad, so I'll probably undo the xorg.conf change. Thanks for the suggestion, though.


I'd like to clarify that the boot process itself is not running terribly slow. There's just a single part of the boot that's causing a long delay. The rest of the boot process, before and after the stall, seems to be very quick.
 
Old 03-20-2009, 01:26 PM   #4
manwithaplan
Member
 
Registered: Nov 2008
Location: ~/
Distribution: Arch || Sidux
Posts: 393

Rep: Reputation: 45
Its still is a xorg.conf issue... Maybe even a HAL fdi policy issue. I would post your question in the Ubuntu forums and see if there is any similar problems... I'm sure that its a matter of adding & deleting a few lines in your config file.

Post your xorg.conf file. Let me see if there is something that could be changed.

Also again search Ubuntu forums and google you error message.
 
Old 03-20-2009, 03:41 PM   #5
pruesdn
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
My xorg.conf:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
 
Old 03-20-2009, 10:12 PM   #6
manwithaplan
Member
 
Registered: Nov 2008
Location: ~/
Distribution: Arch || Sidux
Posts: 393

Rep: Reputation: 45
Quote:
Originally Posted by pruesdn View Post

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
That's all... I can see now why there is a problem... you need to configure your xorg.

Go to this page here on configuring your xorg-server. Then try rebooting and see if the configuration has helped. You need to pay attention to configuring this in your xorg.conf:
Code:
input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input9
See if this forum site helps, if not you need to google this error and get example xorg entries and try entering them in your config file
 
Old 03-21-2009, 11:15 AM   #7
pruesdn
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I reconfigured my xorg, but the new configuration looks exactly like the old one. I used the dpkg method; how do others get the really complex xorg.conf files I see when I google?

Thanks for all the advice--sorry this is being obstinate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wall hangs on tty_write system call for about 15 minutes on debian 2.6 kernel kspradhan Linux - Server 1 08-30-2008 06:02 AM
Fedora 6 Hangs after 3 - 5 minutes of usage? The Dew Linux - General 1 02-06-2007 08:51 PM
Connect ( ) hangs for 3 minutes..how to reduce it santhosh.bachu Linux - Networking 2 07-22-2006 06:03 PM
Boot hangs for 3 minutes at "Starting syslogd daemons" DaneM Slackware 4 06-29-2005 10:52 PM
My Athlon System hangs after 5 minutes when i login to redhat 8 keshif Linux - Hardware 12 03-03-2004 01:12 PM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration