LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 06-17-2004, 05:53 PM   #1
CarletonKnight
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Rep: Reputation: 0
Black bar on right side of screen after installing NVidia 5336 drivers


I'm running RedHat Enterprise Linux with a 2.6.6 kernel on a Toshiba S501-5105 laptop. After installing, my nv driver worked fine, but couldn't run anything with GL acceleration.

I installed NVIDIA-Linux-x86-1.0-5336-pkg1.run, and followed the installation instructions. (su, init 3, sh NVIDIA*, change nv to nvidia in XF86Config, init 5)

Everything worked, EXCEPT for this ugly, 8mm black bar down the right side of my screen. I looked around on Google for a couple hours, but nobody seemed to have a reasonable solution. I even added the line
>> options NVdriver NVreg_SoftEDIDs=0 NVreg_Mobile=2
to my /etc/modules.conf file.

My device section currently reads,

Section "Device"
Identifier "Videocard0"
#Driver "nv"
Driver "nvidia"
Option "FlatPanel" "on"
Option "FlatPanelProperties" "Scaling = native"
VendorName "Nvidia (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Has anyone else had this problem? Ideas on how to fix it?

Thanks.
 
Old 06-18-2004, 05:07 AM   #2
paulo.oliveira
LQ Newbie
 
Registered: Jun 2004
Location: Recife, Pernambuco, Brazil
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Hi,

1. Have you disabled the DRI extension and enabled the GLX one?
2. If the answer is YES, your X11R6 logfile reports correctly the loading of the GLX extension?

The XF86Config change seems like this:

# This loads the GLX module
Load "glx"
# This loads the DRI module
# Load "dri"

Try it and give some feedback...

Sincerely,
 
Old 06-18-2004, 09:53 AM   #3
CarletonKnight
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Paulo,

Thanks for your reply. I double-checked my XF86config, and it looks like everything should be OK. The NVidia drivers run fine (I checked with the 'solar winds' screensaver), but they leave that black bar on the screen. If it'll help, here's my XF86config config file.
________________________________________
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1400x1050"
DisplaySize 300 229
HorizSync 31.5 - 90.0
VertRefresh 59.0 - 75.0
Option "dpms"
EndSection
Section "Device"
Identifier "Videocard0"
#Driver "nv"
Driver "nvidia"
Option "FlatPanel" "on"
Option "FlatPanelProperties" "Scaling = native"
VendorName "Nvidia (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
__________________________________
My XFree86 logfile, however, reports that "(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)" Does the NVIDIA driver not come with the GLX extension?

Thanks for your help,

Mark
 
Old 06-18-2004, 11:15 AM   #4
paulo.oliveira
LQ Newbie
 
Registered: Jun 2004
Location: Recife, Pernambuco, Brazil
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Hi Mark... :-)

Oooooooooops... "NVIDIA XFree86 driver not found"???

This message can help us a lot!

1. Do a sanity check! Check if your machine have the following files:

-> /usr/X11R6/lib/libXvMCNVIDIA.a
-> /usr/X11R6/lib/libXvMCNVIDIA.so
-> /usr/X11R6/lib/libXvMCNVIDIA.so.1
-> /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.5336
-> /usr/X11R6/lib/modules/extensions/libglx.so
-> /usr/X11R6/lib/modules/extensions/libglx.so.1.0.5336

2. Check if the "/usr/X11R6/lib" directory is in your LD_LIBRARY_PATH... Look at the "/etc/ld.so.conf" file. Running "ldconfig -v | grep NVIDIA" must return this:

libXvMCNVIDIA_dynamic.so.1 -> libXvMCNVIDIA.so.1.0.5336

3. Sanity check 2! Check the nvidia kernel module! It's loaded? Run "lsmod | grep nvidia". Must return:

nvidia 1965792 17

I hope that help you...

Sincerely,
 
Old 06-18-2004, 12:43 PM   #5
CarletonKnight
LQ Newbie
 
Registered: Jun 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Paulo,

My machine passes all the sanity checks. Everything looks just like it should.

I tried changing "scaling = native" to "scaling = centered". Interestingly, the NVIDIA drivers don't center the display on the LCD - they center it to the LEFT of the lcd. In other words, if my display didn't have that last 8/10s of a cm, then the NVIDIA drivers would be centering things perfectly.

I tried the same thing using patched drivers from the minion.de site, and got the exact same results - the patched drivers give me the same black stripe.

Thanks for all your time. I really appriciate it.

Mark
 
Old 07-06-2004, 09:06 PM   #6
sfagundes
LQ Newbie
 
Registered: Dec 2003
Location: Milwaukee, WI
Distribution: Ubuntu Breezy v5.10 x86
Posts: 11

Rep: Reputation: 0
try adding this line to at the end of the video card section where the "nvidia" tag is:

Option "IgnoreEDID" "True"

that line used to work for me like a charm, but I am currently having the same problem trying to use Fedora Core2. A good resource is www.linux-laptop.net!

Let me know if you have luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen after installing nvidia 6106 drivers Doktor Prokt Fedora 7 08-10-2004 05:39 AM
Toshiba 5100 & Nvidia - black bar on right side of my screen? rnmartinez Linux - Laptop and Netbook 0 06-10-2004 09:26 PM
Weird...Riva TNT2 Black Screen Nvidia Drivers... Skorpyo Linux - Newbie 2 01-30-2004 07:53 AM
new nvidia drivers bring black screen brandonloserkid Slackware 4 01-20-2004 09:35 PM
redhat 9 geforce 4 mx 440 nvidia drivers black screen baronsam Linux - Software 9 11-06-2003 08:04 PM


All times are GMT -5. The time now is 08:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration