LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 05-28-2005, 11:03 AM   #1
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Rep: Reputation: 0
Ati Mobility Radeon 9700 driver help in Ubuntu


I recently purchased a laptop and installed Ubuntu 5.04 on it. The laptop came with Ati Mobility Radeon 9700 and I have no idea how to get the driver for it to work. A friend of mine told me that all I had to do was install the xorg drivers from synaptic but that doesn't do any changes at all.

I've tried downloading the driver from ATI's website, but when I try to install it, I get:

dpkg: error processing fglrx-4-3-0_8.12.10-2_i386.deb (--install):
trying to overwrite `/usr/X11R6/lib/libGL.so.1.2', which is also in package xlibmesa-gl
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
fglrx-4-3-0_8.12.10-2_i386.deb

I'm not 100% sure if that is the right driver I should be using, since I don't know which XFree I have. I tried using that check.sh file while running root in terminal, but it just says "unable to determine what XFree version" so it didn't help me much.

I don't know what other info I should provide with this, so if anyone cares to help me but notices that info is missing, please reply which info and I will post it the moment i see it.

on forehand, thankyou
 
Old 05-29-2005, 05:26 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Xorg generally supports ATI cards without extra drivers. It is possible that it loaded the ati modules instead of the radeon module and that you don't need to install ATI's drivers.

In either case, you aren't running XFree which is why that error occurs.
Can you post the output of lsmod? Can you find out which driver xorg wants to load in your xorg.conf?
I'll try and help, but it might be a work in progress.


By guess, your 9700 is an R300 chipset

Last edited by musicman_ace; 05-29-2005 at 05:33 AM.
 
Old 05-30-2005, 08:01 AM   #3
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
I'm not sure what parts you need, so I'll just post the whole things from my lsmod and xorg.conf

LSMOD
Module Size Used by
speedstep_centrino 7892 1
proc_intf 4100 0
freq_table 4100 1 speedstep_centrino
cpufreq_userspace 4572 1
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
pcmcia 21380 4
video 16260 0
sony_acpi 6280 0
pcc_acpi 11264 0
button 6800 0
battery 10244 0
container 4608 0
ac 4996 0
ipv6 229504 9
af_packet 20744 4
ohci1394 31876 0
yenta_socket 19584 0
pcmcia_core 53568 2 pcmcia,yenta_socket
ipw2200 66156 0
firmware_class 9728 1 ipw2200
ieee80211 21252 1 ipw2200
ieee80211_crypt 5832 1 ieee80211
b44 20356 0
mii 4736 1 b44
snd_intel8x0 29984 1
snd_ac97_codec 64608 1 snd_intel8x0
snd_pcm_oss 47652 0
snd_mixer_oss 16768 2 snd_pcm_oss
snd_pcm 84872 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 23300 1 snd_pcm
snd 50276 6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 9824 2 snd
snd_page_alloc 9604 2 snd_intel8x0,snd_pcm
i2c_i801 8076 0
i2c_core 21264 1 i2c_i801
ehci_hcd 29444 0
uhci_hcd 30224 0
usbcore 107384 3 ehci_hcd,uhci_hcd
shpchp 86116 0
pci_hotplug 30512 1 shpchp
intel_agp 20636 1
agpgart 31784 1 intel_agp
rtc 12216 0
md 43856 0
evdev 9088 1
joydev 9408 0
tsdev 7488 0
dm_mod 53116 1
capability 5000 0
commoncap 7808 1 capability
sr_mod 16036 0
sbp2 22408 0
scsi_mod 119936 2 sr_mod,sbp2
ieee1394 100408 2 ohci1394,sbp2
psmouse 19336 0
mousedev 11160 1
parport_pc 34372 1
lp 10792 0
parport 33480 2 parport_pc,lp
ide_cd 38532 0
cdrom 36508 2 sr_mod,ide_cd
ext3 120968 1
jbd 54168 1 ext3
ide_generic 1664 0
piix 9988 1
ide_disk 18176 3
ide_core 118988 4 ide_cd,ide_generic,piix,ide_disk
unix 26164 846
thermal 13576 0
processor 22708 2 speedstep_centrino,thermal
fan 4612 0
fbcon 34048 0
font 8448 1 fbcon
bitblit 5120 1 fbcon
vesafb 6948 0
cfbcopyarea 3968 1 vesafb
cfbimgblt 3072 1 vesafb
cfbfillrect 3584 1 vesafb

XORG.CONF

# bare-bones XFree86 config to start the server in probe-only mode
Section "Files"
FontPath "/usr/share/X11/fonts/misc"
RgbPath "/etc/X11/rgb.txt"
EndSection
Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection
Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection
Section "Device"
Identifier "Generic Device"
Driver ":RIVER::"
EndSection
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Generic Device"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Generic Mouse"
EndSection
 
Old 05-30-2005, 09:07 AM   #4
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
The modules loaded for you graphics card are these, which aren't the best one to have loaded.
intel_agp
agpgart

And you xorg doesn't include dri or glx. It also doesn't state the specific driver that should be getting used. This is likely that the R300's are cvs versions and aren't considered stable. You'll have to check out the website I posted and read up on some documentation. Keep an eye on their site for new releases as they will get more stable with each release.
 
Old 05-30-2005, 10:29 AM   #5
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
I checked out that site, but since I'm still not used to Linux stuff, I don't know what files I need or how to install them.

I'm a
 
Old 05-30-2005, 02:06 PM   #6
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
when compiling the kernel, do you have the following selected as modules?


Device Drivers --> Graphics Support --> Support for Frame buffer devices
Device Drivers --> Graphics Support --> ATI radeon
Device Drivers --> Character Devices --> Direct Rendering Manager (Xfree86 4.1.0 & higher)
Device Drivers --> Character Devices --> ATI Radeon
 
Old 05-30-2005, 05:12 PM   #7
titetanium
Member
 
Registered: Mar 2004
Distribution: debian testing/unstable
Posts: 68

Rep: Reputation: 16
Hansiman,

First things first,

Did you resolve the apt-get situtation with the fglrx driver? You'll need to do this to fix this error:
Code:
dpkg -i --force-overwrite fglrx-4-3-0_8.12.10-2_i386.deb
.

The next step you need to do is to follow the instructions from this site:http://xoomer.virgilio.it/flavio.sta...installer.html.
Make sure you use section(s) 4.1, 4.5, and 5.
Section 6 has workarounds if you are experiencing any problems after getting the fglrx module compiled and working.

HTH,

Durand
 
Old 06-01-2005, 02:30 PM   #8
ewor
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Rep: Reputation: 0
Put this guide together myself from heaps of other guides i had read, i have posted it here also: http://ubuntuforums.org/showthread.p...5&page=5&pp=10


You need to install the headers for your kernel,use synaptic or whatever.

Ensure that there are no other fglrx drivers or ati drivers installed, might be under xorg drivers,

Ensure that there are no other fglrx drivers or ati drivers installed, might be under xorg drivers,

Ensure that there are no other fglrx drivers or ati drivers installed, might be under xorg drivers

the ones that are in the repositories for ubuntu 5.04 keep locking up and freezing dell inspiron 9100 s with the ati mobility 9800.
Oh depending on what kernel your using modify some of the lines below with the kernel version, i had been using 2.6.10-5-386 but i have since changed to the 686 smp kernel. Download the linux driver from ati, the xorg one, the latest when i was doing this was the fglrx_6_8_0-8.12.10-1.i386.rpm, then follow below.

~$ sudo apt-get install build-essential
//ensures you have compilers installed
~$ sudo alien fglrx_6_8_0-8.12.10-1.i386.rpm
//wherever you downloaded your linux driver,converts the rpm to a deb package
~$ sudo cp /usr/X11R6/lib/libGL.so.1.2 /usr/X11R6/lib/libGL.so.1.2.backup
~$ sudo rm /usr/X11R6/lib/libGL.so.1.2
//makes a backup and deletes original, cause will be installing different version
//the force overwrite below doesnt seem to always work for the above file
~$ sudo dpkg -i --force-overwrite fglrx-6-8-0_8.12.10-2_i386.deb
~$ sudo mv /lib/modules/2.6.10-5-386/kernel/drivers/video/fglrx.ko $HOME
//change this to whatever kernel you use, dont know why you have to do this
~$ cd /lib/modules/fglrx/build_mod/
~$ sudo chmod 777 make.sh
~$ sudo ./make.sh
~$ cd ..
~$ sudo chmod 777 make_install.sh
~$ sudo ./make_install.sh
~$ sudo dpkg-divert --package fglrx --add /usr/X11R6/lib/libGL.so.1.2
//dont know why ya have to do this either, but saw it as reccommended, but dont //know what it does
~$ sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
//backup your /etc/X11/xorg.conf file


--------modify your xorg.conf----------
1. Run fglrxconfig from terminal as a normal user in your home folder, this will save
xorg.conf in your home folder. (em dont mind people saying do not run this, it has been improved in the latest drivers, and wasnt that scary in the previous drivers, just annoying, but make sure you backup your original xorg.conf before running this)
2. Default all the options in fglrxconfig, or change as you need
3. After running xorgconfig comment out the section like below in your /etc/X11/xorg.conf



#Section "Device"
# Identifier "ATI Technologies, Inc. Radeon Mobility 9800 (M18 JN)"
# Driver "ati"
# BusID "PCI:1:0:0"
#EndSection



4. Add the section shown below from your xorg.conf in your home folder to /etc/X11/xorg.conf



Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "1"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "yes"
Option "ForceGenericCPU" "no"
# BusID "PCI:1:0:0" # no device found at config time
Screen 0
EndSection


5. Change the line
Identifier "ATI Graphics Adapter"
to
Identifier "ATI Technologies, Inc. Radeon Mobility 9800 (M18 JN)"
or whatever your adapter is named
6.Save your /etc/X11/xorg.conf file.


---------------finished editing xorg.conf--------------------------

-Ctrl alt f2
-login
~$ sudo killall gdm
~$ startx

-bring up a terminal
~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON 9800 Generic
OpenGL version string: 1.3.5010 (X4.3.0-8.12.10)

~$ glxgears
18581 frames in 5.0 seconds = 3716.200 FPS
38866 frames in 5.0 seconds = 7773.200 FPS

~$ fgl_glxgears
3700 frames in 5.0 seconds = 740.000 FPS
4312 frames in 5.0 seconds = 862.400 FPS
4417 frames in 5.0 seconds = 883.400 FPS
4465 frames in 5.0 seconds = 893.000 FPS


Runs ut2004 very smoothly at highest settings and resolution 1680x1050
 
Old 06-01-2005, 04:26 PM   #9
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
when I ran fglrxinfo, I got:

Xlib:
extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

glxgears:
1045 frames in 5.0 seconds = 209.000 FPS
1356 frames in 5.0 seconds = 271.200 FPS
1469 frames in 5.0 seconds = 293.800 FPS

fgl_glxgears:
Xlib: extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 30
Current serial number in output stream: 30


What did I do wrong?
 
Old 06-01-2005, 09:26 PM   #10
ewor
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Rep: Reputation: 0
Did you install the headers for your kernel?

What error messages did you get when running any of the steps?


The guide i gave should have worked for you if you followed it step by step, post up your /etc/X11/xorg.conf file. The xorg.conf contents you posted up already doesnt seem right, should have an section with ati in it, but post up your current xorg.conf file after trying my guide.


Note: If you have a 9700 mobility the xorg drivers that can be downloaded using synaptic would do the trick i think, but you have to edit your /etc/X11/xorg.conf file so your system uses them, but you should have no problems getting the ati driver from the website working.
 
Old 06-03-2005, 07:04 AM   #11
MaMatO
LQ Newbie
 
Registered: Mar 2003
Location: Jakarta
Distribution: Debian, Fedora Core, Ubuntu, Slackware, Mandrake, Xandros, Knoppix
Posts: 11

Rep: Reputation: 0
You don't have to compile the kernel. Just install xorg-driver-fglrx package.
Add the restricted section in your
Code:
/etc/apt/sources.list
then do the
Code:
apt-get install xorg-driver-fglrx
and
do
Code:
insmod fglrx
finally
Code:
dpkg-reconfigure xserver-xorg
to configure your X.
 
Old 06-03-2005, 05:58 PM   #12
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
I would like to try your way MaMaTo. But since I installed the driver from www.ati.com, I can't remove it, or overwrite it it seems. When using the apt-get I get:


Preconfiguring packages ...
(Reading database ... 69175 files and directories currently installed.)
Unpacking xorg-driver-fglrx (from .../xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb) ...
dpkg-divert: `diversion of /usr/X11R6/lib/libGL.so.1.2 to /usr/X11R6/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx' clashes with `diversion of /usr/X11R6/lib/libGL.so.1.2 to /usr/X11R6/lib/libGL.so.1.2.distrib by fglrx'
dpkg: error processing /var/cache/apt/archives/xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 06-04-2005, 07:41 PM   #13
Marshalle
Member
 
Registered: Mar 2005
Location: Auckland, New Zealand
Distribution: OpenSuSE, SLE, Yoper, Sabayon
Posts: 68

Rep: Reputation: 15
Talking

I am sure you could use this or adapt it (from Suse). Basically you install an RPM change your init level to 3 and run a simple command. It will then autodetect your ati card and enable 3d support for it. All you need to change is your physical screen size, be sure not to change your card, even if you think it is not right. During the test phase it garbled the screen but upon init 5 it was fine. I hope this helps someone. Link is below.

M

http://portal.suse.com/sdb/en/2005/04/akulk_ati93.html

 
Old 06-05-2005, 04:02 AM   #14
Hansiman
LQ Newbie
 
Registered: May 2005
Location: Bergen, Norway
Distribution: Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
Marshalle, I tried that, but one of the steps included a command, "sax2", which isn't recognized in Ubuntu =/
 
Old 06-05-2005, 05:25 AM   #15
Marshalle
Member
 
Registered: Mar 2005
Location: Auckland, New Zealand
Distribution: OpenSuSE, SLE, Yoper, Sabayon
Posts: 68

Rep: Reputation: 15
Got this from the command line

SaX2 - SuSE advanced X11 configuration, a complete module based X11
configurator

SaX2 is a program to configure the X-Server. It is able to detect
almost all stuff related to the graphics card. The graphics card,
Touchscreens, Tablets, 3D features, AccessX, Keyboard, Mouse, Multi‐
head, ... and more can be configured using this tool.

It's basically all run in command line, perhaps you could downlaod it and install it, not sure but I figure it just write a config tool somewhere, I know this ATI stuff is a pain, I had to muck around with this one a bit to get it going (basically just understanding the instructions). I have pasted the output from the --help command below so you can see what it was doing to the X server. You might be able to adapt it to a similar tool I get the feeling the GUI in linux doesn't quite like it hence you have to do it at the comman line.

[ -h | --help ]
show this message and exit

[ -b | --batchmode [ filename ]]
enable batch mode to set configuration options
via the SaX2 shell. Optionally give a full qualified file
location holding the profile data

[ -a | --auto ]
enable automatic configuration.

[ -l | --lowres ]
use only 640x480 60 Hz standard mode.
DDC detection is switched off in this case

[ -V | --vesa ]
This option will set a given resolution and vertical sync
value (in Hz) as VESA standard resolution for a specific
card. Format: Card:XxY@VSync
Example: 0:1024x768@85

[ -m | --modules ]
comma seperated list of X-Server modules
for example: -m 0=mga,1=nv

[ -c | --chip ]
chip number(s) to scan

[ -x | --xmode ]
use server build in Modelines

[ -u | --automode ]
use server mode suggestion

[ -p | --pci ]
show PCI/AGP information

[ -n | --node ]
set device node to use for the core pointer

[ -t | --type ]
set protocol type to use for the core pointer

[ -g | --gpm ]
use gpm as repeater of mouse events

[ -s | --sysconfig ]
this option tell SaX2 to import the system wide
config file even if SaX2 was started from a textconsole
which normaly will import the SaX2 HW detection
data

[ -i | --ignoreprofile ]
do not include profiles which are normally applied
automatically

[ -r | --reinit ]
remove detection database and re-init the
hardware database

[ -f | --fullscreen ]
start in fullscreen mode

[ -v | --version ]
print version information and exit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon Mobility 9600/9700 and TV IN logologics Linux - Hardware 0 09-05-2005 04:10 AM
ATI Radeon 9700 Mobility with Xorg? Wich driver? fedivh Linux - Hardware 1 11-07-2004 04:48 PM
ATI Mobility Radeon 9700 motovoi Linux - Laptop and Netbook 0 10-28-2004 05:08 AM
ati radeon 9700 mobility and suse 9.1 pro percent20 Linux - Laptop and Netbook 2 08-30-2004 02:35 AM
RHE3 & ATI Mobility Radeon 9700 JamesR22 Linux - Laptop and Netbook 6 08-20-2004 10:34 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration