LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 12-22-2005, 03:47 AM   #1
lydgate
Member
 
Registered: Jun 2005
Location: Fullerton, CA
Distribution: Arch 0.7.1 (laptop) / Slack 10.2 (desktop)
Posts: 41

Rep: Reputation: 15
Athlon XP-M 3000+ won't return to highest CPU freq after being on battery


I'm running Slackware current with kernel 2.6.14.4 on an eMachines M2352 laptop. I've got ACPI working and I'm using the ondemand cpu governor. Here's my problem: if I boot while on AC power, the computer will use its full speed of 2186 mhz, but if I ever switch to battery power ondemand will only take it up to 1457 mhz. Even if I plug it back in, it will only go up to 1457 mhz until I reboot it. If I hibernate it and resume with software suspend 2, it still is limited to 1457 mhz.

Whether I'm plugged in or not, cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies returns the following:

2186580 1855280 1457720 1325200 1192680 1060160 795120 530080

Here's what /proc/cpuinfo returns:

processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : Mobile AMD Athlon(tm) XP 3000+
stepping : 0
cpu MHz : 530.083
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips : 1061.61

This is not a huge issue, as 1457 mhz is still pretty quick, but it's annoying just the knowledge that I'm not running on full cpu. I have observed this issue since the first time I compiled a kernel with a CPU scaling governor. I'm not sure if it was happening before that, but I've looked around the kernel and haven't seen anything that might do this.

I have also tried switching the governor to userspace and manually setting the /sys entry to 2186 mhz, but the highest it will go is 1457.

There appears to be nothing in my ACPI event handler that could possibly be doing this either.

Any help is greatly appreciated.
 
Old 12-22-2005, 05:06 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
This may be normal, my laptop normally runs at 800MHz (on AC or battery);

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 36
model name : AMD Turion(tm) 64 Mobile Technology ML-30
stepping : 2
cpu MHz : 800.039
cache size : 1024 KB
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm
bogomips : 1601.93
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

But if I do something like build a kernel or anything else that places a load on CPU it runs at full speed.

Last edited by Lenard; 12-22-2005 at 05:09 AM.
 
Old 12-22-2005, 05:09 AM   #3
lydgate
Member
 
Registered: Jun 2005
Location: Fullerton, CA
Distribution: Arch 0.7.1 (laptop) / Slack 10.2 (desktop)
Posts: 41

Original Poster
Rep: Reputation: 15
No, I mean I want it to run at lower speed if it's not being used, and with ondemand cpu governor this works, and it stays at 530mhz. My problem is that if I boot all the way to X with my laptop plugged in, and I do something demanding CPU, e.g., cat /dev/urandom > /dev/null it will use all 2186 mhz of my processor speed.

If I do the same thing, only before running the command I unplug my computer then plug it back in, it will only ever reach 1457 mhz again, until I reboot it.
 
Old 12-22-2005, 07:52 PM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
You might what to check and see if a BIOS upgrade is available for your laptop. You may need to build a custom kernel with a custom dsdt also, visit acpi.sourceforge.net for some very helpful information and links.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cpu freq. scaling problem sonis Linux - Laptop and Netbook 4 04-25-2005 07:24 AM
Underclocking my Athlon xp 3000. Should I and how? Baix Linux - Hardware 6 02-22-2005 10:43 AM
how to control cpu freq ruh31 Debian 6 02-14-2005 09:58 AM
cpu freq. scaling problem sonis Suse/Novell 3 01-12-2005 05:04 PM
Lower CPU freq Adony Linux - Hardware 2 10-01-2004 09:23 AM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration