LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-26-2004, 08:43 AM   #1
spoody_goon
Member
 
Registered: Sep 2003
Location: Michigan USA
Distribution: Mandrake, DamnSmallLinux, VectorLinux
Posts: 416

Rep: Reputation: 30
Atheros Super G don't work


I have a Tochiba Satellite A75 206 loaded with Mandrake10.1 and I can't seem to get the Atheros Super G wireless card to work. I have search LQ and many other resources and tried wifi_pci driver and also tried the driver from Linuxant but I have had no luck. This is my last problem and I really want to get this worked out.
Thanks
 
Old 09-26-2004, 09:06 AM   #2
seanbo
LQ Newbie
 
Registered: Aug 2004
Location: Florida
Distribution: Fedora Core 2
Posts: 3

Rep: Reputation: 0
Lightbulb

Take a look at MadWiFi. It was developed with Atheros chip based Wifi cards in mind. It can be found at Sourceforge at: http://sourceforge.net/projects/madwifi/

This is what I used for my Atheros card and it doesn't even require you to use the poorly written Windows drivers. Good luck.
 
Old 09-26-2004, 10:24 AM   #3
spoody_goon
Member
 
Registered: Sep 2003
Location: Michigan USA
Distribution: Mandrake, DamnSmallLinux, VectorLinux
Posts: 416

Original Poster
Rep: Reputation: 30
Sorry I ment to say that the driver was madwifi_pci. So I have tried that driver, maybe I skipped a step or something. I wonder if my wireless card might be the "newest" version and that is what is causing my problems.
I will attemp to install Linuxant's driverloader from source instead of rpm to see if that helps.
Thanks
 
Old 09-26-2004, 12:47 PM   #4
seanbo
LQ Newbie
 
Registered: Aug 2004
Location: Florida
Distribution: Fedora Core 2
Posts: 3

Rep: Reputation: 0
Some other things to try:
Code:
modprobe wlan
modprobe ath_hal
modprobe ath_pci

appropriate iwconfig and ifconfig command to bring up the interface
(probably ath0)
If that doesn't work, can you send me the results of the following commands?

Code:
lsmod
ifconfig -a
iwconfig
I am not familiar with how Mandrqake does it, but if it is anything
like RH or FC, you should have a file that configures your network interface on activation. Can you post this file as well/
Code:
/etc/sysconfig/network/ifcfg-eth0
(replace eth0 with the interface for your wireless device;
probably ath0)
Also, what exactly is NOT working for you. It could be that the device is working and your sireless settings are not configured properly, or the device isn't working, etc, etc. Can you give a bit more of a description of yout problem?

If you can't get madwifi to work after everything else, I would try ndiswrapper as well. It is free and open source, you have to pay for linuxant (which is fine IF it works for you, it wouldn't work for my broadcom card where ndiswrapper did).

You can find ndiswrapper on sourceforge at:
Ndiswrapper @ Sourceforge
 
Old 09-26-2004, 02:39 PM   #5
spoody_goon
Member
 
Registered: Sep 2003
Location: Michigan USA
Distribution: Mandrake, DamnSmallLinux, VectorLinux
Posts: 416

Original Poster
Rep: Reputation: 30
Sorry for the delay seanbo the wife is using the computer for work stuff I will try your suggestions as soon as she is done and report back.
 
Old 09-26-2004, 07:05 PM   #6
spoody_goon
Member
 
Registered: Sep 2003
Location: Michigan USA
Distribution: Mandrake, DamnSmallLinux, VectorLinux
Posts: 416

Original Poster
Rep: Reputation: 30
Thanks you seanbo the
modprobe wlan
modprobe ath_hal
modprobe ath_pci
worked. I see you are new to the forum I think you will be a great addition.

Do you have any suggestions for the performance of the wireless card? Any set up tips?
Thanks again

Last edited by spoody_goon; 09-26-2004 at 07:12 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nfs write == super slow; read == super fast - problem? BrianK Linux - Networking 4 08-23-2007 10:59 PM
Help me get the Atheros 5001X wireless driver to work for fujitsu N5010. OS: SUSE 10 pitchblack Linux - Hardware 2 10-09-2005 09:00 PM
help i cant get my Atheros card to freaking work! asilentmurmur Linux - Hardware 1 03-06-2005 10:37 PM
File manager ( super user) doesn't work slacard Slackware 0 10-01-2003 11:56 AM
Super User mode, my root password doesn't work? kko88 Linux - Newbie 8 05-20-2003 06:01 PM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration