LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   ASUS u52 built-in webcam sound (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/asus-u52-built-in-webcam-sound-890840/)

polymath 07-09-2011 04:41 PM

ASUS u52 built-in webcam sound
 
I have an ASUS u52 laptop with a built-in webcam. I have the video component working (albeit upside-down), but am stuck with the microphone. I'm not sure if the sound is part of the webcam or is its own device.

Right now, I have alsamixer set to 90 on master, and on the capture screen (Boost:Capture:Digital:Internal Boost) I have it set to 33:65:65:33. However, I still get no sound- not in pavumeter, not in skype, not in anything.

I have no audio/mixer/dsp 's in /dev.

lspci | grep audio

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

lsmod | grep snd

snd_hda_codec_hdmi 22174 1
snd_hda_codec_realtek 283734 1
snd_hda_intel 25946 3
snd_hda_codec 67865 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13148 1 snd_hda_codec
snd_pcm 67276 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer 22658 1 snd_pcm
snd 52324 13 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore 13014 1 snd
snd_page_alloc 12969 2 snd_hda_intel,snd_pcm


lsmod | grep usb

i2400m_usb 30263 0
i2400m 87607 1 i2400m_usb
usbhid 39946 0
hid 72745 1 usbhid
usbcore 127203 5 i2400m_usb,uvcvideo,usbhid,ehci_hcd

lsusb


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 8086:0186 Intel Corp. WiMAX Connection 2400m
Bus 002 Device 004: ID 062a:6301 Creative Labs
Bus 001 Device 005: ID 04f2:b1b9 Chicony Electronics Co., Ltd

Thanks for any help!

alfredo10 07-10-2011 09:48 AM

Hi!
To help we must know your distribution, because some commands are not available in all Linux distris.
In many distros
Terminal / Konsole:
Code:

lsb_release -rd
displays it.
Desktop - Gnome, KDE,...?
Code:

uname -a
-> 32 / 64 bit
alfredo

polymath 07-10-2011 03:58 PM

Sorry - I forgot.

Debian Testing amd64 running LXDE.

alfredo10 07-11-2011 09:36 AM

Hi!
Searching with Google I found:
http://www.ideasonboard.org/uvc/
062a:6301 seems to be the hexcode of your camera. I would search on Debian forums or Wikis using that hexcode.
At the moment I don't have Debian installed (some months ago, but I had a hw problem).
alfredo


All times are GMT -5. The time now is 09:25 PM.