LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 03-18-2011, 04:45 AM   #1
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Rep: Reputation: 0
Asus EeePC problem connecting to wifi


Hi

I am brand new to Linux and have just got this netbook which came with Linux on it. I was told it would be simple to use and to connect to the internet but I can't get it to work at all and being completely new to it I have no idea where to start trying to fix it. Getting very tempted to get rid of it!

Basically I go into the wireless networks and can see my btbroadband homehub connection so I try to connect to it but it just stops at 'pending' and wont actually connect.

Can anyone talk me through what I should be doing in words of 1 syallable or less?!!

Thanks
 
Old 03-18-2011, 05:02 AM   #2
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-current
Posts: 95

Rep: Reputation: 7
Hi

Have you put the wep / wpa encryption key in?

What Linux distribution is it, was it supplied with the new netbook?

What model of eeepc so we can find out what distro it is running would be helpful.

Thanks
 
Old 03-18-2011, 08:38 AM   #3
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
I got it on eBay so not sure what Linux it is. How do I find out?

I have put the the key in and double checked it

It says Asus eeepc 4g on it. Hope that's what u wanted!
 
Old 03-18-2011, 11:50 AM   #4
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-current
Posts: 95

Rep: Reputation: 7
OK, Can you open a Terminal? You'll find it in Accessories or something similar, then type that commands below and cut and paste the results of:


Code:
cat /etc/*version
If that doesn't work then try this

Code:
cat /etc/*release
Failing that not working do:
Code:
uname -a
Thing is with linux is you have to put a bit of work in initially / every now and then. I have spent hours and hours and hours making things work, but its always worth the effort.
 
Old 03-18-2011, 01:56 PM   #5
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
4.0
Version: Eee PC 1.0.6.6
Build info: 2008-03-04 17:42
Part: DOC104ENDV1AU14
Sku: DSK0A14NAENNFR
xDMS: unsupported

Does that help?
 
Old 03-18-2011, 03:34 PM   #6
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-current
Posts: 95

Rep: Reputation: 7
Ok, its coming back to me now, the Asus eeePC linux is the one with the big icons. Its Linux, but very different to a normal Linux desktop experience.

Have a look at this URL to check against your configuration.

http://www.a2dvoices.com/realitychec...eePCSetup.html

Silly question I know, but does your wireless box allow new devices to connect automatically? My wireless box has settings that you can set so that each device must be registered with the wireless router.

Im not sure how BT Broadband goes about it, I'm sure the newer ones are WPA and thats it.

Last edited by hyperhead; 03-18-2011 at 03:40 PM.
 
Old 03-18-2011, 04:13 PM   #7
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
I've followed those instructions and it still does the same thing. I have checked the homehub and I can connect new devices as long as they have the WEP key thingy which I have put on the settings for this connection.

When I click on connect and then go to details it shows
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received
No working leases in persistent database - sleeping
run-parts --verbose /etc/network/if-up.d
 
Old 03-18-2011, 04:18 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Is the wireless router set to give out DHCP?
If not set a fixed ip on your computer, or turn DHCP on

Kind regards
 
Old 03-18-2011, 04:28 PM   #9
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
Yep, DHCP is enabled, it has a start address(192.168.1.64) and an end address (192.168.1.237)
 
Old 03-18-2011, 04:32 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Try to set a fixed ip in the range between
Quote:
192.168.1.64 and 192.168.1.237
Kind regards

Last edited by repo; 03-18-2011 at 04:38 PM.
 
Old 03-18-2011, 04:36 PM   #11
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
Tr to set a fixed ip in the range between


Kind regards
Thanks, can you explain how to do that? As I said this is all new to me, I never realised it was going to be so technical to set up!
 
Old 03-18-2011, 04:40 PM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
You should be able to do this in the properties in your
wireless networks.

Kind regards
 
Old 03-18-2011, 04:51 PM   #13
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
Do I need to copy over any of the other settings from the homehub? I have found DNS, default gateway, subnet mask etc
 
Old 03-18-2011, 04:53 PM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
As IP
Code:
192.168.1.66
Dafault GW
Code:
The ip from the router
and the DNS

Kind regards
 
Old 03-18-2011, 05:03 PM   #15
emmam202
LQ Newbie
 
Registered: Mar 2011
Posts: 14

Original Poster
Rep: Reputation: 0
Done that and now when I click connect the connection box flashes up and then disappears leaving the connection status as disconnected but I can't get to click on details to see what is happening.

Oh I give up for tonight, will come back to it again tomorrow. What a nightmare!! If I'd known it would be so hard to get the netbook to do the one thing it I bought it for then I would have got one with windows on! The guy I bought it from said there would be no problems getting it set up on wifi even if I'd not used Linux before. Turns out BT don't help with Linux at all either although they say it should work. My other internet connection option is through a dongle but there are no drivers for Linux for that either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant reconnect to wifi network after asus eeepc sleeps ManVersusFoo Linux - Laptop and Netbook 4 10-18-2010 09:05 PM
Asus eeePC with slackware? Laodiceans Slackware 32 02-13-2010 06:27 AM
debian on Asus EEEPC cccc Debian 6 10-26-2008 01:04 PM
asus eeepc ghodkiller Linux - Hardware 5 10-12-2008 12:37 PM
Reviews of Asus EeePC phantom_cyph General 20 03-13-2008 03:51 PM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration