LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   another problem: soundcard detected but can't hear any sound (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/another-problem-soundcard-detected-but-cant-hear-any-sound-352336/)

gry-HuhuY5 08-11-2005 06:13 PM

another problem: soundcard detected but can't hear any sound
 
Hi,
My previous problem about battery was solved, and now I got a new problem.
I'm running FC4 with GNOME on Toshiba Portege A100 laptop with built in soundcard and speaker on it (http://www.google.com.au/url?sa=t&ct...WJLKikYI_M8ZoN) to view specs. After few days working with it, I finally realized that I haven't got any sounds here. I tried soundcard detection on Desktop -> System Setting -> Soundcard Detection menu, It does detect my soundcard as follows:

Vendor: Intel
Model: Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
Module: snd-intel8x0

but when I clicked 'play test sound', no sounds come up. I've tried to max out my volume control both in my laptop and in gnome. It doesn't work on KDE either. XMMS, Rhythmbox, i've tried all of them, they do say playing but no sounds. Does it have anything to do with X, can someone help please.. thanks

gry-HuhuY5 08-11-2005 06:17 PM

one more thing I need to add, when I boot my system to Win XP, everything went fine, I can hear music, change the volume etc, so It's driver problem i think?

Justbill 08-11-2005 10:39 PM

Have you tried to adjust your alsa mixer. That solved my sound problem. Open a terminal and type alsamixer , that will open the mixer, and then bring your levels up, and you should have sound.

Justbill

gry-HuhuY5 08-12-2005 07:53 AM

Too bad it doesn't, do you have any other idea? Possibly something to do with drivers?

oomfoofoo 08-12-2005 12:39 PM

what about this?

1. alsaconf
2. alsamixer (turn up the volume/unmute whatever you need to)
3. alsactl store (saves your settings so you don't have to keep unmuting/turning up the volume

gry-HuhuY5 08-13-2005 08:19 AM

I don't know what's wrong with my system, but I can't find command 'alsaconf'. Probably linux is too hard for me. I might just use linux for uni assignment and go back to windows for mp3, games, vids and warez.. (I spent 1.5 hours trying to install xine & mplayer, none of them works :( and I was struggling for an hour before azureus work in my system..)

oomfoofoo 08-13-2005 10:42 AM

try adding "snd-intel8x0m" (without quotes) to the /etc/hotplug/blacklist directory (if you have one). you'll have to be root to edit the file. Then reboot the computer.

Don't forget, if you give up on Linux and go back to Windows, God kills a penguin.

Justbill 08-13-2005 04:55 PM

Quote:

Originally posted by gry-HuhuY5
Probably linux is too hard for me.
Don't feel that way! I am 46 years old and just started using computers a year and a half ago. It took me some time to learn windows, and then when I switched to Linux (Fedora Core 3 at that time, Core 4 now), it has taken time to learn this (and I might add, I have a long way to go)! Be patient with yourself, and take time to learn. That is what this site and sites like this one exsit for! You will be happy in the end!
A site that really helped me to begin to understand command line in Linux is
here
however you may want to look at this site in windows, it requires java, and that is another command line nightmare that you may or may not have accomplished yet on Linux. Good Luck to you, and Patience really will pay off in the end for you. If I can use this stuff, anyone can.

Justbill

zack3g 09-22-2005 03:52 PM

I am having a similar problem, with a twist. I'm running a Dell Inspiron 5100 dual boot FC4 and XP pro. Under XP all is well. FC4, no sound through built in speakers, but headphones work just fine. Adjusted the mixer, no change. Ideas?

Edit: Dug deeper into the mixer and played with the settings a bit more, got mine working.

fabianrios 09-22-2005 04:46 PM

FC4 mute the external amplifier at installing time. What you have to do in the terminal windows is:

$ alsamixer

The window will show a bunch of bars, master, master M etc. With the arrows keep moving until you find external. Usually there is a MM. If you press M in the keyboard you will unmute the external.

It happened to me but I do not remember the original post that help me to solve this so I cannot give the proper credit.

Anyway, hope this helps...

:newbie:

Dertanion 10-05-2005 02:53 PM

Quote:

Originally posted by fabianrios
FC4 mute the external amplifier at installing time. What you have to do in the terminal windows is:

$ alsamixer

The window will show a bunch of bars, master, master M etc. With the arrows keep moving until you find external. Usually there is a MM. If you press M in the keyboard you will unmute the external.

It happened to me but I do not remember the original post that help me to solve this so I cannot give the proper credit.

Anyway, hope this helps...

:newbie:

I have a dell inspiron 5100 and had the same problem. After installing FC4 i had no sound. i went to the $ alsamixer and that solved my problem.

pdcnix 01-14-2006 10:25 PM

Quote:

Originally Posted by Dertanion
I have a dell inspiron 5100 and had the same problem. After installing FC4 i had no sound. i went to the $ alsamixer and that solved my problem.

I have a Dell Inspiron 9100 and this solution (and similar above) worked too. Great Advice! Thanks!

I think alsamixer replaces aumixer which is mentioned in some posts.


All times are GMT -5. The time now is 03:27 AM.