LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices



Reply
 
Search this Thread
Old 08-11-2005, 07:13 PM   #1
gry-HuhuY5
LQ Newbie
 
Registered: Aug 2005
Posts: 12

Rep: Reputation: 0
another problem: soundcard detected but can't hear any sound


Hi,
My previous problem about battery was solved, and now I got a new problem.
I'm running FC4 with GNOME on Toshiba Portege A100 laptop with built in soundcard and speaker on it (http://www.google.com.au/url?sa=t&ct...WJLKikYI_M8ZoN) to view specs. After few days working with it, I finally realized that I haven't got any sounds here. I tried soundcard detection on Desktop -> System Setting -> Soundcard Detection menu, It does detect my soundcard as follows:

Vendor: Intel
Model: Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
Module: snd-intel8x0

but when I clicked 'play test sound', no sounds come up. I've tried to max out my volume control both in my laptop and in gnome. It doesn't work on KDE either. XMMS, Rhythmbox, i've tried all of them, they do say playing but no sounds. Does it have anything to do with X, can someone help please.. thanks
 
Old 08-11-2005, 07:17 PM   #2
gry-HuhuY5
LQ Newbie
 
Registered: Aug 2005
Posts: 12

Original Poster
Rep: Reputation: 0
one more thing I need to add, when I boot my system to Win XP, everything went fine, I can hear music, change the volume etc, so It's driver problem i think?
 
Old 08-11-2005, 11:39 PM   #3
Justbill
Member
 
Registered: Aug 2005
Location: House Springs, Mo. USA
Distribution: Fedora Core 5 & Ubuntu 5.10
Posts: 53

Rep: Reputation: 15
Have you tried to adjust your alsa mixer. That solved my sound problem. Open a terminal and type alsamixer , that will open the mixer, and then bring your levels up, and you should have sound.

Justbill
 
Old 08-12-2005, 08:53 AM   #4
gry-HuhuY5
LQ Newbie
 
Registered: Aug 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Unhappy

Too bad it doesn't, do you have any other idea? Possibly something to do with drivers?
 
Old 08-12-2005, 01:39 PM   #5
oomfoofoo
Member
 
Registered: Jul 2005
Posts: 34

Rep: Reputation: 15
what about this?

1. alsaconf
2. alsamixer (turn up the volume/unmute whatever you need to)
3. alsactl store (saves your settings so you don't have to keep unmuting/turning up the volume
 
Old 08-13-2005, 09:19 AM   #6
gry-HuhuY5
LQ Newbie
 
Registered: Aug 2005
Posts: 12

Original Poster
Rep: Reputation: 0
I don't know what's wrong with my system, but I can't find command 'alsaconf'. Probably linux is too hard for me. I might just use linux for uni assignment and go back to windows for mp3, games, vids and warez.. (I spent 1.5 hours trying to install xine & mplayer, none of them works and I was struggling for an hour before azureus work in my system..)
 
Old 08-13-2005, 11:42 AM   #7
oomfoofoo
Member
 
Registered: Jul 2005
Posts: 34

Rep: Reputation: 15
try adding "snd-intel8x0m" (without quotes) to the /etc/hotplug/blacklist directory (if you have one). you'll have to be root to edit the file. Then reboot the computer.

Don't forget, if you give up on Linux and go back to Windows, God kills a penguin.

Last edited by oomfoofoo; 08-13-2005 at 11:46 AM.
 
Old 08-13-2005, 05:55 PM   #8
Justbill
Member
 
Registered: Aug 2005
Location: House Springs, Mo. USA
Distribution: Fedora Core 5 & Ubuntu 5.10
Posts: 53

Rep: Reputation: 15
Quote:
Originally posted by gry-HuhuY5
Probably linux is too hard for me.
Don't feel that way! I am 46 years old and just started using computers a year and a half ago. It took me some time to learn windows, and then when I switched to Linux (Fedora Core 3 at that time, Core 4 now), it has taken time to learn this (and I might add, I have a long way to go)! Be patient with yourself, and take time to learn. That is what this site and sites like this one exsit for! You will be happy in the end!
A site that really helped me to begin to understand command line in Linux is
here
however you may want to look at this site in windows, it requires java, and that is another command line nightmare that you may or may not have accomplished yet on Linux. Good Luck to you, and Patience really will pay off in the end for you. If I can use this stuff, anyone can.

Justbill

Last edited by Justbill; 08-13-2005 at 05:58 PM.
 
Old 09-22-2005, 04:52 PM   #9
zack3g
LQ Newbie
 
Registered: May 2004
Location: Lafayette, LA
Distribution: Fedora Core 2 on a dell inspiron 5100
Posts: 21

Rep: Reputation: 15
I am having a similar problem, with a twist. I'm running a Dell Inspiron 5100 dual boot FC4 and XP pro. Under XP all is well. FC4, no sound through built in speakers, but headphones work just fine. Adjusted the mixer, no change. Ideas?

Edit: Dug deeper into the mixer and played with the settings a bit more, got mine working.

Last edited by zack3g; 09-22-2005 at 05:11 PM.
 
Old 09-22-2005, 05:46 PM   #10
fabianrios
Member
 
Registered: Apr 2005
Location: Atlanta
Distribution: FC3
Posts: 34

Rep: Reputation: 15
Wink

FC4 mute the external amplifier at installing time. What you have to do in the terminal windows is:

$ alsamixer

The window will show a bunch of bars, master, master M etc. With the arrows keep moving until you find external. Usually there is a MM. If you press M in the keyboard you will unmute the external.

It happened to me but I do not remember the original post that help me to solve this so I cannot give the proper credit.

Anyway, hope this helps...

 
Old 10-05-2005, 03:53 PM   #11
Dertanion
LQ Newbie
 
Registered: Sep 2005
Location: Florida
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by fabianrios
FC4 mute the external amplifier at installing time. What you have to do in the terminal windows is:

$ alsamixer

The window will show a bunch of bars, master, master M etc. With the arrows keep moving until you find external. Usually there is a MM. If you press M in the keyboard you will unmute the external.

It happened to me but I do not remember the original post that help me to solve this so I cannot give the proper credit.

Anyway, hope this helps...

I have a dell inspiron 5100 and had the same problem. After installing FC4 i had no sound. i went to the $ alsamixer and that solved my problem.
 
Old 01-14-2006, 11:25 PM   #12
pdcnix
LQ Newbie
 
Registered: Nov 2005
Location: .AU
Distribution: Suse / FC4
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by Dertanion
I have a dell inspiron 5100 and had the same problem. After installing FC4 i had no sound. i went to the $ alsamixer and that solved my problem.
I have a Dell Inspiron 9100 and this solution (and similar above) worked too. Great Advice! Thanks!

I think alsamixer replaces aumixer which is mentioned in some posts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcard or sound system problem: no sound! nmoog Linux - Newbie 4 09-01-2004 12:27 AM
sound card configured. can hear testsound. cant hear cd's tdr_nj Red Hat 2 04-19-2004 10:36 PM
I couldn't hear any sound from asus build-in soundcard exper Linux - Hardware 2 12-14-2003 06:30 PM
No sound in Mandrake v9.1 - Soundcard Detected mallesite Linux - Hardware 2 11-01-2003 04:26 PM
RH 9 Soundcard detected; sound w/ xine, mplayer; none w/ xmms, cd player johnsandidge Linux - Newbie 0 08-09-2003 09:42 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration