LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Alienware M15X and Karmic: Webcam and Integrated Microphone (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/alienware-m15x-and-karmic-webcam-and-integrated-microphone-793655/)

tstrike 03-06-2010 01:04 PM

Alienware M15X and Karmic: Webcam and Integrated Microphone
 
Hi everyone,

A short preface. I am a Convert. Ubuntu runs my laptop so AWESOMELY that I will never ever go back to Windows as my host OS. I had a bad crash from Windows 7 and my friend gave me Karmic on a USB stick. That day changed my personal computing experience forever!! Ubuntu for the FREE WORLD!! Best OS EVER!! The benchmarks speak for themselves and the footprint on my Alienware machine is absolutely freaking scary.

Ok on to my problem. With the sound issue solved, I am trying to get my integrated webcam and microphone to work with Alsa. I have updated Alsa to 1.0.22. I know the webcam has been identified by Karmic:

lsusb:
Bus 001 Device 002: ID 152d:0770 JMicron Technology Corp. / JMicron USA Technology Corp.

So I did a worldwide Google search for +ubuntu +152d:0770 and cant seem to find drivers or anyone who has had this problem. Now under Hardy and Jaunty I had the webcam working but not the microphone. Is there a patch or package for this specific webcam?

Thanks in advance my friends

Additional diagnostic information is available here:

http://pastebin.ca/1824762

TB0ne 03-06-2010 05:15 PM

Quote:

Originally Posted by tstrike (Post 3888431)
Hi everyone,

A short preface. I am a Convert. Ubuntu runs my laptop so AWESOMELY that I will never ever go back to Windows as my host OS. I had a bad crash from Windows 7 and my friend gave me Karmic on a USB stick. That day changed my personal computing experience forever!! Ubuntu for the FREE WORLD!! Best OS EVER!! The benchmarks speak for themselves and the footprint on my Alienware machine is absolutely freaking scary.

Ok on to my problem. With the sound issue solved, I am trying to get my integrated webcam and microphone to work with Alsa. I have updated Alsa to 1.0.22. I know the webcam has been identified by Karmic:

lsusb:
Bus 001 Device 002: ID 152d:0770 JMicron Technology Corp. / JMicron USA Technology Corp.

So I did a worldwide Google search for +ubuntu +152d:0770 and cant seem to find drivers or anyone who has had this problem. Now under Hardy and Jaunty I had the webcam working but not the microphone. Is there a patch or package for this specific webcam?

Thanks in advance my friends

Additional diagnostic information is available here:

http://pastebin.ca/1824762

First, welcome. Glad you're having a positive experience, and I do feel your pain regarding the laptop-specific type hardware, having dealt with it for some time. Read a post a while back on Alienware's site, that says they don't officially support Linux, only Windows, so if you load it, you won't void your warranty, but they also won't give you any help/info to get it going.

These:
http://www.crapules.com/wordpress/20...5x-and-ubuntu/
http://cn.centos.org/modules/newbb/v...24991&forum=39

may help some, but the second link is for CentOS, which may have an updated UVCVIDEO driver, which (from what I read), is what you're using. If you've just got things loaded, and haven't got much data out there yet, you may want to try a 'live' CD version of a couple of different distros. Hardware support varies sometimes, and what works 'out-of-the-box' with one distro, needs a lot of tweaking to work in another. Mandriva and openSUSE are two good ones to try, to see if they get things going.

On my openSUSE Vaio CS110E, I *just* got the internal mic working a couple weeks ago. Even though the sound card is Intel, I had to set the card type to Toshiba-S06 (??WTF??) to get it working. Post the output of lsusb and lspci, and try to find the entries for the webcam and sound hardware. It could be getting mis-identified, and not loaded.

tstrike 03-07-2010 12:01 AM

Quote:

Originally Posted by TB0ne (Post 3888623)
First, welcome. Glad you're having a positive experience, and I do feel your pain regarding the laptop-specific type hardware, having dealt with it for some time. Read a post a while back on Alienware's site, that says they don't officially support Linux, only Windows, so if you load it, you won't void your warranty, but they also won't give you any help/info to get it going.

These:
http://www.crapules.com/wordpress/20...5x-and-ubuntu/
http://cn.centos.org/modules/newbb/v...24991&forum=39

may help some, but the second link is for CentOS, which may have an updated UVCVIDEO driver, which (from what I read), is what you're using. If you've just got things loaded, and haven't got much data out there yet, you may want to try a 'live' CD version of a couple of different distros. Hardware support varies sometimes, and what works 'out-of-the-box' with one distro, needs a lot of tweaking to work in another. Mandriva and openSUSE are two good ones to try, to see if they get things going.

On my openSUSE Vaio CS110E, I *just* got the internal mic working a couple weeks ago. Even though the sound card is Intel, I had to set the card type to Toshiba-S06 (??WTF??) to get it working. Post the output of lsusb and lspci, and try to find the entries for the webcam and sound hardware. It could be getting mis-identified, and not loaded.

Tbone,

Many thanks... this I shall do.. I can say in fair confidence that Ubuntu was the proper OS for the Alienware brand. OMG this thing runs FAR FAR different than the benchmarks from Windows Vista or Windows 7. So much that it's frakking criminial.

I have the video working but the darn blasted integrated mike is killing me. In the meantime, Karmic popped a major issue. I went thru 6 fscks, and now cant detect my external. I am so close to going back to Hardy or Jaunty. However, my Ubuntu experience now is so geeked, that that blasted Win 7 DVD sitting on my bar is just a coaster.

That is extremely serious. I will circle back by morning with my results. I sincerely appreciate the advice. I will act now on it and provide detail by noontime (my noon).

I must say, Ubuntu is a warhorse. Now if we can get ole girl some eyes and a mouth ... it would make this machine deadly... My Alienware (if you saw the link I provided) is a monster.. Bred for war, and feasting on the bits like Pacman on fruit (I had to give you and the other readers a good laugh but this machine is that damn good).

tstrike 03-07-2010 10:05 AM

Ok update time
 
It seems that with Karmic, the webcam is activated but the digital microphone is dead. Further testing indicates that you have to get an external microphone to use.

TB0ne 03-07-2010 11:33 AM

Quote:

Originally Posted by tstrike (Post 3889232)
It seems that with Karmic, the webcam is activated but the digital microphone is dead. Further testing indicates that you have to get an external microphone to use.

Try changing the sound card type first, as I had the exact same problem with my Vaio.

This:
http://www.linuxquestions.org/questi...e-11.2-785161/

may point you in the right direction. Changing the sound card type was all it took for me.


All times are GMT -5. The time now is 09:20 AM.