LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-26-2009, 05:42 AM   #1
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Rep: Reputation: 0
4GB RAM Ubuntu 9.04


Hello,
I am new to this LQ. Hope, anyone could assists me to solve the problem I have.

Recently, I put a 4GiB (2 x 2 GiB) RAM on Acer Extensa 4620, running Ubuntu 9.04. However, when I click System/Administration/System Monitor
at the Memory and Swap history part, I only can see 2.9 GiB of RAM (memory).

Is this really only 2.9 GiB RAM is being used.

If I would like to have as what installed, 4 GiB, how can I achieve that. Thank you for your response.

Best regards,
++ pit ++
 
Old 09-26-2009, 06:18 AM   #2
callumacrae
Member
 
Registered: Sep 2009
Distribution: Fedora and Ubuntu
Posts: 126

Rep: Reputation: 22
Does your laptop support 4gb of memory?

~Callum
 
Old 09-26-2009, 06:53 AM   #3
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Original Poster
Rep: Reputation: 0
according to the specification, yes it does support (extended upto) 4GiB RAM.

anyhow, I found a solution (but not for notebook) in here
http://www.cyberciti.biz/faq/ubuntu-...tion-solution/

that solution is for HP workstation.

Would it be worked for a notebook (?)
Thank you.

Last edited by pitanaya; 09-26-2009 at 07:08 AM. Reason: need to add more information after googling the net.
 
Old 09-26-2009, 07:04 AM   #4
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mandriva, CentOS, Ubuntu
Posts: 456

Rep: Reputation: 69
The default Ubuntu desktop kernel does not support PAE, which is needed by the 32bit kernel to address the 4GB of RAM. So far I have only found 3 solutions around this.
1. Run the server kernel instead of the desktop kernel. (Battery life may suffer if this is a laptop)
2. Recompile the desktop kernel yourself to enable this feature.
3. Run the x86_64bit version of Ubuntu. (Which requires your system to support EM64T, Most C2D systems do)

Easiest solution is 1. But best solution is 3.
 
Old 09-26-2009, 07:05 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,201

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
32-bit or 64-bit ?.
Looks like that uses shared memory for video - that means it is taken from the total RAM.
 
Old 09-26-2009, 08:23 AM   #6
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mandriva, CentOS, Ubuntu
Posts: 456

Rep: Reputation: 69
Even without the video card taking ur RAM. The 32bit Ubuntu Desktop kernel only sees about 3.2GB of RAM. This is a 32bit limitation, it happens on Windows as well.

In your case, your video card probably took an additional 256MB off your RAM leaving you with 2.9GB available. If you take my option 1 & use the Server kernel, it will enable the PAE feature that will allow Ubuntu to address the full 4GB. With this, you might end up with about 3.7GB (your video card still needs RM)

The best solution though is to dump the 32bit Ubuntu & install the x86_64 version of Ubuntu. But make sure your CPU is EM64T capable. Check the specs of your system or you could post the output of # cat /proc/cpuinfo
 
Old 09-26-2009, 08:40 AM   #7
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ongte View Post
The default Ubuntu desktop kernel does not support PAE, which is needed by the 32bit kernel to address the 4GB of RAM. So far I have only found 3 solutions around this.
1. Run the server kernel instead of the desktop kernel. (Battery life may suffer if this is a laptop)
2. Recompile the desktop kernel yourself to enable this feature.
3. Run the x86_64bit version of Ubuntu. (Which requires your system to support EM64T, Most C2D systems do)

Easiest solution is 1. But best solution is 3.


Yes, I am considering your advice.

But, some words need to be clear first.
What is C2D system ? Don't understand that, please explain. Thank you.

Running x86_64 ubuntu, meaning that I need to change the notebook to the 64-bit architecture (?), since my notebook is 32-bit system. So, this option would not be possible. Am I right ?

I had tried option 1, which is installing the server kernel. It worked. The memory shown was 3.9 GiB. But, I had a problem later on, that FireFox and Opera became not responsive to a mouse scroll up/down. I was not very sure that it was due to the upgrade of the kernel. However, since I was not knowing how to solve it, I returned back to the original kernel by re-installing the system back again.
And, the mouse scroll became normal again. Now, I am back to the state that only 2.9 GiB shown as explained previously.

Option 2, not yet tried.

Thank you for the responses.
 
Old 09-26-2009, 08:45 AM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,201

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Quote:
Originally Posted by pitanaya View Post
Running x86_64 ubuntu, meaning that I need to change the notebook to the 64-bit architecture (?), since my notebook is 32-bit system. So, this option would not be possible. Am I right ?
Try this from a terminal and post the output (if any) - it will indicate if you have 64-bit capable hardware
Code:
grep -iow lm /proc/cpuinfo
 
Old 09-26-2009, 08:56 AM   #9
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by syg00 View Post
Try this from a terminal and post the output (if any) - it will indicate if you have 64-bit capable hardware
Code:
grep -iow lm /proc/cpuinfo

got 2 lines of 'lm'

so, is it correct. ? here it is ...

pitanaya@pitanaya-laptop:~$ grep -iow lm /proc/cpuinfo
lm
lm
 
Old 09-26-2009, 09:07 AM   #10
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ongte View Post
Even without the video card taking ur RAM. The 32bit Ubuntu Desktop kernel only sees about 3.2GB of RAM. This is a 32bit limitation, it happens on Windows as well.

In your case, your video card probably took an additional 256MB off your RAM leaving you with 2.9GB available. If you take my option 1 & use the Server kernel, it will enable the PAE feature that will allow Ubuntu to address the full 4GB. With this, you might end up with about 3.7GB (your video card still needs RM)

The best solution though is to dump the 32bit Ubuntu & install the x86_64 version of Ubuntu. But make sure your CPU is EM64T capable. Check the specs of your system or you could post the output of # cat /proc/cpuinfo
Ok ...
try to follow your directive.
Here is the result. How should I read it. Thank you.

pitanaya@pitanaya-laptop:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz
stepping : 13
cpu MHz : 1000.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 3325.19
clflush size : 64
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz
stepping : 13
cpu MHz : 1000.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 3325.01
clflush size : 64
power management:
 
Old 09-26-2009, 10:25 AM   #11
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
lm flag is long mode which means you can do 64bit.
 
Old 09-26-2009, 12:01 PM   #12
ongte
Member
 
Registered: Jun 2009
Location: Penang, Malaysia
Distribution: Mandriva, CentOS, Ubuntu
Posts: 456

Rep: Reputation: 69
Quote:
Originally Posted by pitanaya View Post
But, some words need to be clear first.
What is C2D system ? Don't understand that, please explain. Thank you.
......
Sorry about that, I meant Core 2 Duo. As in the Intel chip.

Well, looks like your system is 64bit capable, so I highly recommend installing the x86_64 version of Ubuntu.
 
Old 09-26-2009, 03:29 PM   #13
pitanaya
LQ Newbie
 
Registered: Feb 2004
Location: Tangerang, Indonesia
Distribution: Ubuntu 9.04
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ongte View Post
Sorry about that, I meant Core 2 Duo. As in the Intel chip.

Well, looks like your system is 64bit capable, so I highly recommend installing the x86_64 version of Ubuntu.
Ow ... thank you to you all.
I will try and install x86_64 ubuntu :-)

thank you to @Ongte, @Syg00, @Crito, ... all of you.
 
Old 09-17-2010, 09:41 PM   #14
huangh
LQ Newbie
 
Registered: Sep 2010
Location: yanju
Posts: 1

Rep: Reputation: 0
Smile install PAE if your os is ubuntu

Option #2: Install PAE enabled kernel

Open terminal and type the following command:
$ sudo apt-get update
$ sudo sudo apt-get install linux-headers-server linux-image-server linux-server
Once kernel images installed, just reboot your workstation, type:
$ sudo reboot
 
Old 09-17-2010, 09:48 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,201

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Welcome to LQ - I guess you were trying to help, but that thread is very nearly a year old.
Dead threads should be left that way.
 
  


Reply

Tags
notebook, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue about installing Ubuntu 9.04 on Dell XPS 1530, 4GB RAM ranveerj Linux - Newbie 2 08-06-2009 07:24 AM
Will 64bit Ubuntu use 4gb of Ram when runnin a 32bit VM Windows Environment? Enicko Linux - Newbie 1 02-24-2009 03:48 PM
3.6GB RAM instead of 4GB ??? masterross Slackware 11 09-04-2008 08:07 AM
utilize 4gb of ram cynick Linux - General 2 04-20-2006 11:42 AM
What if you had 2GB RAM and 4GB HD? AC97Conquerer General 21 03-28-2005 07:21 PM


All times are GMT -5. The time now is 08:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration