LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 10-10-2011, 03:26 PM   #1
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
[HOWTO] [UPDATED] Alienware M14x, Fedora 15 - Bumblebee, System Setup


Alright guys, I purchased the Alienware M14x, knowing that I was going to immediately remove windows and use only linux. I knew that I was in for it, and after a few weeks, with an unexpected delay of getting a new motherboard, I am happy to say that I got the nVidia GPU fully working. This isn't a full step by step tutorial, but just confirming that I have gotten it to work, and I am sharing my information with you.

First of all, Fedora is not officially supported yet in The Bumblebee Project. First of all, we need to clone into fedora-dev:
Code:
git clone git://github.com/Bumblebee-Project/Bumblebee.git -b fedora-dev
Note that you should do this as a normal user, and run the install using either sudo, or "su -". In my case, I did it as root because I was doing a lot of modifications at the time to the code to test everything out. After we clone in, we need to tell the install script to keep running after complaining about running fedora and not being fully supported.
Code:
cd Bumblebee/stages
vi determinedistro
You need to comment out "exit 3" under Fedora, and you will be set. Follow up and run the install script in the Bumblebee directory, allowing everything to install. For me, I had to remove the nouveau driver because the proprietary drivers wouldn't install, due to a driver already being loaded.
Code:
rmmod nouveau
rmmod nvidiafb
I removed both modules just in case, and everything went very smoothly.

Well enjoy your system, and please note that fedora is still unsupported. I'm on the mailing list, and I will be working with the devs soon to get it fully supported. On a side note, I have gotten everything else working, with the exception of a minor audio glitch with my headphone jacks. That will come in the future, as it is not a pressing issue. All I got besides that is I had to install the following:

UPDATE: After updating my kernel, and messing with bumblebee and the latest nvidia drivers, I have come across a small bug regarding FPS issues. Since I like to manually start all of my services to be in complete control, everything worked as advertised. The only drawback was that I had to manually "ps aux" and grep out bumblebee, and kill the PIDs of the started X server, and the bumbebee server, and then manually restart the bumblebee service. Without doing this, minecraft was very laggy, even using my Nvidia 555M GT chipset. On the contrary, after doing all of that, I noticed a drastic increase in performance, in comparison to the older version of bumblebee I was using, and the older kernel I was running.

Code:
yum install vbetool
/var/log/pm-suspend.log was complaining that vbetool wasn't installed, and this was refraining my system from completely powering up my monitor and graphic drivers after suspend mode and hibernation. More to come as I keep working on all the glitches. I hope to have everything sorted out by late next week. (Thanks to my buddy Eric for pointing out the log file - I almost forgot to look there at last.)

Cheers, and all the best,

Josh


EDIT 1 - Being a 64 bit system, and a heavy minecraft player, I had difficulties getting minecraft running using optirun. I had to run the following:
Code:
ldconfig /usr/java/jre1.7.0/lib/amd64
Note that the location of your 64 bit Java JRE libraries may be different. After reconfiguring, I ran my script to run up minecraft with optirun, and success! Here is my small script to make things a bit easier, and to call from an icon shortcut on my status bar:
Code:
#!/bin/bash
cd /home/casper/GAMES/minecraft
optirun java -jar minecraft.jar 1>minecraft.out 2>minecraft.err

EDIT 2 - Here are the screenshots of the FPS of glxgears, using both the normal Intel Graphics driver, and the nVidia graphics driver. Can you tell which one is which?
http://img841.imageshack.us/img841/9...0201104333.png
http://img255.imageshack.us/img255/5...0201104355.png


EDIT 3 - Here is the benchmark that H_TeXMeX_H told me about.....
http://img27.imageshack.us/img27/269...3201107442.png
I know not the best, but still pretty dang good for being a laptop....

Last edited by corp769; 11-22-2011 at 02:33 PM.
 
Old 10-11-2011, 09:11 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Indeed, we can tell which one is the Intel. 50 FPS ... I wonder if it even contributes significantly to any rendering. It's mostly there to save power, and that's about it.
 
Old 10-11-2011, 11:25 AM   #3
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Oh it definitely does. I ran up minecraft with everything maxed out, fullscreen, and no lag whatsoever. I did the same with the Intel, and after a few minutes, everything started to get pixelated, and started to lag.
 
Old 10-11-2011, 01:33 PM   #4
justforyou
LQ Newbie
 
Registered: Oct 2011
Posts: 9

Rep: Reputation: Disabled
Thats some impresive numbers :d

I wonder how it will do on real numbers chruching like calculating md5's? What gpu u use?
 
Old 10-11-2011, 02:14 PM   #5
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
It's the nVidia GeForce 555M (it's in my sig). It's not the best mobile GPU they have, but it's really good still. I love it.... I ran a benchmark yesterday back at my house, and the numbers were very impressive. I'm not home right now, so I can't post everything currently. I will get back to you on that.
 
Old 10-12-2011, 07:01 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
glxgears is not a benchmark. Try something like the unigine benchmark.
 
Old 10-12-2011, 07:18 AM   #7
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
Quote:
Originally Posted by corp769 View Post
EDIT 2 - Here are the screenshots of the FPS of glxgears, using both the normal Intel Graphics driver, and the nVidia graphics driver. Can you tell which one is which?
http://img841.imageshack.us/img841/9...0201104333.png
http://img255.imageshack.us/img255/5...0201104355.png
Besides 'glxgears is not a benchmark', you did notice the little disclaimer? "Running synchronised to the vertical refresh" means its not going to produce any more frames than the refresh rate.

Sure, intel video chips are about as weak as you can find, but that glxgears run doesnt show the intel video chip running at full power.

Quote:
Originally Posted by corp769 View Post
It's the nVidia GeForce 555M (it's in my sig). It's not the best mobile GPU they have, but it's really good still.
Yet another nVidia GPU with multipule versions.

*rant mode*

nVidia, if you cant give different GPUs different names, its either lazy or an attempt to mislead. I'm sick of seeing 'up to' on spec pages. Optimus not getting suppoort for linux is one thing, but this 'badge engineering' GPUs of different families into a single name is pure bulldust.

*rant mode over*
 
Old 10-12-2011, 11:52 AM   #8
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
You always go into rant mode, don't you?

And yes, of course I know that glxgears is not a benchmark. It was to show proof that I was able to successfully get the nvidia drivers working with bumblebee.
 
Old 10-12-2011, 12:24 PM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Yeah, it's good that it works. I was never able to get it working ... probably because I'm using Slackware and it seems to be distro specific.
 
Old 10-12-2011, 05:15 PM   #10
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Quote:
Originally Posted by H_TeXMeX_H View Post
Yeah, it's good that it works. I was never able to get it working ... probably because I'm using Slackware and it seems to be distro specific.
Well in that case, how do you go by installing the nvidia drivers? Do you use the proprietary drivers, or the open source drivers? I'm not currently running slackware, but I might be able to squeeze some time in to work on an install script for you slack users....
 
Old 10-13-2011, 03:51 AM   #11
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
Quote:
Originally Posted by corp769 View Post
You always go into rant mode, don't you?
Not really...one of these days you might see a real rant from me, when I get really worked up it can be amusing to see how much vitriol I can spew...

Quote:
Originally Posted by H_TeXMeX_H View Post
Yeah, it's good that it works. I was never able to get it working ... probably because I'm using Slackware and it seems to be distro specific.
IIRC you have a Eee PC 1015PN, right?

Those things came with 'windows 7 starter' which doesnt support 'optimus'. So the asus engineers have probably made the IonII 'optimus' setup work more like switchable graphics.
 
Old 10-13-2011, 03:56 AM   #12
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
In that case, would that be beneficial with the BIOS, having a switch in the settings to turn off the dedicated graphics card, and vice versa?
 
Old 10-13-2011, 06:31 AM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by cascade9 View Post
IIRC you have a Eee PC 1015PN, right?

Those things came with 'windows 7 starter' which doesnt support 'optimus'. So the asus engineers have probably made the IonII 'optimus' setup work more like switchable graphics.
Yes, and yes. I don't see anything in the BIOS tho to switch it. It says in the manual that only non-Starter Window$ is able to use optimus.

I use the proprietary nvidia drivers. I can try bumblebee if there is a package for it, but I don't care that much, because I don't like Intel cards, they are very weak. I doubt that it would help me play videos any better than I do now.
 
Old 10-13-2011, 06:58 AM   #14
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Quote:
Originally Posted by H_TeXMeX_H View Post
Yes, and yes. I don't see anything in the BIOS tho to switch it. It says in the manual that only non-Starter Window$ is able to use optimus.

I use the proprietary nvidia drivers. I can try bumblebee if there is a package for it, but I don't care that much, because I don't like Intel cards, they are very weak. I doubt that it would help me play videos any better than I do now.
Here you go man, if you dare to try.....
https://github.com/Bumblebee-Project...bee/issues/121

And I just ran that benchmark that you mentioned..... Awesome experience! I know the numbers aren't the best, but it really pushed my graphics card to its limits. I'm uploading right now as I type this.
 
Old 10-13-2011, 07:06 AM   #15
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Original Poster
Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
Just updated my thread with the benchmark.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Alienware M14x BIOS linux-based flashing utility corp769 Linux - Hardware 22 10-06-2011 10:41 AM
Howto setup XEN virtual machine on Fedora Core 6 x86 trieudoahong Linux - Virtualization and Cloud 9 07-27-2011 07:01 AM
No sound fedora 12 Alienware M17x thelegendofando Linux - Hardware 3 01-25-2010 03:30 PM
HOWTO: Installing Fedora on any remote Linux system with no physical access. halo14 Fedora 1 11-05-2008 02:08 AM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration