LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 04-16-2007, 11:06 AM   #1
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Rep: Reputation: 15
Question Warning: kernel headers don't match running Linux version


Hi all,

I'm trying to install wacom-kernel-source on Debian 4 Etch, but I get the following error while installing:

Code:
# apt-get install wacom-kernel-source
Reading package lists... Done
Building dependency tree... Done
wacom-kernel-source is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up wacom-kernel-source (0.7.4.1-5) ...
/var/lib/dpkg/info/wacom-kernel-source.postinst: line 49: [: too many arguments
Warning: kernel headers don't match running Linux version.
Building wacom modules for Linux _CODE 13262 (this may take a few minutes)...dpkg: error processing wacom-kernel-source (--configure):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
wacom-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
I know I have the correct headers installed, or at least I believe so:

Code:
# uname -r
2.6.18-4-686
so:

Code:
# apt-get install linux-headers-`(uname -r)`
Reading package lists... Done
Building dependency tree... Done
linux-headers-2.6.18-4-686 is already the newest version.
At this point I am clueless. What is missing?

Thanks a lot for your time
 
Old 04-17-2007, 09:44 AM   #2
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
The issue here doesn't seem to be that your headers and kernel dont match up, but that there is something wrong in /var/lib/dpkg/info/wacom-kernel-source.postinst. The output is telling you that there are too many arguments on line 49 of /var/lib/dpkg/info/wacom-kernel-source.postinst.
 
Old 04-17-2007, 09:47 AM   #3
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Original Poster
Rep: Reputation: 15
Ok, I see the point. Could there be a fix for this? Is that a bug I should report to the Debian devs? I know Etch was supposed to be stable and work, so there must be something wrong with this package...

Thanks for your reply
 
Old 04-17-2007, 10:02 AM   #4
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
If you have some scripting / programming experience you might be able to do it yourself. I'm not sure how you'd contact the dev's as I don't use etch (In Arch it's as simple as emailing the package maintainer or putting in a bug report.) You might want to search on google to find out how to do so. A post on their forums might be in order as well.
 
Old 04-17-2007, 10:05 AM   #5
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Original Poster
Rep: Reputation: 15
Well, they don't have any official forums, that's the big deal.
I haven't got any programmin experience, but if you tell me I should contact the devs I'll find a way to do so (at once, I would add). I think I'll try to subscribe to their mailing list and ask there.

Thanks a lot!
 
Old 04-17-2007, 10:26 AM   #6
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Original Poster
Rep: Reputation: 15
Ah, by the way, these are the contents of line 49:

Code:
[ $kvers = `uname -r` ] || echo "Warning: kernel headers don't match running $kernel version."
Which outputs the message of warning I get during the installation...
 
Old 04-17-2007, 10:29 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Originally Posted by finferflu
Well, they don't have any official forums, that's the big deal.
Mmmh who are you talking about? debian? they don't have an official forum? You're joking aren't you?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=418008


For this task, another solution (and better one) is to use module-assistant. Check it.

A side question:
Why do you need to install this while it's already in the kernel?
 
Old 04-17-2007, 10:50 AM   #8
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks for your reply.

I have searched a lot, but couldn't find anything. I wonder how you got there. Anyways, you say it's already in the kernel, but how comes my pen tablet is not even recognised? There is no input whatsoever from it. I know it's a supported model (Wacom Volito2), because it worked fine on Ubuntu (Dapper and Edgy), and also on Knoppix (5.0 if I remember correctly).
I have set up everything like I used to, and I don't even get input.

Also, I have got module-assistant installed, I have used it for ndiswrapper-source, so I thought I had to do the same for wacom-kernel-source, but first I need to download it through apt, right (that's what I did with ndiswrapper-source)?

I know my questions probably look silly, but this is for me a completely new area, as I am used the simplified Ubuntu.

Thanks!
 
Old 04-17-2007, 11:47 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Originally Posted by finferflu
Thanks for your reply.

I have searched a lot, but couldn't find anything. I wonder how you got there.
You want to be efficient with debian? Put this in bookmark:
http://www.debian.org/distrib/packages#search_packages
Then I have put the name of your package , chose also all distribution (stable,unstable,test,expe), clicked. Next page I clicked the unstable version. Then down You see bug report, click on this.
You arrive there:
http://bugs.debian.org/cgi-bin/pkgre...;dist=unstable
Oooh your bug is the first one :o)
Another interesting link on this above page is
Package Tracking System

Quote:
Anyways, you say it's already in the kernel, but how comes my pen tablet is not even recognised? There is no input whatsoever from it. I know it's a supported model (Wacom Volito2), because it worked fine on Ubuntu (Dapper and Edgy), and also on Knoppix (5.0 if I remember correctly).
I have set up everything like I used to, and I don't even get input.
Humm.
I don't know these devices so I can't help you precisely. Lazy as I am what I would do in your situation is to boot in one working distro and try to see what configuration they use (modules, wacom version, parameters, maybe udev)
uname -r
lsmod
modinfo wacomxxx
read what is in /etc/modprobe.b , maybe there is something about this device
And then try manually to insert the module with the same options?
If you can't get this device to work, maybe you should report in Debian forum (it could be a kernel version number and then the current post is right) and try to get some help (could be udev that doesn't do its job)
Quote:
Also, I have got module-assistant installed, I have used it for ndiswrapper-source, so I thought I had to do the same for wacom-kernel-source, but first I need to download it through apt, right (that's what I did with ndiswrapper-source)?
Right, it should be like this:
http://www.debian-administration.org/articles/401
Just adapt with the wacom.
Quote:
I know my questions probably look silly, but this is for me a completely new area, as I am used the simplified Ubuntu.

Thanks!
No problem, you don't look silly. It's not that easy.
The silly is the one with unanswered question.
Did you look at this:
http://forums.debian.net/viewtopic.p...65a42b5cb29cc6
Because it should work out of the box.
If you modify things it may not work (sorry if its too late)
In general, little things are needed. The hard thing is to find which are these things :)
Good luck

Last edited by nx5000; 04-17-2007 at 11:48 AM.
 
Old 04-17-2007, 01:23 PM   #10
finferflu
LQ Newbie
 
Registered: Jun 2006
Location: Manchester, UK
Distribution: Debian Etch / Ubuntu Feisty Fawn
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks for that
I have tried to ask the question about my Volito2 in the thread you have pointed out, I hope to solve this, since I need to use that pen tablet and I am enjoying Etch so far... I hope I don't need a new clean install, though...
 
Old 05-08-2009, 04:32 PM   #11
craig61107
LQ Newbie
 
Registered: Apr 2009
Location: Rockford, Illinois, USA
Distribution: Debian (tower), ASUS Xandros
Posts: 8

Rep: Reputation: 0
cpad, wacom modules--same problem

I'm getting the same errors with cpad and wacom kernel modules each time I run an update or installation, and it's interfering with my ability to add applications and features to my system--specifically, Scribus and XUL libraries.

I'm running kernel 2.6.24-etchnhalf.1-686. uname says the headers are installed.

Should I use Synaptic to remove and reinstall the cpad and wacom modules?

Last edited by craig61107; 05-08-2009 at 05:43 PM.
 
  


Reply

Tags
headers, linux, match


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem of Linux kernel version mismatch while running the compile program Nishant Desai Linux - Kernel 8 03-12-2007 09:22 AM
nfs warning: mount version older than kernel Yalla-One Slackware 2 09-21-2005 04:00 PM
nfs warning: mount version older than kernel dgermann Linux - Networking 4 07-04-2005 05:30 PM
redhat fedora gcc version (compiled for 2.4.20) doesn't match kernel version 2.4.22 start1000 Linux - Software 0 03-16-2004 09:17 PM
OpenSSL headers do not match your library theone333 Linux - Software 5 11-15-2002 10:55 AM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration