LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   usb power management (suspend) gone in 2.6.34?! (http://www.linuxquestions.org/questions/linux-kernel-70/usb-power-management-suspend-gone-in-2-6-34-a-808887/)

Olaus 05-19-2010 12:19 PM

usb power management (suspend) gone in 2.6.34?!
 
Hi, the entries in /sys/bus/usb/devices/.../power that permitted me to set the suspend options, like power/level and power/autosuspend, seem to be gone in 2.6.34. Any hints where I can find them? It seems like they SHOULD be there, according to Documentation/usb/power-management.txt in the kernel source tree.

serafean 05-19-2010 05:05 PM

Did you enable USB selective suspend/resume and wakeup?

Olaus 05-20-2010 01:43 AM

Quote:

Originally Posted by serafean (Post 3974667)
Did you enable USB selective suspend/resume and wakeup?

When I checked the configuration, which was generated from a 2.6.33.3 kernel configuration (where the USB suspend option WAS enabled), it seems that those options were not available any more. When I searched for USB_SUSPEND in menuconfig the help text said that this options now is dependent on PM_RUNTIME, which it wasn't before this kernel. According to http://comments.gmane.org/gmane.linu...general/30876:
Quote:

we make USB_SUSPEND depend on PM_RUNTIME instead of CONFIG_PM
I enabled that option, and then USB_SUSPEND was available again in the configuration. I haven't tried to compile with this new configuration yet, will get back later. By the way, since I didn't have PM_RUNTIME enabled before this kernel (I didn't feel the need for it), did I miss any other power saving features? I don't know if 'SATA Aggressive Link Power Management' is dependent on this, for example.

Olaus 05-20-2010 11:05 AM

Quote:

Originally Posted by Olaus (Post 3975048)
When I searched for USB_SUSPEND in menuconfig the help text said that this options now is dependent on PM_RUNTIME, which it wasn't before this kernel config.
I enabled that option, and then USB_SUSPEND was available again in the configuration. I haven't tried to compile with this new configuration yet, will get back later.

Compilation and suspending worked like a charm with PM_RUNTIME enabled. Case closed. I think that the 'make silentoldconfig' command should have fixed this, though.

serafean 05-21-2010 04:33 AM

Did a bit more reading (kernelnewbies.org) and found that this new dependency might be a consequence of asynchronous suspending (all buses : SATA,SCSI, USB...). just a thought added for completeness.

Olaus 05-21-2010 03:00 PM

A warning: According to http://permalink.gmane.org/gmane.lin....general/29764 the new control attribute under the power directory is supposed to act as the level attribute (which will be deprecated next year), BUT when I changed "level" to "control" in my rc.local, as in
Code:

echo -n "auto" > /sys/bus/usb/devices/2-8/power/control
the unit did not autosuspend. I had to replace control with level again in order for autosuspend to work. Obviously this is a bug?

kebabbrullen 02-09-2011 06:17 AM

USB power suspend problems in 2.6.37
 
I used to be able to suspend with my previous kernels that was older than 2.6.33.
My new kernel IS compiled with USB_SUSPEND support but I still have problems.
When I do "echo -n suspend > control" (or > level) I get this error message:

-su: echo: write error: Invalid argument

(I can echo "on" and "auto" to control without problems)

My current kernel is 2.6.37 but I have the same problem in 2.6.35 and the computer is a Hewlett-Packard -HP Compaq 8000 Elite.

Anyone has any suggestions?

kebabbrullen 02-10-2011 10:15 AM

Posting new thread for this as its marked as solved.


Quote:

Originally Posted by kebabbrullen (Post 4252925)
I used to be able to suspend with my previous kernels that was older than 2.6.33.
My new kernel IS compiled with USB_SUSPEND support but I still have problems.
When I do "echo -n suspend > control" (or > level) I get this error message:

-su: echo: write error: Invalid argument

(I can echo "on" and "auto" to control without problems)

My current kernel is 2.6.37 but I have the same problem in 2.6.35 and the computer is a Hewlett-Packard -HP Compaq 8000 Elite.

Anyone has any suggestions?



All times are GMT -5. The time now is 08:51 AM.