LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 05-02-2007, 09:45 PM   #1
Cereal765
Member
 
Registered: May 2006
Distribution: Fedora Core, SuSE
Posts: 44

Rep: Reputation: 15
Unable to turn cooling device on?, FC6


Hey all,

About every 10 seconds im getting a weird message in my kernel log:

Code:
ACPI: Unable to turn cooling device [c1403dec] 'on'
All my fans are working properly, and this has been going on so long that I've gotten semi-used to it, but recently its started to become an annoyance. My log files are ginormous...

I'm running FC6 uname -r 2.6.18-1.2849.fc6

I would be very thankful if someone could help me get rid of this message, or maybe stop it from appearing 20 million times in a row!
 
Old 05-05-2007, 01:29 AM   #2
meaje
LQ Newbie
 
Registered: Jan 2005
Location: Fort Collins, CO
Distribution: Fedora, WhiteBox, Centos
Posts: 3

Rep: Reputation: 0
Thumbs up It seems that on the CentOS list this problem has a solution

echo -n "65:60:50:55:50:45" > /proc/acpi/thermal_zone/THRM/trip_points

Ref: Post number 4 on topic_id=8158
 
Old 05-05-2007, 01:30 AM   #3
meaje
LQ Newbie
 
Registered: Jan 2005
Location: Fort Collins, CO
Distribution: Fedora, WhiteBox, Centos
Posts: 3

Rep: Reputation: 0
Arrow

the exact URL is:
http://www.centos.org/modules/newbb/...?topic_id=8158
 
Old 10-10-2007, 10:14 PM   #4
miles2034
LQ Newbie
 
Registered: Aug 2006
Location: honolulu
Distribution: redhat ubuntu
Posts: 17

Rep: Reputation: 0
o come on guys I just installed fc7 and i get the same message. I have a compaq presario. It just doesn't make any sense. and the bootup doesn't get to the gui login screen. which ist what i expect.
miles
 
Old 10-25-2007, 04:12 AM   #5
meaje
LQ Newbie
 
Registered: Jan 2005
Location: Fort Collins, CO
Distribution: Fedora, WhiteBox, Centos
Posts: 3

Rep: Reputation: 0
Lightbulb Best explanation yet on how to stop those annoying log messages with a true fix.

Quote:
Originally Posted by meaje View Post
echo -n "65:60:50:55:50:45" > /proc/acpi/thermal_zone/THRM/trip_points

Ref: Post number 4 on topic_id=8158
To explain further I am copying http://http://www.geocities.com/acar...lo-1450ls.html

-- snip
ACPI
Fan
In order to have the fan managed by the ACPI system, I added the following commands to /etc/rc.d/rc.local:

# Set the trip point temperatures (in Celsius)
# the order of the fields is critical:hot:passive:active:active
echo -n "95:0:90:80:65" > /proc/acpi/thermal_zone/THRM/trip_points

# Activate the temperature control system of the kernel
echo -n "30" > /proc/acpi/thermal_zone/THRM/polling_frequency

# Turn the fan over to Kernel control
echo -n "3" > /proc/acpi/fan/FAN0/state

Make sure that you use the appropriate trip point temperatures for your laptop with "cat /proc/acpi/thermal_zone/THRM/trip_points". On my laptop, I have:

critical (S5): 100 C
passive: 90 C: tc1=2 tc2=3 tsp=100 devices=0xc1425660
active[0]: 80 C: devices=0xc1436860
active[1]: 65 C: devices=0xc14366e0

When writing to /proc/acpi/thermal_zone/THRM/trip_points, the order of the fields is critical:hot:passive:active:active. Since all fields must be present, I entered a zero for the unused 'hot' trip point. See Michael T. Kelly's Gateway 1450se page for more detail. http://www.piratehaven.org/~mike/index.cgi?gateway

snap--

I hope this clears things up for you and shows you how to control your fans a little better and life a little easier too.

--Jeff
 
Old 11-05-2007, 03:25 PM   #6
matti3
LQ Newbie
 
Registered: Nov 2007
Location: Belgium
Distribution: openSUSE 11.4, opensuse 12.1
Posts: 15

Rep: Reputation: 0
the first link is malformed. here is the corrected one:
http://www.geocities.com/acarirfan/solo-1450ls.html

thanks a lot for this info!
 
Old 01-27-2008, 12:05 AM   #7
Motaro
Member
 
Registered: Mar 2003
Location: USA, Florida
Distribution: slackware 12.1
Posts: 44

Rep: Reputation: 16
It seems the feature was removed.

Well I found out that they removed the capacity to change the values in trip_points, so right now I have that it returns invalid arguments when you try to send an echo of the values to trip_points as of kernel 2.6.22. But my problem is that the values that configuration comes with are not very realistics. So if any body has another way to change this parameters please let me know.
 
Old 01-27-2008, 04:04 PM   #8
matti3
LQ Newbie
 
Registered: Nov 2007
Location: Belgium
Distribution: openSUSE 11.4, opensuse 12.1
Posts: 15

Rep: Reputation: 0
mm, you're right. I also get the invalid arg now. But I saw in the changelog of 2.6.24 kernel that they fixed a regression of acpi related dmesg spam, so I hope it will be fixed now
/me awaits suse kernel update..
 
Old 11-25-2008, 10:22 AM   #9
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Rep: Reputation: 30
Using Sidux with kernel 2.6.26 and I also am not allowed to change the setting
 
Old 12-04-2008, 06:47 PM   #10
matti3
LQ Newbie
 
Registered: Nov 2007
Location: Belgium
Distribution: openSUSE 11.4, opensuse 12.1
Posts: 15

Rep: Reputation: 0
on suse 11.0 it also still isn't fixed. I filed a bug on Novell's bug tracker but it seems they are not very keen on fixing it....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 Install Problem: "Unable to find any device of the type needed for instal" AeroGT3 Fedora 23 05-21-2008 10:40 PM
unable to turn off auto mounting feature sharkus Suse/Novell 1 08-22-2006 03:26 PM
Impossible to turn BROADCAST mode off on ethernet device subjazz Linux - Networking 1 08-17-2004 03:47 AM
How to turn on log for tty device yan Linux - General 0 12-08-2003 04:52 PM
Volume control is unable to run correctly. Unable to open audio device '/dev/mixer'. sevenreams Slackware 1 05-16-2003 07:29 PM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration