LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Unable to compile 64 bit kernel on 64 bit machine even after successful compilation. (http://www.linuxquestions.org/questions/linux-kernel-70/unable-to-compile-64-bit-kernel-on-64-bit-machine-even-after-successful-compilation-755888/)

atulsdeshmukh 09-17-2009 08:40 AM

Unable to compile 64 bit kernel on 64 bit machine even after successful compilation.
 
I want to compile 64 bit 2.6.26 kernel on my 64 machine My distribution is Fedore 9.
I tried the commands
1: make ARCH=x86_64 menuconfig and all other remaing routine makes to compile the kernel.
But after successful compilation when i looked into /lib/modules/2.6.26.2/build/.config
It shows x86_64=n and x86_32=y entries in .config file.
I also checked it by command
file /proc/kcore
but the output is
/proc/kcore: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style, from 'ro root=/dev/VolGroup00/LogVol00 rhgb quie'
Still shows 32 bit kernel..
on my 64 bit machine 32 bit 2.6.26.2 kernel is installed .
Now i want to test my code on 64 bit 2.6.26.2
Can anyone suggest me detailed steps to compile 64 bit kernel.
It would be great help for me.

gael 09-17-2009 09:00 AM

Did you save your configuration file when exciting make menuconfig?

Did you have a look at .config in your source folder before running make all, make modules_install, make install?

G.

atulsdeshmukh 09-18-2009 03:28 AM

Quote:

Originally Posted by gael (Post 3686904)
Did you save your configuration file when exciting make menuconfig?

Did you have a look at .config in your source folder before running make all, make modules_install, make install?

G.

Hi gael,
No,I dint save my .config.But how does it make any diff if i dont want 32 bit kernel on my machine..I looked at it befoore...It were showing
x86_64 = y after make ARCH=x86_64 menuconfig
So i thought i wouldnt get any prob and went further by make all,make modules,make modules_install,make install.
But finally,there were same x86_32 = y in my /lib/modules/2.6.26.2/build/.config file
and same 32 bit stuff by executing command file /proc/kcore ...
I think there must be something extra need to be done..
Surprisingly I was asked some other configuration options when i executed make commnad even after i was done with make ARCH=x86_64 menuconfig..


All times are GMT -5. The time now is 10:18 PM.