LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 07-19-2010, 07:18 PM   #1
0p7imuM Viru1ence
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu 10.04, Fedora 12, OpenSUSE 10.3
Posts: 10

Rep: Reputation: 0
Ubuntu 10.04 Custom Kernel Issue Related to Filesystem


I have compiled and installed a custom version of the 2.6.33.6 kernel. When I boot my laptop, the kernel gives me two messages. They are as follows.

Ext3-fs (sda1): couldn't mount because of unsupported optional features (240).
Ext2-fs (sda1): couldn't mount because of unsupported optional features (240).

I have looked online for this issue, but the closest I can find is this.

http://www.linuxquestions.org/questi...t-seen-760785/

Like I said, it will boot, but not before it gives me these messages.
Here are the outputs for the commands requested in the other post.

fdisk -l /dev/sda

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4679 37584036 83 Linux
/dev/sda2 4680 4864 1486012+ 5 Extended
/dev/sda5 4680 4864 1485981 82 Linux swap / Solaris

dmesg | grep sda

[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.33.6 root=/dev/sda1 ro quiet splash
[ 0.357192] sd 0:0:0:0: [sda] 78140160 512-byte logical blocks: (40.0 GB/37.2 GiB)
[ 0.357267] sd 0:0:0:0: [sda] Write Protect is off
[ 0.357271] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 0.357302] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 0.357506] sda: sda1 sda2 <
[ 0.404857] sda5 >
[ 0.407867] sd 0:0:0:0: [sda] Attached SCSI disk
[ 0.428322] EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
[ 0.428656] EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
[ 0.459967] EXT4-fs (sda1): mounted filesystem with ordered data mode
[ 19.703992] Adding 1485972k swap on /dev/sda5. Priority:-1 extents:1 across:1485972k

This is all the relevant data I can think of to enter. I would like to say thank you in advance to anyone who is willing to help.
 
Old 07-19-2010, 08:13 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,647

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
Is sda1 an ext4 filesystem? Post your /etc/fstab. Does it specify ext4 for sda1?

I don't see a problem here: your filesystem is mounted.
 
Old 07-20-2010, 05:24 PM   #3
0p7imuM Viru1ence
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu 10.04, Fedora 12, OpenSUSE 10.3
Posts: 10

Original Poster
Rep: Reputation: 0
fstab

Oh yeah. Sorry about that. I meant to post my fstab. Here it is:

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=caf97 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=259 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

My harddrive does mount, but the whole reason I compiled the kernel was to speed up boot time. The amount of time I shaved off of my boot process is reduced by the amount of time that these two messages are on the screen. Besides, I don't consider it properly compiled until I don't get error messages on bootup. Thanks for the help.
 
Old 07-20-2010, 06:01 PM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,647

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
Are you saying that the messages cause noticeable delays? Or are you really worrying about the .05 seconds it takes to display them?

Try booting with rootfstype=ext4.
 
Old 07-21-2010, 06:35 PM   #5
0p7imuM Viru1ence
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu 10.04, Fedora 12, OpenSUSE 10.3
Posts: 10

Original Poster
Rep: Reputation: 0
Yes it does cause a noticeable delay. The messages stay on the screen for around 10 to 15 seconds. And where would one enter this rootfstype=ext4? Should that be added to fstab?
 
Old 07-21-2010, 07:36 PM   #6
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,647

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
No, on your kernel boot line. Either at the grub prompt or edit your grub config file(s) and add it.
example line:
Code:
kernel          /vmlinuz-2.6.19.2-rsbac root=/dev/hda3 ro rootfstype=ext4
 
Old 07-22-2010, 08:26 PM   #7
0p7imuM Viru1ence
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu 10.04, Fedora 12, OpenSUSE 10.3
Posts: 10

Original Poster
Rep: Reputation: 0
I tried entering it manually during boot up, and it worked. So, I went in and added it to my grub.cfg file, and now it works perfectly. Thank you for helping me shave 20 seconds off my boot time. My initial guess of 10 to 15 seconds was just a guess. Actual measurement of boot time showed that 20 seconds passed while those messages showed. Now, I just need to make sure I've gotten rid of all excess modules and kernel options so that it's perfectly customized for my machine. Thank you again for your patient and explanatory help.
 
  


Reply

Tags
ext2fs, ext3fs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu installation issue with custom RAID Rommsey Ubuntu 1 05-11-2010 01:59 AM
Booting a custom kernel with a new root filesystem LinuxNewman Linux - General 10 04-19-2009 10:53 PM
Filesystem-Related Kernel Panic Arg0nyX Linux - Kernel 2 07-04-2007 03:28 PM
Custom kernel causing odd issue mdkusr Slackware 14 11-20-2006 07:07 PM
Kernel/Source-Related Issue Help Megadeth08902 Linux - Software 0 02-17-2005 11:07 PM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration