LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 12-06-2008, 07:11 AM   #1
deadkenny
LQ Newbie
 
Registered: Sep 2007
Location: Woking, UK
Distribution: Fedora 7
Posts: 3

Rep: Reputation: 0
True Image boot problem: cmov feature not present on CPU


Hi,

I'm not really sure what's the right forum for this, but seemed to make sense here as it's a kernel boot issue.

I've got True Image Home 2009, which although I bought to backup my Windows boxes, it also comes with a boot CD that turns out (I believe) to be a linux variant of some sort. The specs also say it supports linux filesystems.

So I thought I'd have a go on my mail server (which runs Fedora), and see if it will boot and try and do a backup image. Would be great for when I make major changes on the server.

However on booting it comes up with this:

"This kernel requires the following features not present on the CPU: cmov
Unable to boot - please use a kernel appropriate for your CPU."

and that's as far as it will go.

Now, the machine is somewhat antique, but then I never believe in throwing out old machines if it can do the job (it's just a mail and low use web server and performs fine). It's an old AMD K6-2 400Mhz.

It's been running versions of Red Hat through to Fedora 8 (currently) with no problem at all. It's currently running 2.6.26.6 kernel.

I understand there may be some options I can give to the True Image boot, either through a key press on boot, or I can provide options when I burn the image to CD using their utility to do so. Would there be any such option to make it work? I don't specify anything for Fedora though.
 
Old 12-06-2008, 08:43 AM   #2
fordeck
Member
 
Registered: Oct 2006
Location: Utah
Posts: 520

Rep: Reputation: 61
I'm not sure this is relevant, but here is a link that talks about a similar issue:

http://www.wilderssecurity.com/archi.../t-101919.html

you might try there suggestion as follows:

{QUOTE-> Please try the following workaround:
Please boot your computer from the Acronis True Image rescue disc (the full version) and press F11 key when the "Starting Acronis Loader..." message appears. After you get the "Linux kernel command line" prompt, please modify it in the following way:

quiet acpi=off noapic <-QUOTE}

Regards,

Fordeck
 
Old 12-06-2008, 02:12 PM   #3
deadkenny
LQ Newbie
 
Registered: Sep 2007
Location: Woking, UK
Distribution: Fedora 7
Posts: 3

Original Poster
Rep: Reputation: 0
Cheers. Gave that a go, but sadly I just get the same error. Looking around it seems I may need the kernel recompiled without cmov to get it to work perhaps? Job for Acronis really, so time to contact them.

Their minimum spec is a Pentium, and wouldn't a K6-2 come above a Pentium? So in which case they should support it.
 
Old 09-05-2009, 08:31 AM   #4
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia
Posts: 84

Rep: Reputation: 15
The cmov issue is a known problem not only with Acronis but even general distros like Centos, Mandriva, etc.

The problem is that certain CPU's, even though they are "pentium class", lack the cmov instruction. At some point a few years ago, the default 586/686 build of the booter (isolinux?) started requiring cmov.

This totally hosed VIA C3 processors and AMD K6/2. When I upgraded to TrueImage 10, Acronis support eventually sent me an updated iso to boot that would work on CPU's without cmov.

Unfortunately, version 10 doesn't support the default block sizes of newer ext3 filesystems. So I upgraded to TrueImage 2009. Ug, it has the exact same cmov issue as before, and I am still working with support, trying to get them to "relearn" how they fixed it last time.
 
  


Reply

Tags
acronis, amd, boot, image, iso, isolinux, kernel, true


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acronis True Image ? cccc Linux - Software 1 11-29-2008 10:10 AM
Installing Acronis True Image - SnapAPI problem PlymWS Suse/Novell 1 03-26-2008 02:09 AM
True image or Ghost for Linux? DotHQ General 5 08-27-2007 04:50 PM
Ghost 9 or Acronis True Image 8? nathanv117 Suse/Novell 0 01-09-2005 08:11 PM
problem: freebsd boot loader still present after 'fixmbr' veritas *BSD 3 06-24-2004 02:43 PM


All times are GMT -5. The time now is 01:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration