LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 05-21-2006, 11:45 PM   #1
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Rep: Reputation: 0
Slackware Linux kernel upgrade difficulties.


Hi, this is my first time upgrading the kernel on my computer (currently running under slackware) and when I try to load with the new kernel, after a line reading

"input: Alps PS/2 ALPS Glidpoint as /class/input/input5"

it hangs up reading

alx_get_response timeout.

Which repeats indefinitely.
My best guess at this point is to load up my previous kernel and attempt to fix the new kernel config file, but honestly I have no clue where to start. Any recommendations? Thanks in advance.
 
Old 05-22-2006, 04:40 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You've left out all the important information so that someone can help you. Rather than asking you a lot of questions to find out what you've done, I'm going to refer you to How To Ask Questions The Smart Way.

If you get offended, you won't read that article and you won't learn anything. But if you decide to read it, you'll learn a lot about how to post a good question, which will in turn get some good answers. Also, you will learn how to search for answers yourself.

Kwan Lowe has written an excellent Kernel Rebuild Guide which should answer any questions you have about rebuilding your kernel. As for specific options, it is necessary to read the Help for each item when you issue "make xconfig" during the rebuild process. This will take a lot of time, but you'll learn about your hardware, and the options available in the Linux kernel.

It's a good idea to keep your original kernel, so that if anything goes wrong building a new one, you can boot back into the old one.

If after reading that article and the kernel rebuild guide, you still have questions, please post them back. With a little bit of background information about your system, and what you've done to get to where you are.

This simple kernel rebuild guide is the way I do it in Slackware. As a matter of fact, because of changes made in the 2.6.16.17 stable kernel, I am upgrading the kernel on 4 Slackware boxen right now.

You might not see this as such, but it's meant to help you.

If you can't boot back into your default, original kernel, just say so...
 
Old 05-22-2006, 05:47 PM   #3
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you for the reply. First let me apologize for my other post, I didn't forget what I had said on my earlier post, which is why I made a point not to post again asking a moderator to move my thread to the proper forum, and rather opted to post the thread in the proper forum, taking into consideration that bothering a mod is more trouble for the moderator than it would be worth. I didn't mean to make this seem like a bratty poster's impatient attempt to get an answer, which is why im issuing an apology in the first place. Take it as you will, though if you still see me as a 'liar' then you probably won't belive the credibility of this response.

As for the current question, I'll try to be a bit more specific.

I'm using a VGN-S580 vaio laptop, attempting to upgrade the default Slackware 10.2 kernel (2.4 something) to the newest (2.5.16.17). I am following this guide almost to the letter, and the only viable solution must be that I messed up the kernel config file. The system hangs up after the lines

input: PS/2 Mouse as /class/input/input4
input: Alps PS/2 ALPS Glidpoint as /class/input/input5

are displayed. This leads me to believe that I configured the peripheral device section incorrectly at one point or another, but I cannot figure out which one. I will read through the guides you suggested however, thank you. When I find the answer I'll post it.


edit:: I am also using this as a resource, posting it as it may/may not help. Thanks.

Last edited by soulseraph; 05-22-2006 at 06:12 PM.
 
Old 05-22-2006, 05:57 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,174
Blog Entries: 4

Rep: Reputation: 428Reputation: 428Reputation: 428Reputation: 428Reputation: 428
Quote:
Originally Posted by soulseraph
Thank you for the reply. First let me apologize for my other post, I didn't forget what I had said on my earlier post, which is why I made a point not to post again asking a moderator to move my thread to the proper forum, and rather opted to post the thread in the proper forum, taking into consideration that bothering a mod is more trouble for the moderator than it would be worth. I didn't mean to make this seem like a bratty poster's impatient attempt to get an answer, which is why im issuing an apology in the first place.
As the moderator who closed your other thread, it is no trouble. If you need a post to be moved because you think it's in the wrong forum, report it and request a move. It looks far worse if you post again.
 
Old 05-22-2006, 07:05 PM   #5
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Original Poster
Rep: Reputation: 0
After digging around a bit, I figured out that ALPS is my touchpad, (after checking back, it was right on that gentoo page I linked to) and came across this page which says

Quote:
I did NOT allow GPM to load at boot time. (The Alps/Synaptics driver sometimes has problems with this).
So then the question now is, what is GPM (gallons.. per.. minute..?) and how can I disable it from loading at boot time. Sorry if this is a noobish question, but then again I've only been using linux for a week. Thank you for all the help.
 
Old 05-22-2006, 07:08 PM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Issue and read "man gpm" -- copy and paste with mouse -- Windoze can't do this.

Whilst you're reading I was already posting a long one to you.
 
Old 05-22-2006, 07:47 PM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by soulseraph
As for the current question, I'll try to be a bit more specific.

I'm using a VGN-S580 vaio laptop, attempting to upgrade the default Slackware 10.2 kernel (2.4 something) to the newest (2.5.16.17). I am following this guide almost to the letter
That guide has some things which are inconsistent with the instructions that are provided with the Linux kernel source. Linus Torvalds has posted the correct method in every kernel source in a file called README. You can read it at ./linux-2.6.16.17/README (wherever you unpacked it - assuming /usr/src/linux-2.6.16.17/README according to the guide you referenced).

First inconsistency in that guide:
Quote:
A real good choice is /usr/src
Let me quote from Linux Torvalds in ./linux-2.6.16.17/README:
Code:
INSTALLING the kernel:

 - If you install the full sources, put the kernel tarball in a
   directory where you have permissions (eg. your home directory) and
   unpack it:

		gzip -cd linux-2.6.XX.tar.gz | tar xvf -

   or
		bzip2 -dc linux-2.6.XX.tar.bz2 | tar xvf -


   Replace "XX" with the version number of the latest kernel.

   Do NOT use the /usr/src/linux area! This area has a (usually
   incomplete) set of kernel headers that are used by the library header
   files.  They should match the library, and not get messed up by
   whatever the kernel-du-jour happens to be.
which is why I build my kernels in /home/mingdao/kernel/

NB: With Slackware, as opposed to some other distros, you can build kernels in /usr/src/ but there is absolutely no reason to break the original linux -> linux-2.4.32/ symlink if you do so. There are other good reasons to build under /home, but quite frankly, I'm not interested in but a little bit of rebuttle today.

Evidence:
Code:
mingdao@silas:~$ ls -lh /usr/src/
total 1.0K
lrwxrwxrwx  1 root root  12 2006-01-27 01:26 linux -> linux-2.4.32/
drwxr-xr-x 15 root root 584 2006-04-29 11:44 linux-2.4.32/
drwxrwxrwx 19 root root 856 2006-04-13 06:43 linux-2.6.16.2/
drwxr-xr-x  7 root root 168 2003-10-29 14:08 rpm/
drwxr-xr-x  2 root root 176 2005-12-05 06:35 speakup-2.4.32/
This system was installed from Slackware -current with 2.4.32, rather than 2.4.31 from Slackware-10.2. It's other kernels are here:
Code:
mingdao@silas:~/kernel$ ls -lh
total 117M
-rwxr-xr-x  1 mingdao users 5.1K 2006-05-08 05:59 2.6-kernel-build.txt*
-rw-r--r--  1 mingdao users 2.1K 2006-02-10 09:16 build_times
drwxr-xr-x 19 mingdao users  896 2006-05-11 20:51 linux-2.6.16.14/
-rw-r--r--  1 mingdao users  39M 2006-05-07 09:10 linux-2.6.16.14.tar.bz2
drwxr-xr-x 19 mingdao users  680 2006-05-11 09:56 linux-2.6.16.16/
-rw-r--r--  1 mingdao users  39M 2006-05-11 10:06 linux-2.6.16.16.tar.bz2
drwxr-xr-x 20 mingdao users 1.4K 2006-05-22 19:32 linux-2.6.16.17/
-rw-r--r--  1 mingdao users  39M 2006-05-21 06:18 linux-2.6.16.17.tar.bz2
mingdao@silas:~/kernel$ uname -a
Linux silas 2.6.16.17 #1 Mon May 22 10:49:19 CST 2006 i686 athlon-4 i386 GNU/Linux
Yesterday while posting to you I built 2.6.16.17 on 4 totally different Slackware boxen.

Second inconsistency in that guide:
Quote:
While your looking, you should also see a folder with a shortcut mark named linux in /usr/src. Go ahead and delete that folder.
See Torvald quote above ^^ for why you do NOT do this.

Third inconsistency in that guide:
Quote:
make bzImage
cp /usr/src/linux/arch/i386/boot/bzImage /boot/vmlinuz-2.6.5
make modules
make modules_install
cp System.map /boot/System.map-2.6.5
cp .config /boot/config-2.6.5
Someone obviously doesn't understand what's changed from 2.4.x to 2.6.x.y. The makefile for 2.6.x.y builds the kernel image (bzImage) and makes the modules. If you watch the text on your screen when you issue "make" you will see both of these events happen.

So, according to Linus, the proper steps are:
Code:
make config (there are 5 types -- this makes your .config file -- select options and save)
make (this creates a compressed kernel image and makes modules if you selected any)
make modules_install
copy the kernel image (e.g. .../linux/arch/i386/boot/bzImage after compilation) to the place where your regular bootable kernel is found
edit /etc/lilo.conf
rerun /sbin/lilo as root
reboot
The step I use of "cp System.map /boot/System.map-2.6.16.17 ; ln -sf /boot/System.map-2.6.16.17 /boot/System.map" is not needed according to Linus. And there is no precedent IMO for copying the .config file to the /boot directory, as it doesn't use it.

I have simple guides for Slackware that you can follow posted in LQ.
To build under /home
To build under /usr/src/ without breaking the orginal linux symlink

Quote:
Originally posted by soulseraph
the only viable solution must be that I messed up the kernel config file. The system hangs up after the lines

input: PS/2 Mouse as /class/input/input4
input: Alps PS/2 ALPS Glidpoint as /class/input/input5
When you have a laptop, the first places to look for Linux information is:
Linux on Laptops (which had no entry for yours)
TuxMobil (which has a great entry for yours)
Sony_VGN_S580 (don't be intimidated because it's Gentoo and not Slackware)

That guy posted a lot of stuff, be he also seems to have used Gentoo packages rather than doing anything by hand. This might be good, but you can't extrapolate and learn anything from it -- you could just install Gentoo like he did. Maybe you could get the packages and extract and read them, I don't know. From looking at his "lspci" output, and the fact that he has no information in his "ALPS Touchpad /cat /proc/bus/input/devices" section; I would assume that he has it turned off in the BIOS and is using perhaps a USB mouse instead. But I can't be sure.

The other link you provided as Slackware information for the ALPS touchpad is by cwwilson721 here in LQ, and if you have problems, he would be glad to help you. I believe following his steps will get the touchpad working.

Okay, that's all my posting time for this day. Need more help? There's a Slacker ready to give it.
 
Old 05-23-2006, 07:54 PM   #8
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Original Poster
Rep: Reputation: 0
SCORE!

Kernel 2.6.16.17 is WORKING!

It takes quite a long time to load, and my computer is going extremely slow, but it works regardless. Time to get to login: 5:02.
It hangs up at a few select points, at

Quote:
input: AlpsPS/2 ALPS GlidePoint as /class/input/input5
..again, for about 30 seconds, as well as

Quote:
dhcpcd: MAC address = 00:01:4a:84:de:92
for close to 45 seconds. Not to mention my computer is slow overall, alot slower than usual. Is the guide here good for making it work smoother or is there anything that you would advise against? Alot of what this guy has to say sounds legit, but thought it would be best to run it by others first. Thanks a lot for the help!
 
Old 05-23-2006, 08:16 PM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
My only experience with a ALPS device goes back to 2003 before my Sony laptop's southbridge chip burned out, so I can't help you. But you could try to disable the GPM server, if what cwwilson721 said applies to your computer. Just issue as root "chmod -x /etc/rc.d/rc.gpm" which will disable the GPM server. If this helps your boot times, leave it like that. If not, then change it back by issuing as root "chmod +x /etc/rc.d/rc.gpm" and it will start again.

As for the MAC address issue, can you post some files and information about what you're using for internet? Wired, wireless?

If wireless, there are some Slackware instructions in Alien_Bob's wiki.

And your computer might be slower because DMA is not turned on. Just a shot in the dark there. You can check by issuing as root "hdparm /dev/hda" or whatever your hard drive happens to be. You want to see something similar to this:
Code:
root@silas:~# hdparm /dev/hda

/dev/hda:
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 HDIO_GETGEO failed: Inappropriate ioctl for device
Drive is an ATA -- settings like that will work for you okay depending upon the hard drive. I'll check on my error when I get back in country.

Last edited by Bruce Hill; 05-23-2006 at 08:17 PM.
 
Old 05-24-2006, 12:45 AM   #10
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Alright. When issuing "hdparm /dev/sda" what returned was

Code:
/dev/sda:
 IO_support   =  0 (default 16-bit)
 readonly     =  0 (off)
 readahead    =  256 (on)
 geometry     = 9729/255/63, sectors = 156301488, start = 0
I was gonna try to install nvidia drivers but maybe its better to hold off on that for a while, heh. I have wireless by the way, and went to the site you recommended, but it didnt help much (rather, I dont know how to utilize it properly im guessing).

Anyway back to DMA, I don't know how to turn it on yet but i'll figure it out, and will probably be able to do so by tomorrow :P Thanks for pointing me in the right direction.

edit:: Alright, after wandering a bit I came across this site which sported tempting solutions (which didnt work). Oh well data corruption doesnt sound that great to begin with. When I ran "hdparm -tT /dev/sda" I got:

Quote:
/dev/sda:
Timing cached reads: 3812 MB in 2.00 seconds = 1909.90 MB/sec
Timing buffered disk reads: 102 MB in 3.02 seconds = 33.82 MB/sec

Last edited by soulseraph; 05-24-2006 at 01:46 AM.
 
Old 05-24-2006, 08:38 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You can install the Nvidia driver -- no problem. Just change you "/etc/X11/xorg.conf" file according to the Nvidia README instructions. The driver and REAME are here -> http://www.nvidia.com/object/linux_d..._1.0-8762.html

As for hdparm on SATA drives, you probably don't have the proper support in your kernel.

I'm ssh'ing into my server, then to my PC, from the road -- but I think this is what I have for DMA in a kernel with SATA drives:
Code:
mingdao@silas:~/kernel/linux-2.6.16.18$ cat .config | grep -i dma
CONFIG_GENERIC_ISA_DMA=y
CONFIG_ISA_DMA_API=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
# CONFIG_BLK_DEV_IDEDMA_FORCED is not set
CONFIG_IDEDMA_PCI_AUTO=y
# CONFIG_IDEDMA_ONLYDISK is not set
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_IDEDMA_IVB is not set
CONFIG_IDEDMA_AUTO=y
 
Old 05-25-2006, 02:49 PM   #12
soulseraph
LQ Newbie
 
Registered: May 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Yeah, I went to the site you linked (for the graphics card) and used the .run file, but it still refuses because the 'module license taints the kernel'

Quote:
nvidia: module license 'NVIDIA' taints kernel.
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: rivatv was loaded and obtained ownership from the NVIDIA
NVRM: device(s).
NVRM: Try unloading the rivafb, nvidiafb, or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support.), then try loading the NVIDIA kernel module again. No NVIDIA graphics adapter probed!
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com
rivafb, nvidiafv and rivatv kernel modules are all unloaded, so I dont know what else there is to do. I'm going to post on the nvidia Linux support forums in a bit to see if they can help.

Also, for my DMA, they match your .config file, except for 1- my .config file is named 'defconfig' under /home/soul/linux-2.6.16.17/arch/i386/defconfig
and two, the file doesnt contain the line
Quote:
CONFIG_ISA_DMA_API=y
At all. Will fixing my DMA really make my computer run alot faster? Thanks again.

Last edited by soulseraph; 05-25-2006 at 02:58 PM.
 
Old 05-26-2006, 06:20 PM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
This was the key error message:
Code:
NVRM: Try unloading the rivafb, nvidiafb, or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support.), then try loading the NVIDIA kernel module again. No NVIDIA graphics adapter probed!
Either the Nvidia installer is broken, or you have one of those configured in your kernel. I suspect that since this was your first go at compiling a kernel, and you know you have a Nvidia chipset, that you compiled the nvidia framebuffer driver here:
Code:
#
# Graphics support
#
# CONFIG_FB_NVIDIA is not set
It should be like this ^^^ and not =y or =m for any of those three (rivafb, nvidiafb, or rivatv). If you have any of them compiled into your kernel or as a module, you'll need to rebuild your kernel. Just "cd /home/soul/linux-2.6.16.17/" and run "make xconfig" and unselect all three of those, being sure you have "CONFIG_FB=y" and " CONFIG_FB_VESA=y" and then run:
Code:
$ make
# cp System.map /boot/System.map-2.6.16.17 ; ln -sf /boot/System.map-2.6.16.17 /boot/System.map
# make modules_install
# cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.16.17
# pico /etc/lilo.conf   <-- no need to change LiLO for the same version 
# lilo   <-- but you must run this to reinstall LiLO 
# reboot
and enjoy Slackware goodness with a shiny new kernel.



Then in "/etc/X11/xorg.conf" you should have:
Code:
# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
#    Driver      "nvidia"
<snip>
If you get your kernel correct, the new Nvidia driver will reconfigure "/etc/X11/xorg.conf" for you, and make a backup. On the comps that I've let it do that, everything has still worked fine.

And yes, if you get the proper chipset for your IDE bus, SATA or RAID controller; and get DMA set properly, you should at least get in the 60's from "hdparm /dev/sda". I have SATA drives in 3 of our 6 comps and they all get that, with different motherboards -- one older Intel chipset and two VIAs.

About your kernel's .config file. That "/home/soul/linux-2.6.16.17/arch/i386/defconfig" is where "make" puts your configuration during kernel building -- it is your default (def) configuration (config) file. But you NEVER touch that -- you use "/home/soul/linux-2.6.16.17/.config" when rebuilding kernels.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Kernel upgrade carlosinfl Slackware 8 06-18-2005 12:33 AM
Slackware boot difficulties +0+4|_ n00b Linux - Newbie 4 01-27-2005 04:10 PM
Slackware 10 - Botched kernel 2.6.7 upgrade MDesigner Slackware 14 06-25-2004 05:16 PM
adaptec.s kernel upgrade for slackware? cybrjackle Slackware 2 12-09-2003 07:58 PM


All times are GMT -5. The time now is 03:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration