LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   /proc/mounts - acreg* and acdir* inconsistencies... (http://www.linuxquestions.org/questions/linux-kernel-70/proc-mounts-acreg%2A-and-acdir%2A-inconsistencies-783805/)

larold 01-21-2010 01:32 PM

/proc/mounts - acreg* and acdir* inconsistencies...
 
[I sincerely apologize if this is the wrong forum - but this regards certain options that sometimes appear in /proc/mounts, and sometimes don't, even with the same mount options in /etc/fstab, same kernel, etc. Please move this to a different forum if necessary.]

I am helping a client set up several Linux boxes that are now running Oracle. The Oracle consultants at my client have asked me to set up an NFS mount from one server (we'll call 'server') to another box (we'll call 'client').

The Oracle consultants are getting an Oracle error when trying to run their rman backups on 'client', which complains that it can't create a file on the NFS mount, and that there are one or more incorrect NFS mount options. Please keep in mind, during other Oracle backup runs in the same night, it can create plenty of other files and directories on the same mount / directory hierarchy. Also, apparently this version of Oracle has been updated to scan /proc/mounts - or so the consultants tell me.

So here's the dilemma. The Oracle consultants have said "Hey, you had set up a different NFS mount for us before (which bit the dust due to multiple drive failure), with the following set of options visible in /proc/mounts, and it worked. This set of mount options they showed me in /proc/mounts (they had captured the output and saved it), included acregmin=0, acregmax=0, acdirmin=0, and acdirmax=0.

Now, with this new NFS mount, I have specified the EXACT SAME options in /etc/fstab on 'client'. However, this time, when the NFS mount gets mounted on client, the /proc/mounts file shows many of the same options as before, "when it was working", but it does NOT show any of the acreg* or acdir* attributes.

To complicate things further, I set up an additional client to test, and exported the same NFS mount to this new client. I copy and pasted the /etc/fstab entry from the original client to the next client. Upon mounting, the acreg* and acdir* entries DID show up in /proc/mounts, all with values of 0. (Please keep in mind - the only 'ac*' option I'm setting in all of these /etc/fstab files is 'actimeo=0'.

Because the Oracle consultants will not get the 'warm fuzzies' until I can show them the acreg* and acdir* (=0) entries in /proc/mounts to appear, can someone explain to me why and when these will or will not show up? If I don't see these options in /proc/mounts, do I assume they have the default values specified in the nfs(5) man page?

For what it's worth, uname -r shows 2.6.18-128.1.14.el5 on both clients and the server.

Please let me know what other information I can provide that can help.

My main goal, overall, is to get the Oracle backups to work - avoiding the file creation error they get. However, I wonder if the error message about bad NFS file options is misleading. I have specified EXACTLY what the Oracle consultants have wanted in /etc/fstab, but they're all stuck on the fact that /proc/mounts doesn't look exactly like it did before.

THANKS for the help!!


All times are GMT -5. The time now is 03:22 PM.