LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   proc, dev and others not mounted on boot after HD changed (http://www.linuxquestions.org/questions/linux-kernel-70/proc-dev-and-others-not-mounted-on-boot-after-hd-changed-659267/)

auroraglacialis 07-30-2008 10:21 AM

proc, dev and others not mounted on boot after HD changed
 
Hi.

I rsynced my Fedora 9 System from a RAID 1 on md1/md2 to a new RAID (md3/md4). md2 and md4 are / while md1/md3 are /boot/. When I try to boot from the new system, I can't do so. The errors are "could not find filesystem /dev/root" and the same for /dev /sys /proc and so on.

I made a new grub.conf, changed /etc/mdadm.conf and /etc/raidtab, made a new initrd and re-installed grub - no success until now.

What else can I do? What have I done wrong? Do I need to do something to the /proc /dev folders on the new system?

Thanks
Aurora

syg00 07-31-2008 06:53 PM

D'oh - ignore me. Gotta learn to read the whole post.

auroraglacialis 08-06-2008 08:57 AM

[SOLVED] proc, dev and others not mounted on boot after HD changed
 
Just wanted to explain what I did:

I had to make a new initrd with mkinitrd.

HOWEVER, I had to do a chroot into the new system (i used the knoppix DVD to make the changes in RAID configuration and to do the rsync. The trouble was, that I could not chroot because Knoppix is 32bit and my Fedora is 64bit. So I had to do it from my running Fedora system after I copied it. I had to mount /dev, /proc and /sys to the new chroot environment prior to chroot. But it helped, RAID is starting now.

Ciao
Aurora


All times are GMT -5. The time now is 05:17 PM.