LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 12-05-2006, 07:36 PM   #1
cigamiga
LQ Newbie
 
Registered: Nov 2006
Location: Serbia, Subotica
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Unhappy problem with kernel 2.6.19 and ati radeon drivers


compiled 2.6.19 and its working superbly but when i tried to compile my ati radeon drivers (v. 8.31.5) i get this error when i go into /lib/modules/fglrx/build_mod

Code:
root@dread:/lib/modules/fglrx/build_mod# sh make.sh
ATI module generator V 2.0
==========================
initializing...
cat: /lib/modules/2.6.19/build/include/linux/version-*.h: No such file or directory
make.sh: line 451: [: =: unary operator expected
make.sh: line 525: [: =: unary operator expected
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.19/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.19'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:89:26: linux/config.h: No such file or directory
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:456: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `firegl_stub_open':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:579: warning: assignment discards qualifiers from pointer target type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_request_irq':
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2528: warning: passing arg 2 of `request_irq' from incompatible pointer type
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.19'
make: *** [kmod_build] Error 2
build failed with return value 2
just for the record i have ati radeon 9600XT, and if u need any info or got any solutions how can i make my 3D games work fine ;p (mmorpg ftw ;p) just post ;p

thx in advance
 
Old 12-06-2006, 12:50 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:89:26: linux/config.h: No such file or directory
This problem has also cropped up in the wireless forums. I haven't had time to dig into it, but apparently 2.6.19 doesn't have a config.h file and that is breaking both ATI drivers and madwifi wireless drivers.

The only information I've found about it is here and it sounds like config.h is gone for good. You'll likely either have to go to an earlier kernel or wait for a patch to the ATI drivers.
 
Old 12-06-2006, 04:08 PM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
There is a similar post on the Slackware forum and apparently doing

touch /usr/src/linux/include/linux/config.h


first will take care of this problem. Just be sure /usr/src/linux points to your kernel source directory (or adjust the command).
 
Old 12-06-2006, 04:56 PM   #4
cigamiga
LQ Newbie
 
Registered: Nov 2006
Location: Serbia, Subotica
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
will try with touch-ing...now too busy getting fat

thx, gonna post if i get something good out of it (not my fat ;p )

cheers
 
Old 12-07-2006, 10:19 AM   #5
cigamiga
LQ Newbie
 
Registered: Nov 2006
Location: Serbia, Subotica
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
i compiled drivers without any errors but there is no 3d acceleration, and i configured nicely my xorg.conf

here is the error i get in Xorg.0.log

Code:
--- snip ---
(II) fglrx(0): driver needs X.org 6.8.x.y with x.y >= 99.8
(II) fglrx(0): detected X.org 7.0.0.0
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
--- snip ---
does ati have working drivers for 6.9.0 X.org ? those drivers are compiled for 6.8.x.y (that says in log file) but i guess they compile for 6.9.0 but without 3k acceleration

if u need more info from log just tell me...
and i have 6.9.0 X.org not 7.0.0 ;p

if anyone have managed who has slackware 11 to get his ati radeon going on nicely plz share your knowledge

thx in advance
 
Old 12-07-2006, 01:21 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Have you checked out this thread in the Slackware forum?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ATI Mobility Radeon 7500 Drivers The_Awesome Linux - Hardware 1 07-09-2006 01:47 PM
ATI drivers fakes- Impossible to run 3D on ATI Radeon 9550 ilpadrino Linux - Hardware 29 06-24-2006 02:59 PM
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
ATI Radeon 9600 drivers problem Zig Linux - Hardware 15 03-19-2004 03:06 PM
ATI Radeon Drivers & MesaGL problem elbozo Linux - Hardware 2 10-02-2003 01:50 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration