LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Overheating w/ ACPI (http://www.linuxquestions.org/questions/linux-kernel-70/overheating-w-acpi-437840/)

samuelpauls 04-22-2006 06:39 PM

Overheating w/ ACPI
 
Greetings,

I have a Toshiba A60-WM1 laptop that hasn't had any overheating problems in the past. It still doesn't if I boot into Kubuntu 5.10. This was the same at first as I was booting into my own custom Linux From Scratch 6.1 system but now in LFS, specifically, the computer will overheat during compilation of larger programs. Since it's a A60-WM1, it will power off immediately when the temperature hits around 85 C. This started happening after I compiled the Madwifi drivers for my Atheros wireless adapter into the kernel. There is also a small chance I am missing something else that changed to cause this overheating problem, but I doubt it.

I would be grateful to know the answer to this "burning" question: How do I keep my laptop from overheating in LFS like it used to?

# dmesg | grep ACPI
...
ACPI: Fan [FAN1] (off)
ACPI: Thermal Zone [THZN] (73 C)
...

I only have one thermal zone as detailed below:
-----
# cat /proc/acpi/thermal_zone/THZN/*
cooling mode: active
<polling disabled>
state: ok
temperature: 72 C
critical (S5): 105 C

I only have one fan in fan/ but suspect that the computer has another non-controllable one:
------
# cat /proc/acpi/fan/FAN1/state
status: off

When I "echo 0 > state" the status of FAN1 changes to on but I don't hear any extra fans starting up.

samuelpauls 04-23-2006 05:08 PM

Resolved
 
After compiling many extra features into my Linux kernel, the temperature no longer sky-rockets to 85 C and causes power down on my laptop! It's interesting to note that I already had the obvious ACPI features compiled in and it goes to show that for ACPI to work correctly, you sometimes have to compile in non-obvious things besides thermal zones, fan control, and your vendor's special kernel stuff.


All times are GMT -5. The time now is 08:28 AM.