LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 05-01-2011, 10:36 AM   #1
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
No or empty root= argument


Hello all. I just compiled the 2.6.38.4 kernel and was booting it and I got a "No or empty root= argument". Then, I boot into my other kernel and check out my grub menu.lst and there is indeed a root= argument. It says:

Code:
ro root=/dev/mapper/vg0-ROOT
Menu.lst:

Code:
#boot=/dev/sda
default=2
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.38.4)
	root (hd0,0)
	kernel /vmlinuz-2.6.38.4 ro root=/dev/mapper/vg0-ROOT rd_LVM_LV=vg0/ROOT rd_LVM_LV=vg0/SWAP rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.38.4.img
title Fedora (2.6.39-rc5)
	root (hd0,0)
	kernel /vmlinuz-2.6.39-rc5 ro root=/dev/mapper/vg0-ROOT rd_LVM_LV=vg0/ROOT rd_LVM_LV=vg0/SWAP rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.39-rc5.img
title Fedora (2.6.35.12-90.fc14.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.35.12-90.fc14.x86_64 ro root=/dev/mapper/vg0-ROOT rd_LVM_LV=vg0/ROOT rd_LVM_LV=vg0/SWAP rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.35.12-90.fc14.x86_64.img
title Fedora (2.6.35.12-88.fc14.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.35.12-88.fc14.x86_64 ro root=/dev/mapper/vg0-ROOT rd_LVM_LV=vg0/ROOT rd_LVM_LV=vg0/SWAP rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.35.12-88.fc14.x86_64.img
title Fedora (2.6.35.11-83.fc14.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.35.11-83.fc14.x86_64 ro root=/dev/mapper/vg0-ROOT rd_LVM_LV=vg0/ROOT rd_LVM_LV=vg0/SWAP rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.35.11-83.fc14.x86_64.img
title Other
	rootnoverify (hd2,0)
	chainloader +1
 
Old 05-01-2011, 06:15 PM   #2
plpl303a
Member
 
Registered: May 2011
Posts: 52

Rep: Reputation: 3
I notice your root partitions are all on LVM volumes. Might the newly compiled kernel be missing LVM (or have it compiled as a module)?
 
Old 05-01-2011, 08:14 PM   #3
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Original Poster
Rep: Reputation: 38
Yea I was thinking the same thing. But if you notice, I compiled the 2.6.39-rc5 kernel as well. While compiling, I missed the "make *config" step because I just wanted the generic modules. That kernel boots fine. The one I'm trying to get to work is 2.6.38.4, which I edited heavily with "make gconfig", the gtk config program. I didn't see anything for LVM in there, but its worth to look. I'll post back after recompile.

Thanks

Alex
 
Old 05-01-2011, 09:51 PM   #4
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Original Poster
Rep: Reputation: 38
Well, I recompiled with different modules (mostly just an array of file systems support)(none of which are LVM since there is no option for it) now it gives me an

Code:
Error 253: Error parsing number
or something to that effect. Maybe it has something to do with the modules I am choosing to compile my kernel with...

Thanks

Alex

Last edited by abrinister; 05-01-2011 at 09:53 PM.
 
Old 05-05-2011, 07:24 PM   #5
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Original Poster
Rep: Reputation: 38
Ok well I left alone the 2.38.4 kernel and got a fresh 2.38.5 source from the kernel site. I compiled it with tons of modules, and it all completed. It boots up fine until after the splash screen, when it tells me that there is no root device and that boot has failed forever. Why does this happen? Do I have to change the root directory in some file to make it work? This same problem happened to me when I built the rpm for an earlier kernel.

Thanks

Alex
 
Old 05-06-2011, 04:49 PM   #6
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Original Poster
Rep: Reputation: 38
Ok I have found out the problem. Dracut is not finding a root partition because it is not initializing the volume group that the root partition is on. A quick and dirty fix to this is to add rdshell to your grub configuration file, then dracut will drop into a shell if it doesn't boot. From this shell, you need to enter:

Code:
lvm vgchange -ay
and then exit the shell by entering "exit". The kernel will then boot just fine. I do not think this is good fix, as you need to do this every time you boot. If anyone knows how to make this command run at boot by default, please share.

Thanks

Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] shell scripting: value of argument dissapears depending on argument order akelder Programming 5 03-22-2011 12:27 AM
Can't remove empty dir from ntfs-3g partition even by root! Linux For Ever Slackware 3 08-01-2009 02:21 PM
message sending failed : Error[22 ] invalid argument .....but each and every argument rakeshranjanjha Linux - Software 2 01-08-2008 12:22 AM
Needing root to empty the bin??! hongman Linux - Newbie 2 03-01-2005 02:43 AM
Merging empty hard drive with root partion on ext3? crayolarx Linux - General 11 03-06-2004 04:29 PM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration