LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 08-14-2009, 07:40 PM   #1
acalderon
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Rep: Reputation: 1
Talking [Solved] Machine hangs on boot. kernel or Initrd not loaded.


Hi,

My machine hangs on boot.

After freshly installing Debian 5.0 (lenny). I rebooted the system and when I selected the default GRUB entry I got a similar console output and it halted:

Code:
Booting 'Debian GNU/Linux, kernel 2.6.26-2-686'

root (hd0,0)
Filesystem is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
[Linux-bzImage, setup=0x3000, size=0x16c910]
Then, all you get is the blinking cursor at the next line. Just blinking indefinitely.

I tried using the rescue mode from the Debian net install disk to try and fix the GRUB installation, if in case there was any problem with it, with no luck.

Any suggestions or ideas?

I also tried to install sOS with similar results. The difference is that after the the GRUB entry selected I just get a black screen with a blinking cursor. I believe that the loglevel=0 kernel option has something to do with it.

Last edited by acalderon; 08-17-2009 at 12:22 AM. Reason: Issue solved. Look at reply #5
 
Old 08-14-2009, 09:19 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,441
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
Quote:
root (hd0,0)
Filesystem is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
[Linux-bzImage, setup=0x3000, size=0x16c910]
correct is
Quote:
root (hd0,0)
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
initrd /boot/initrd.img-2.6.26-2-686 <---------------- Note the initrd.image
[Linux-bzImage, setup=0x3000, size=0x16c910]
so boot to grub and press escape I think then you can go to comand line grub
then press o yeap the leter o this will let you add a line. then type. initrd /boot/initrd.img-2.6.26-2-686 push enter then press the letter b for boot.
now your system will start then go to as root /boot/grub/menu.1st and edit the file.
good luck

Last edited by Drakeo; 08-14-2009 at 09:20 PM.
 
Old 08-15-2009, 01:43 AM   #3
acalderon
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 1
It turned out to be the BIOS hard drive settings...

I have researched the issue for about two weeks or so. As I was reading about Grub on its website FAQs I got curious about the hard drive issues that they mentioned a lot. In particular I suspected my issue could be related to the size of the hard drive I installed Debian on. They mention a 8GB or 32GB hard drive size bug or something along those lines.

http://www.gnu.org/software/grub/gru...en.html#TOCq14

And something about BIOS issues as well.

http://www.gnu.org/software/grub/gru....en.html#TOCq2

It turned out to be the BIOS. I changed the hard drive interface setting of 32bit (or Bite, do not remember) IDE data rate compatibility interface from disabled to enabled. That allowed the kernel to load and boot.

The laptop has a SATA 2.5 hard drive. So the IDE compatibility setting allowed Grub to successfully communicate with the hard drive and do its thing. I believe that the Logical Block Address (LBA) and thus the 1024 cylinder problem may be the source of the cause.

AC

Last edited by acalderon; 08-15-2009 at 01:51 AM.
 
Old 08-15-2009, 11:11 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,441
Blog Entries: 3

Rep: Reputation: 182Reputation: 182
Quote:
It turned out to be the BIOS hard drive settings...
your machine posted bios. then looked for the mbr on your drive. there grub was loaded because it read your drives. then you selected your Linux OS or default selects it for you in about 10 seconds.
then after that read my first post.
So this is not a Bios issue or hard drive issue. or you would never get an error from grub.or the kernel to.
 
Old 08-17-2009, 12:15 AM   #5
acalderon
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 1
OK, I'm still looking into itn.

I turned the settings back off, and I was able to boot and load the OS.

I'm troubleshooting this some more.

Post back as soon as I get more info.
 
Old 08-17-2009, 12:21 AM   #6
acalderon
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 1
It was the path to my initrd and kernel

Quote:
Originally Posted by acalderon View Post
Code:
Booting 'Debian GNU/Linux, kernel 2.6.26-2-686'

root (hd0,0)
Filesystem is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
[Linux-bzImage, setup=0x3000, size=0x16c910]
Note on the entry below. The path to the actual initrd and kernel files is different. No "/boot" in the path.
Code:
Booting 'Debian GNU/Linux, kernel 2.6.26-2-686'

root (hd0,0)
Filesystem is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.26-2-686 root=/dev/sda1 ro quiet
[Linux-bzImage, setup=0x3000, size=0x16c910]
It looks like that was the issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot boot without kernel loaded singhshyam Linux - Kernel 2 02-01-2008 02:08 PM
F7 dvd boot - hangs after Loading initrd.img mwainwright Fedora 6 06-06-2007 12:28 PM
Dual processor machine hangs on boot richardthegreat Linux - Hardware 1 09-19-2005 02:58 AM
FC2 always reboot when initrd.img loaded detrox Fedora 2 11-01-2004 06:30 PM
Redhat hangs on boot when initrd should load brianinswfla Linux - General 2 05-10-2003 06:30 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration