LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 07-02-2007, 04:49 AM   #1
jagdishpandey
LQ Newbie
 
Registered: Jul 2007
Posts: 16

Rep: Reputation: 0
kernel panic - soft lockup detected


i have innstalled PCQuest linux 2006

after booting linux kernel it gives error:


kernel panic-not syncing:drivers/ide/pci/piix.c:232:spin-lock(drivers/ide/ide.c:c03de668) already locked by drivers/ide/ide-ops.c/1235(not tainted)

BUG: soft lockup detected on CPU#0!
 
Old 07-02-2007, 05:54 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

First: Please use a better title for your thread. kernel panic - soft lockup detected would have been much better.
Second: Do not use urgent. It's a reason for some to not even look at your thread. All people on this board answer threads voluntarily.

Ok, back to your question:

It looks like that there are 2 drivers 'fighting' for the same device. Try turning off one of the two. I think that you should turn off scsci emulation support.

BTW: pii points to an 'Intel chipset' and ide-ops.c points to 'scsi emulation support'

Hope this helps.

Last edited by druuna; 07-02-2007 at 07:31 AM. Reason: Fixed a typo
 
Old 07-02-2007, 06:08 AM   #3
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
It looks like that there are 2 drivers 'fighting' for the same device. Try turning of on of the two. I think that you should turn off scsci emulation support.
This what I'm saying depends on the kernel version in this case (which isn't clear to me as of now), but I'm pretty sure it uses a 2.6 kernel in which scsi-emulation is not needed anymore, and it's even recommended not to be used because it creates trouble Ok, it's not exactly what it says in the kernel config, but if it's rather new kernel, you can safely (and should) turn off SCSI emulation. In older kernels it was needed in some cases (such as getting IDE cd-rw drive to work, because programs wanted to use SCSI drives only), but nowadays it's not.

So...turn it off and see if that helps.
 
Old 07-02-2007, 06:58 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
I've changed the thread title, so that it reflects the contents of the thread.
 
Old 07-02-2007, 07:25 AM   #5
jagdishpandey
LQ Newbie
 
Registered: Jul 2007
Posts: 16

Original Poster
Rep: Reputation: 0
how to turn off SCSI emulation support while booting linux kernel 2.6.11

thanks for ur reply

i have one cdrom device and one dvd writer in my system;did it is the problem

but how do i turn off SCSI emulation support

Last edited by jagdishpandey; 07-02-2007 at 11:57 PM.
 
Old 07-03-2007, 04:49 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

I do assume that kernel 2.6.x is used and not 2.4.x (2.6 doesn't need scsi emulation, 2.4 does).

I'm not familiar with PCQuest linux (I cannot even find it in distrowatch). It could be that you can choose from different kernels. If that is not the case you probably need to re-compile the kernel yourself.

There is one other thing you could try before re-compiling, although I doubt if it would work: Add 2 specific entries to your grub config. These entries roughly look like this:

hdd=ide-scsi hde=ide-scsi

hdd should reflect your cd and/or hde your dvd.

The grub line you need to add this to looks something like this: kernel /boot/vmlinuz
If you are not sure what to put where, post your grub.conf file and the output of dmesg | grep hd.

After searching the net it seems that pcquest is a magazine, did it create its own linux distro or did it include another distro with its magazine? Maybe you should consider using a 'real' distro

Anyway, hope this gets you going again.
 
Old 07-10-2007, 12:36 PM   #7
jagdishpandey
LQ Newbie
 
Registered: Jul 2007
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks for ur support....but i try to experiment to rectify the problem

i have 2 h/d on primary IDE(IDE1) and one cd rom and a DVD WRITER ON OTHER IDE(IDE@).

i have Xp installed and it works but when i m trying to install PCQ linux 2006 or RHEL 4(kernel version 2.6.9.-34 EL) , it gives the error :

kernel panic-not syncing:drivers/ide/pci/piix.c:232:spin-lock(drivers/ide/ide.c:c03de668) already locked by drivers/ide/ide-ops.c/1235(not tainted)

BUG: soft lockup detected on CPU#0!


---------------------------------------------------------------------
now i removed second h/d and then install RHEL 4(kernel version 2.6.9.-34 EL)
i have successfully installed RHEL4 on my PC.


it all works..after that i attached my second harddisk


then booting on linux it gives


kernel panic-not syncing:drivers/ide/pci/piix.c:232:spin-lock(drivers/ide/ide.c:c03de668) already locked by drivers/ide/ide-ops.c/1235(not tainted)

BUG: soft lockup detected on CPU#0!


However i also have windows xp os installed on the m/c but it works fine ..with no problem

Last edited by jagdishpandey; 07-10-2007 at 12:45 PM.
 
Old 07-10-2007, 10:47 PM   #8
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,378

Rep: Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108
Whoa...! That's an amazing number of fonts and colors!

Start with the basics: recompile your entire kernel from scratch ("make clean") after checking that all of your configuration options are actually appropriate to your hardware. . .

If the configuration is "nonsense," and/or incorrectly-built, then the resultant behavior of that configuration is going to be ... "nonsense." And you simply must not waste too much time 'rationalizing' nonsense.
 
Old 07-11-2007, 02:05 AM   #9
jagdishpandey
LQ Newbie
 
Registered: Jul 2007
Posts: 16

Original Poster
Rep: Reputation: 0
But i m new bee

thanks but how do i recompile kernel from scratch to match my hardware configuration
 
Old 07-11-2007, 05:25 AM   #10
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Hi,

Maybe this will help: PCQuest Forums -> kernel panic - Resolved

If that works, no kernel re-compiling is needed.

PS: The PCQuest Forums seem to be a good source for PCQuest/PCLinux related questions

Hope this helps.
 
Old 07-16-2007, 12:20 AM   #11
jagdishpandey
LQ Newbie
 
Registered: Jul 2007
Posts: 16

Original Poster
Rep: Reputation: 0
kernel panic

Thanks Draunna
it works;now problem is solved;it's a dma conflict; i append boot parameters as well as in config. file
thx very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"BUG: soft lockup detected on CPU#0!" while installing 7.04 Ubuntu on Clevo m590k blue_sphere Linux - Laptop and Netbook 1 04-21-2007 12:10 AM
Kernel soft lockups detected in dmesg. xushi Linux - Hardware 0 12-03-2006 05:21 AM
BUG: soft lockup detected on CPU#0 and BUG: spinlock recursion on CPU#0 ... BloodyCat Linux - Hardware 3 11-07-2006 01:14 PM
bug:soft lockup detected on cpu#0! paraiso Linux - General 2 01-29-2006 05:42 AM
BUG: Soft lockup detected on CPU#0! 97tbird Linux - General 0 11-03-2005 02:12 PM


All times are GMT -5. The time now is 07:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration