LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 04-14-2005, 03:17 PM   #1
potsilui
LQ Newbie
 
Registered: Apr 2005
Distribution: Fedora Core 3
Posts: 11

Rep: Reputation: 0
Unhappy Kernel panic - not syncing: Attempted to kill init!


Did the usual up2date thing and then rebooted. System now stops with message:

exec of init (/sbin/init) failed!!! : 2
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

Don't know where to start. Really need step by step as I am not a hacker.

Thanks for help.
 
Old 04-14-2005, 08:39 PM   #2
nonzero
Member
 
Registered: Feb 2005
Distribution: Debian FC4 LFS Slackware
Posts: 174

Rep: Reputation: 31
At the grub boot screen did you try to load your previous kernel? When the menu
shows, hit any key and the boot sequence freezes allowing you to choose a previous kernel version.

nz
 
Old 04-14-2005, 10:31 PM   #3
potsilui
LQ Newbie
 
Registered: Apr 2005
Distribution: Fedora Core 3
Posts: 11

Original Poster
Rep: Reputation: 0
There's about four previous kernels and I've tried all of them with the same results. I am looking at the /var/log/messages file but I don't know what to look for. I can email it to anyone who might want to decipher it.
 
Old 07-05-2007, 05:40 PM   #4
toastboy
LQ Newbie
 
Registered: Jul 2007
Posts: 1

Rep: Reputation: 0
I know this is an old thread, but I'm posting here because this page was the first hit on Google when I started looking for a solution to the same problem myself:

Trying to install Ubuntu Feisty x64, I got this same error. Tried Debian Etch too, both of them known good install DVDs, with no joy. Same error. It turns out the problem is bad RAM. Windows limped along (I wondered why it had been so slow and flaky) on this machine, but it seems Linux (or at least the installer) is more sensitive to bad memory.

Boot into the Ubuntu installer - or any other Live distro installer - and choose memtest86. Most likely it will start showing failures very quickly. Then it's just a case of the settling down to the long task of trying the system with each stick of RAM in turn removed. Be careful to use an anti-static wrist strap when handing the RAM.

Good luck!
 
Old 01-24-2008, 11:17 AM   #5
aaabbbccc
LQ Newbie
 
Registered: Jan 2008
Posts: 2

Rep: Reputation: 0
Bios

Sorry, my english is very bad.

I had same problem.

I update BIOS and Linux work OK.
 
Old 01-24-2008, 11:19 AM   #6
aaabbbccc
LQ Newbie
 
Registered: Jan 2008
Posts: 2

Rep: Reputation: 0
Bios

Sorry, my english is very bad.

I had same problem.

I update BIOS and Linux work OK.
(My motherboard is MSI Neo2 platinum 915G/P)
 
Old 02-15-2008, 07:15 PM   #7
a3kEgxuK
LQ Newbie
 
Registered: Feb 2008
Posts: 1

Rep: Reputation: 0
Bad RAM was my cause

I was getting this error ("Kernel panic - not syncing") when I was duplicating a 40GB h/d (dd if=/dev/hda of=/dev/hdb bs=11182080).

In my case the cause was a bad RAM stick.

Last edited by a3kEgxuK; 02-15-2008 at 07:23 PM. Reason: Clarify which error I was getting
 
Old 05-26-2008, 02:42 AM   #8
lightwave
Member
 
Registered: Oct 2005
Distribution: Suse, Debian
Posts: 44

Rep: Reputation: 15
'kernel panic - not syncing'

Quote:
Originally Posted by a3kEgxuK View Post
I was getting this error ("Kernel panic - not syncing") when I was duplicating a 40GB h/d (dd if=/dev/hda of=/dev/hdb bs=11182080).

In my case the cause was a bad RAM stick.
I can also testify it is a bad memory module, seemingly.
Since, I do not have the error with all other memory.
Very strange indeed, since I believe it is good. It seems that the kernel itself is not liking it.

Last edited by lightwave; 12-13-2008 at 12:22 AM.
 
Old 05-30-2008, 07:08 AM   #9
jayjwa
Member
 
Registered: Jul 2003
Location: NY
Distribution: None (src & compile)
Posts: 253

Rep: Reputation: 36
Can we make this a sticky topic? That's the 10-kazillionth time I've seen this. Kernel panic - not syncing: Attempted to kill init! <smiley of head smashing against wall repeatedly>
 
Old 10-22-2008, 02:55 AM   #10
dubtek
LQ Newbie
 
Registered: Mar 2005
Location: Spring Lake, Michigan
Distribution: SUSE
Posts: 1

Rep: Reputation: 0
Cool Kernel Panic - reset bios

I had no problem running System Rescue CD, but a custom distribution of Linux would give me the kernel panic error. Thanks to this thread I knew it had to be a ram problem. I just reset my memory settings in the bios, all to defaults, and disabled any caching of video and bios to ram. It started right up.
 
Old 10-23-2008, 02:48 PM   #11
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,278

Rep: Reputation: 1088Reputation: 1088Reputation: 1088Reputation: 1088Reputation: 1088Reputation: 1088Reputation: 1088Reputation: 1088
Yes, this should be a "sticky topic."

The most-important thing to realize about this message is... what it is actually saying. (It's all "geek speak," so bear with me.)

(0) A "kernel panic" happens when the kernel realizes that it is hopeless to continue. (If that happened to you, well, "you'd panic too.")

(1) When Linux starts, it automagically creates one process. That's "process #1," and its name is init. I don't need to explain here all of the things that init (and "init" alone...) does: the important thing to know is, "init" is not allowed to die.

(1a) If "init" does die, for whatever reason, the message given is deceptive: it says that someone "attempted to kill 'init,'" when the actual truth is just that "'init' died."

(2) The computer does a lot of disk-I/O activity "in the background." So, there's a tiny amount of time that passes between a request to write something to the disk, and the point in time when that disk-write is physically complete. Bottom line is... "not syncing" is good, and "syncing" means that you just scribbled your disk. Don't ask me why.

(3) The real problem that you need to actually be concerned about is described in the messages that precede this one. Not "this one!"

Yep... "let it be 'sticky.'"
 
Old 12-12-2008, 01:48 PM   #12
mfontz
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Exclamation Kernel Panic

I downloaded linux-2.6.27.8 fm kernel.org and did the make menuconfig (took defaults there), make, make modules, make modules_install, make install. After reboot, got the same kernel panic - not syncing: Attempted to kill init! message. I am able to boot with my old kernel without problems so hw might not an issue for me. The error I get before that is:
VolGroup00 using metadata type LVM2
/dev/hdcpen failed: no medium found

Last edited by mfontz; 12-12-2008 at 02:10 PM.
 
Old 12-12-2008, 02:45 PM   #13
ksudeadeye
LQ Newbie
 
Registered: Dec 2008
Posts: 6

Rep: Reputation: 0
Same Issue

Quote:
Originally Posted by mfontz View Post
I downloaded linux-2.6.27.8 fm kernel.org and did the make menuconfig (took defaults there), make, make modules, make modules_install, make install. After reboot, got the same kernel panic - not syncing: Attempted to kill init! message. I am able to boot with my old kernel without problems so hw might not an issue for me. The error I get before that is:
VolGroup00 using metadata type LVM2
/dev/hdcpen failed: no medium found
I'm having the same issue with the new kernel. I'm going to roll back to 2.6.26.8, see if that helps.
 
Old 12-12-2008, 03:09 PM   #14
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by ksudeadeye View Post
I'm having the same issue with the new kernel. I'm going to roll back to 2.6.26.8, see if that helps.
If you actually saw a reference to /dev/hd?, you may need to update your /etc/fstab: the newer kernels often use the "combined Serial/Parallel device driver" which names hard drives as /dev/sd? rather than /dev/hd?.

A better choice in /etc/fstab is to use the LABEL= or UUID= form to identify partitions. (The values to put after the "=" can be found by a ls -l /dev/disk/by-label or ls -l /dev/disk/by-uuid. (An added advantage of using the LABEL= or UUID= form is that your system doesn't "barf" when you play with your drive cables, which you sometimes need to do when a cable fails or you add a new drive od other device.)

Last edited by PTrenholme; 12-12-2008 at 03:11 PM.
 
Old 12-13-2008, 12:19 AM   #15
lightwave
Member
 
Registered: Oct 2005
Distribution: Suse, Debian
Posts: 44

Rep: Reputation: 15
Post same topic

Often when the OS will panic, for whatever reason. It appears to start to "kill" processes. What processes it kills may be random (even some system) hence the reasoning behind the fact that some of these issues seem unrelated and leads a little to the illusive-ness of the issue that caused problems for users , in this thread and others.
As I stated previously, my issue was bad hardware which was a drive in my case. My problem hasn't been experienced since a replacement 9 months or so now.

I believe it to be somewhat misleading when someone will say that they have defined the definitive problem and want then to 'retire' the topic. Clearly the issue still affects people out there...
 
  


Reply

Tags
kernel, panic


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Explained: "kernel panic - not syncing - attempted to kill init" sundialsvcs Linux - Software 36 04-24-2010 08:58 AM
Kernel Panic -- not syncing: attempted to kill idle task oraclerg Linux - Distributions 15 02-03-2010 03:36 AM
Kernel Panic - Not Syncing: Attempted To Kill Init! tegralens Linux - Software 13 06-23-2008 03:15 PM
kernel panic - not syncing: Attempted to kill init! k5knt Linux - General 39 07-18-2007 12:47 AM
Updated = Kernel panic - not syncing: Attempted to kill init! potsilui Fedora 4 04-18-2005 03:02 PM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration