LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 04-25-2006, 05:03 PM   #1
bong.mau
Member
 
Registered: Apr 2004
Posts: 290

Rep: Reputation: 30
kernel & aalsa drivers


Hi
i need to know wich kernel has the alsa drivers at level >=1.0.10
and wich are distros with the above kernel
currently i'm using mandriva with kernel 2.6.12 and alsa drivers are at 1.0.9b
thanks in advance
Maurizio
 
Old 04-25-2006, 05:27 PM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,973

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
The 2.6.16.8 kernel that I'm running uses ALSA v1.0.11rc2
 
Old 04-25-2006, 06:42 PM   #3
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
If I do a new kernel build, will I need to re-install the alsa driver and libaries again?

I started a 2.6.16.11 build when I left the house this morning.

Peace...
 
Old 04-26-2006, 02:50 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,973

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Quote:
If I do a new kernel build, will I need to re-install the alsa driver and libaries again?
From ALSA documentation:
Quote:
> Some queries about the latest 2.6 kernels...
>
> I presume the "alsa" part that comes with a 2.6 kernel is only
> the equiv of the alsa-driver package so do I still need to get
> alsa-lib and alsa-utils from somewhere else ?

Yes, from our main site - http://www.alsa-project.org .


> If so, then do I have to determine which particular version is
> in the kernel and then source the same versioned lib/utils packages ?

Version is available in linux/include/sound/version.h
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.9 kernel & ltmodem drivers done Linux - Hardware 4 01-10-2005 10:02 AM
latest RH9 kernel & wlan-ng drivers robson8112 Linux - Wireless Networking 0 02-21-2004 12:24 PM
Slackware 9.1 w/ 2.6.2 kernel & nvidia drivers - need assistance r_jensen11 Linux - Hardware 8 02-11-2004 08:40 PM
Kernel 2.6.1 & NVIDIA drivers mrt198 Linux - Hardware 0 02-08-2004 01:34 PM
NVIDIA drivers & kernel 2.6.1 [slack9.1] darklogik_org Slackware 4 01-25-2004 01:17 PM


All times are GMT -5. The time now is 01:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration