LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   installing gcc (http://www.linuxquestions.org/questions/linux-kernel-70/installing-gcc-825603/)

apeto 08-11-2010 02:06 PM

installing gcc
 
Hi, I'm having some problems installing gcc on a Fedora 13 system.
Te response to the command is:
[root@ns310181 local]# yum install gcc
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.4-10.fc13 set to be installed
--> Processing Dependency: cpp = 4.4.4-10.fc13 for package: gcc-4.4.4-10.fc13.x86_64
--> Processing Dependency: libgomp = 4.4.4-10.fc13 for package: gcc-4.4.4-10.fc13.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.4-10.fc13.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.4-10.fc13.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc-4.4.4-10.fc13.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.fc12 set to be installed
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.fc12.x86_64
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.fc12.x86_64
---> Package cpp.x86_64 0:4.4.4-10.fc13 set to be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.4-10.fc13.x86_64
---> Package glibc-devel.x86_64 0:2.12-3 set to be installed
--> Processing Dependency: glibc-headers = 2.12-3 for package: glibc-devel-2.12-3.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-3.x86_64
---> Package libgomp.x86_64 0:4.4.4-10.fc13 set to be installed
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.12-3 set to be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-3.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-3.x86_64
---> Package mpfr.x86_64 0:2.4.2-1.fc13 set to be installed
---> Package ppl.x86_64 0:0.10.2-10.fc12 set to be installed
--> Finished Dependency Resolution
Error: Package: glibc-headers-2.12-3.x86_64 (updates)
Requires: kernel-headers >= 2.2.1
Error: Package: glibc-headers-2.12-3.x86_64 (updates)
Requires: kernel-headers
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


I couldn't either install the kernel-devel for that version so a tryed other version with rpm and I think I messed up.

Running yum -v info kernel-devel gets me:
Config time: 0.008
Yum Version: 3.2.28
Setting up Package Sacks
pkgsack time: 0.065
rpmdb time: 0.000
Installed Packages
Name : kernel-devel
Arch : x86_64
Version : 2.6.33.6
Release : 147.2.4.fc13
Size : 22 M
Repo : installed
Committer : Chuck Ebbert <cebbert@redhat.com>
Committime : Fri Jul 23 14:00:00 2010
Buildtime : Fri Jul 23 19:29:21 2010
Install time: Wed Aug 11 18:08:58 2010
Installed by: System <unset>
Changed by : System <unset>
Summary : Development package for building kernel modules to match the kernel
URL : http://www.kernel.org/
License : GPLv2
Description : This package provides kernel headers and makefiles sufficient to build modules
: against the kernel package.

but running uname -r gets me:
2.6.33.5-xxxx-grs-ipv4-64
See the difference in verssion ???
Some mess I did here.
Can anybody help me with his ?
Thanks
Albert

John VV 08-11-2010 10:29 PM

--------edit---------


All times are GMT -5. The time now is 12:02 PM.