LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Gentoo, LUKS, LVM - kernel panic - not syncing /init not found (http://www.linuxquestions.org/questions/linux-kernel-70/gentoo-luks-lvm-kernel-panic-not-syncing-init-not-found-838598/)

mechman422 10-17-2010 03:55 AM

Gentoo, LUKS, LVM - kernel panic - not syncing /init not found
 
I have been setting up a fresh install of gentoo, using ubuntu live cd 10.04, and have run into a snag. Upon boot I receive the dreaded "kernel panic - not syncing /init not found" along with a hard freeze.

First off my setup:

/dev/sda1 - (boot 100MB) [using grub in MBR]
/dev/sda2 - sda2crypt (LV encrypted w/ LUKS)
15G root (mechvg-root)
4G swap (mechvg-swap)
~675G home (mechvg-home)

The new system is installed correctly and can be chroot'ed with full function from within the live CD i am using.

I am hypothesizing the kernel cannot find /init because it is located on the encrypted LV and the system has not prompted for the pass phrase yet.

The kernel has been compiled with all the required components / modules (dm, lvm2, cryptsetup, aes-cbc-essiv:sha256), and I am experimenting with utilizing a 'kernel embedded' initramfs (I did receive the same error with a separate file also, though)

I have tried passing the init through the grub line but I do not know exactly where the init should be located at. (the RAM due to the temporary mount???)

Anyone have any ideas / suggestions? I have tried multiple solutions found in various forums / google'ing with no luck.

Code:

grub.conf

default 0
timeout 30

title=Cryp2 2.6.34-r6
root (hd0,0)
kernel /bzImage

title Cryp2rescue 2.6.34-r6
root (hd0,0)
kernel /bzImage init=/bin/busybox --install -s

# vim:ft=conf:

Code:

inittab
#
# /etc/inittab:  This file describes how the INIT process should set up
#                the system in a certain run-level.
#
# Author:  Miquel van Smoorenburg, <miquels@cistron.nl>
# Modified by:  Patrick J. Volkerding, <volkerdi@ftp.cdrom.com>
# Modified by:  Daniel Robbins, <drobbins@gentoo.org>
# Modified by:  Martin Schlemmer, <azarah@gentoo.org>
# Modified by:  Mike Frysinger, <vapier@gentoo.org>
# Modified by:  Robin H. Johnson, <robbat2@gentoo.org>
#
# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/files/inittab-2.87,v 1.1 2010/01/08 16:55:07 williamh Exp $

# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/rc sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/rc boot

l0:0:wait:/sbin/rc shutdown
l0s:0:wait:/sbin/halt -dhp
l1:1:wait:/sbin/rc single
l2:2:wait:/sbin/rc nonetwork
l3:3:wait:/sbin/rc default
l4:4:wait:/sbin/rc default
l5:5:wait:/sbin/rc default
l6:6:wait:/sbin/rc reboot
l6r:6:wait:/sbin/reboot -dk
#z6:6:respawn:/sbin/sulogin

# new-style single-user
su0:S:wait:/sbin/rc single
su1:S:wait:/sbin/sulogin

# TERMINALS
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux

# SERIAL CONSOLES
#s0:12345:respawn:/sbin/agetty 9600 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty 9600 ttyS1 vt100

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh

Code:

device.map
(hd0)    /dev/sda

Code:

init
#!/bin/busybox sh
mount -t proc proc /proc
CMDLINE='cat /proc/cmdline'
mount -t sysfs sysfs /sys
sleep 3
loadkmap < /etc/kmap-en
/bin/cryptsetup luksOpen /dev/sda2 sda2crypt
/bin/vgchange -ay mechvg
mount -r /dev/mapper/mechvg-root /newroot
umount /sys
umount /proc
exec /bin/busybox switch_root /newroot /sbin/init ${CMDLINE}


mechman422 10-23-2010 02:15 AM

Finally got it working, FYI for anyone else having this issue...

After two weeks of fussing I stumbled across this guide;

http://nuno-sousa-corner.blogspot.co...s-and-lvm.html

This was the first guide that meantioned the need to edit '/etc/genkernel.conf' in order to enable luks and lvm apparently just enabling them with menuconfig is only part of the process.


All times are GMT -5. The time now is 07:45 PM.