LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 09-18-2009, 01:28 AM   #1
teraghavendragoud
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
Thumbs up error: #error Your version of gcc miscompiles the __weak directive


Hi
I am using RHEL 5 with Kernel version of 2.6.18 and gcc version 4.1.1 20070105 . I am getting the error like

error: #error Your version of gcc miscompiles the __weak directive

while I was trying to compile a code 2.6.30 code on same machine.

how can I over come this problem to get full compilation new kernel.
 
Old 09-18-2009, 07:27 PM   #2
jhwilliams
Senior Member
 
Registered: Apr 2007
Location: Portland, OR
Distribution: Debian, Android, LFS
Posts: 1,168

Rep: Reputation: 207Reputation: 207Reputation: 207
Give gcc 4.3 a try.
 
Old 09-19-2009, 08:22 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,668

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# yum install gcc43
.. which provides version 4.3.2-7.el5.

Example command using gcc-4.3.2 :
'make CC=gcc43'
 
  


Reply

Tags
el5


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
one more error building GCC - related with the newer version of Glibc?? lfs63 Linux From Scratch 1 02-17-2008 09:20 AM
[current] stdin: error: invalid preprocessing directive #xterm dive Slackware 2 03-25-2007 04:27 PM
gmake error or gcc old version......??? pravinth Linux - Newbie 2 11-23-2006 10:43 AM
in gcc compiler error: parse error before string constsnt cynthia_thomas Linux - Networking 1 10-20-2005 01:29 AM
Error due to old version of gcc (probably) tandre Programming 4 04-13-2005 11:01 AM


All times are GMT -5. The time now is 07:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration