Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Linux - Kernel This forum is for all discussion relating to the Linux kernel.


  Search this Thread
Old 01-24-2009, 01:36 AM   #1
LQ Newbie
Registered: Jan 2009
Location: Alturas, California
Distribution: kubuntu 11.04
Posts: 21

Rep: Reputation: 0
Device-mapper missing from kernel

I'm running Kubuntu Intrepid 8.10 with kde-4.1.96 kernal-2.6.27-9

ivtv at first look, it's good, drivers in place but when I run KMPlayer or Tvtime I have no picture or invalid argument. Media programs can't find /dev/video0, even though it does exist, I've prove it with cat /dev/video0 > test.mpg

So I think it stem back to the kernel and io control, so that other programs that need the device can have access.

Maybe a new update will fix the problem?

Message from the KERNEL
xxxx@linux-007:~$ dmsetup info /dev/video0
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
Incompatible libdevmapper 1.02.27 (2008-06-25)(compat) and kernel driver
Command failed

Last edited by jazpaisley; 01-24-2009 at 01:38 AM.
Old 07-26-2010, 01:09 PM   #2
Registered: Jan 2010
Location: Minnesota, USA
Distribution: Slackware 13.37
Posts: 284

Rep: Reputation: 54

The messages "/proc/misc" and "Is kernel missing device-mapper" are identical to those we get from Lilo.

I do not see how you are invoking Lilo, but then where could that message come from that would be in common with Lilo error messages ?

This is 2010 and we are still getting the same message from them.
It seems that the device-mapper was made optional sometime in the 2.6 development line, and Lilo has not changed to cope with it not being there. I have the same bug, and from what I can find in the docs, the device mapper only is necessary if there is a RAID or LVM remapping of the logical block to physical drive/block addressing which Lilo could never figure out itself. Normal drives Lilo was always able to figure out itself.
In my opinion this is a Lilo bug.
I have not seen my Lilo fail yet so I assume that it does something

Last edited by selfprogrammed; 07-26-2010 at 01:16 PM.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom kernel - lilo complains device-mapper missing donni Linux - Software 3 07-26-2010 01:47 PM
mkrescue Fatal: device-mapper: only linear boot device supported Molly Slackware 5 01-06-2009 05:35 PM
unable to find device-mapper major/minor? help!!!!! can't boot up! kernel panic! newtovanilla Linux - Newbie 5 11-23-2008 03:39 PM
trying to install/boot 2.6.15 kernel - device mapper error jmike1 Linux - Software 2 03-15-2006 10:49 PM
LVM problems, device-mapper missing dworkin Linux - Newbie 3 03-22-2004 05:54 PM

All times are GMT -5. The time now is 11:36 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration