LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
LinkBack Search this Thread
Old 07-18-2010, 12:13 PM   #1
hevi
LQ Newbie
 
Registered: Jun 2004
Location: Surabaya, Indonesia
Distribution: Slackware64
Posts: 7

Rep: Reputation: 1
compiling mousedev as module


Hi,

I tried to using Genius MousePen 8x6 with wizardpen driver in Slackware64 13.1. The driver works but the cursor always refers to top-left corner on the screen. After googling, some people suggested that I don't use /dev/input/mice because all of pointers (mouse, tablet, etc) will be mapped to it. Based on those suggestions, I tried to recompiled kernel (2.6.34.1) after changing CONFIG_INPUT_MOUSE from 'y' to 'm' manually because I could not change it using "make menuconfig" or "make xconfig". I need mousedev as module so that I can unload it when I use the tablet. However, when I compiled the kernel using "make bzImage", CONFIG_INPUT_MOUSE is always changed automatically to 'y' again.

How to change CONFIG_INPUT_MOUSE to 'm' permanently?
Thank you in advanced.

Regards,
Henry.
 
Old 07-21-2010, 11:40 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,363
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
have you tried rmmod psmouse and modprobe tablet
that said this is why it is mapped to input device mice.
you have to uncheck input
Quote:
#
# Userland interfaces <<<<<<<<<<---------- user creates devices
#
CONFIG_INPUT_MOUSEDEV=y
CONFIG_INPUT_MOUSEDEV_PSAUX=y
This will allow you to set this
Quote:
# Input Device Drivers <<<<<<,,------ note drivers
#
CONFIG_INPUT_KEYBOARD=y
CONFIG_KEYBOARD_ADP5588=m
CONFIG_KEYBOARD_ATKBD=y
CONFIG_QT2160=m
# CONFIG_KEYBOARD_LKKBD is not set
CONFIG_KEYBOARD_GPIO=m
CONFIG_KEYBOARD_MATRIX=m
CONFIG_KEYBOARD_LM8323=m
CONFIG_KEYBOARD_MAX7359=m
# CONFIG_KEYBOARD_NEWTON is not set
CONFIG_KEYBOARD_OPENCORES=m
CONFIG_KEYBOARD_STOWAWAY=m
# CONFIG_KEYBOARD_SUNKBD is not set
# CONFIG_KEYBOARD_XTKBD is not set
CONFIG_INPUT_MOUSE=y
CONFIG_MOUSE_PS2=m
the configuration program will not let you do it any other way.
the default way the kernel make the device input and loads the module.

Last edited by Drakeo; 07-22-2010 at 12:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling a module separately without compiling entire kernel kushalkoolwal Linux - Kernel 8 08-06-2008 01:45 AM
Invalid module error after compiling Acronis module cryogenica Linux - General 2 03-17-2008 04:23 PM
Use of MODULE macro while compiling a module fssengg Linux - Newbie 0 03-31-2006 07:13 AM
modprobe:Can't locate module mousedev petarsabev Slackware 7 10-13-2003 12:22 AM
Modprobe: Can't locate module mousedev (gentoo) amphibious Linux - Newbie 1 09-26-2003 02:18 AM


All times are GMT -5. The time now is 11:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration